FAQ
Hi, (reposted to provide more meaningful subject)
I got the error shown below when i run startup.bat. Seems to have 2 main
error here:
1. Tomcat not able to find the library that allows optimal performance in
production environment.
2. There is a Permission Denied while trying to initialize endpoint.

Currently using:
Microsoft Vista
jdk1.6.0_10 (tried jdk1.5.16 also does not work)
tomcat 6.0.18

What I have tried:
* has disabled the firewall
* start the DOS session as administrator
* change the port number 8080 in server.xml to 8383.

Run out of ideas on how to solve it...so any help will be much appreciated.

Regards,
yclim

06-Aug-08 PM 12:02 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal
performanc
e in production environments was not found on the java.library.path:
C:\Program
Files\Java\jre1.6.0\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows
;C:\oraclexe\app\oracle\product\10.2.0\server\bin;C:\Windows\system32;C:\Windows
;C:\Windows\System32\Wbem;C:\PROGRA~1\COMMON~1\ULEADS~1\MPEG;C:\Program
Files\No
rman\Npm\Bin;C:\Program Files\jEdit;C:\Program Files\QuickTime\QTSystem\
06-Aug-08 PM 12:02 org.apache.coyote.http11.Http11Protocol init
SEVERE: Error initializing endpoint
java.net.SocketException: Permission denied: listen failed
at java.net.PlainSocketImpl.socketListen(Native Method)
at java.net.PlainSocketImpl.listen(Unknown Source)
at java.net.ServerSocket.bind(Unknown Source)
at java.net.ServerSocket.<init>(Unknown Source)
at java.net.ServerSocket.<init>(Unknown Source)
at
org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(De
faultServerSocketFactory.java:50)
at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:496)
at
org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:176)
at
org.apache.catalina.connector.Connector.initialize(Connector.java:105
8)
at
org.apache.catalina.core.StandardService.initialize(StandardService.j
ava:677)
at
org.apache.catalina.core.StandardServer.initialize(StandardServer.jav
a:795)
at org.apache.catalina.startup.Catalina.load(Catalina.java:530)
at org.apache.catalina.startup.Catalina.load(Catalina.java:550)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:412)
06-Aug-08 PM 12:02 org.apache.catalina.startup.Catalina load
SEVERE: Catalina.start
LifecycleException: Protocol handler initialization failed:
java.net.SocketExce
ption: Permission denied: listen failed
at
org.apache.catalina.connector.Connector.initialize(Connector.java:106
0)
at
org.apache.catalina.core.StandardService.initialize(StandardService.j
ava:677)
at
org.apache.catalina.core.StandardServer.initialize(StandardServer.jav
a:795)
at org.apache.catalina.startup.Catalina.load(Catalina.java:530)
at org.apache.catalina.startup.Catalina.load(Catalina.java:550)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:412)
06-Aug-08 PM 12:02 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 904 ms
06-Aug-08 PM 12:02 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
06-Aug-08 PM 12:02 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
06-Aug-08 PM 12:02 org.apache.coyote.http11.Http11Protocol start
SEVERE: Error starting endpoint
java.net.SocketException: Permission denied: listen failed
at java.net.PlainSocketImpl.socketListen(Native Method)
at java.net.PlainSocketImpl.listen(Unknown Source)
at java.net.ServerSocket.bind(Unknown Source)
at java.net.ServerSocket.<init>(Unknown Source)
at java.net.ServerSocket.<init>(Unknown Source)
at
org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(De
faultServerSocketFactory.java:50)
at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:496)
at
org.apache.tomcat.util.net.JIoEndpoint.start(JIoEndpoint.java:519)
at
org.apache.coyote.http11.Http11Protocol.start(Http11Protocol.java:203
)
at
org.apache.catalina.connector.Connector.start(Connector.java:1131)
at
org.apache.catalina.core.StandardService.start(StandardService.java:5
31)
at
org.apache.catalina.core.StandardServer.start(StandardServer.java:710
)
at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
06-Aug-08 PM 12:02 org.apache.catalina.startup.Catalina start
SEVERE: Catalina.start:
LifecycleException: service.getName(): "Catalina"; Protocol handler start
fail
ed: java.net.SocketException: Permission denied: listen failed
at
org.apache.catalina.connector.Connector.start(Connector.java:1138)
at
org.apache.catalina.core.StandardService.start(StandardService.java:5
31)
at
org.apache.catalina.core.StandardServer.start(StandardServer.java:710
)
at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
06-Aug-08 PM 12:02 org.apache.catalina.startup.Catalina start
INFO: Server startup in 1501 ms

Search Discussions

  • Mladen Turk at Aug 6, 2008 at 7:23 am

    Charles Lim wrote:
    Hi, (reposted to provide more meaningful subject)
    I got the error shown below when i run startup.bat. Seems to have 2 main
    error here:
    1. Tomcat not able to find the library that allows optimal performance in
    production environment.
    This not an error. It's an [info] that you are not using
    tcnative-1.dll
    2. There is a Permission Denied while trying to initialize endpoint.

    Currently using:
    Microsoft Vista
    jdk1.6.0_10 (tried jdk1.5.16 also does not work)
    tomcat 6.0.18

    What I have tried:
    * has disabled the firewall
    * start the DOS session as administrator
    * change the port number 8080 in server.xml to 8383.
    There has to be some security permission missing.
    Run the cmd.exe, type
    netstat -ab -p tcp
    and see if the ports are used.

    Regards
    --
    ^(TM)

    ---------------------------------------------------------------------
    To start a new topic, e-mail: users@tomcat.apache.org
    To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
    For additional commands, e-mail: users-help@tomcat.apache.org
  • Charles Lim at Aug 6, 2008 at 7:32 am
    Below is the result after running netstat...both port 8080 and 8383 do not
    seem to be used.

    C:\Programs2\apache-tomcat-6.0.18\bin>netstat -ab -p tcp

    Active Connections

    Proto Local Address Foreign Address State
    TCP 0.0.0.0:135 Charles-PC:0 LISTENING
    RpcSs
    [svchost.exe]
    TCP 0.0.0.0:2868 Charles-PC:0 LISTENING
    [NJEEVES.EXE]
    TCP 0.0.0.0:49152 Charles-PC:0 LISTENING
    [wininit.exe]
    TCP 0.0.0.0:49153 Charles-PC:0 LISTENING
    Eventlog
    [svchost.exe]
    TCP 0.0.0.0:49154 Charles-PC:0 LISTENING
    [lsass.exe]
    TCP 0.0.0.0:49155 Charles-PC:0 LISTENING
    Schedule
    [svchost.exe]
    TCP 121.7.111.75:139 Charles-PC:0 LISTENING

    Can not obtain ownership information

    x: Windows Sockets initialization failed: 5
    TCP 121.7.111.75:55032 wf-in-f189:https ESTABLISHED
    [iexplore.exe]
    TCP 121.7.111.75:55295 cf-in-f18:https ESTABLISHED
    [iexplore.exe]
    TCP 121.7.111.75:55296 cf-in-f18:https ESTABLISHED
    [iexplore.exe]
    TCP 127.0.0.1:2868 Charles-PC:55285 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55286 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55287 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55289 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55290 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55291 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55293 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55294 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55298 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55300 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55301 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55302 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55303 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55304 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55305 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55306 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55307 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55308 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55309 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55310 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55311 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55312 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55313 TIME_WAIT
    TCP 127.0.0.1:2868 Charles-PC:55314 TIME_WAIT
    TCP 127.0.0.1:27015 Charles-PC:0 LISTENING
    [AppleMobileDeviceService.exe]
    TCP 127.0.0.1:27015 Charles-PC:54555 ESTABLISHED
    [AppleMobileDeviceService.exe]
    TCP 127.0.0.1:54554 Charles-PC:0 LISTENING
    [javaw.exe]
    TCP 127.0.0.1:54555 Charles-PC:27015 ESTABLISHED
    [iTunesHelper.exe]

    C:\Programs2\apache-tomcat-6.0.18\bin>
    On Wed, Aug 6, 2008 at 3:20 PM, Mladen Turk wrote:

    Charles Lim wrote:
    Hi, (reposted to provide more meaningful subject)
    I got the error shown below when i run startup.bat. Seems to have 2 main
    error here:
    1. Tomcat not able to find the library that allows optimal performance in
    production environment.
    This not an error. It's an [info] that you are not using
    tcnative-1.dll

    2. There is a Permission Denied while trying to initialize endpoint.
    Currently using:
    Microsoft Vista
    jdk1.6.0_10 (tried jdk1.5.16 also does not work)
    tomcat 6.0.18

    What I have tried:
    * has disabled the firewall
    * start the DOS session as administrator
    * change the port number 8080 in server.xml to 8383.
    There has to be some security permission missing.
    Run the cmd.exe, type
    netstat -ab -p tcp
    and see if the ports are used.

    Regards
    --
    ^(TM)

    ---------------------------------------------------------------------
    To start a new topic, e-mail: users@tomcat.apache.org
    To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
    For additional commands, e-mail: users-help@tomcat.apache.org
  • Mladen Turk at Aug 6, 2008 at 8:12 am

    Charles Lim wrote:
    Below is the result after running netstat...both port 8080 and 8383 do not
    seem to be used.

    C:\Programs2\apache-tomcat-6.0.18\bin>netstat -ab -p tcp

    Active Connections
    Seems the ports are not used.
    So you should try some simple program
    Download openssl.exe from
    http://www.apache.org/dist/tomcat/tomcat-connectors/native/1.1.14/binaries/win32/
    openssl.exe -nocert -accept 8080
    If that's not fine you have some security problems.

    Regards
    --
    ^(TM)

    ---------------------------------------------------------------------
    To start a new topic, e-mail: users@tomcat.apache.org
    To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
    For additional commands, e-mail: users-help@tomcat.apache.org
  • Charles Lim at Aug 6, 2008 at 9:52 am
    I try to run, but it says -nocert and -accept commands are invalid:

    C:\Downloads\test program>openssl -nocert -accept 8080
    openssl:Error: '-nocert' is an invalid command.

    Standard commands
    asn1parse ca ciphers crl crl2pkcs7
    dgst dh dhparam dsa dsaparam
    ec ecparam enc engine errstr
    gendh gendsa genrsa nseq ocsp
    passwd pkcs12 pkcs7 pkcs8 prime
    rand req rsa rsautl s_client
    s_server s_time sess_id smime speed
    spkac verify version x509

    Message Digest commands (see the `dgst' command for more details)
    md2 md4 md5 rmd160 sha
    sha1

    Cipher commands (see the `enc' command for more details)
    aes-128-cbc aes-128-ecb aes-192-cbc aes-192-ecb aes-256-cbc
    aes-256-ecb base64 bf bf-cbc bf-cfb
    bf-ecb bf-ofb cast cast-cbc cast5-cbc
    cast5-cfb cast5-ecb cast5-ofb des des-cbc
    des-cfb des-ecb des-ede des-ede-cbc des-ede-cfb
    des-ede-ofb des-ede3 des-ede3-cbc des-ede3-cfb des-ede3-ofb
    des-ofb des3 desx idea idea-cbc
    idea-cfb idea-ecb idea-ofb rc2 rc2-40-cbc
    rc2-64-cbc rc2-cbc rc2-cfb rc2-ecb rc2-ofb
    rc4 rc4-40


    C:\Downloads\test program>


    On 8/6/08, Mladen Turk wrote:

    Charles Lim wrote:
    Below is the result after running netstat...both port 8080 and 8383 do not
    seem to be used.

    C:\Programs2\apache-tomcat-6.0.18\bin>netstat -ab -p tcp

    Active Connections
    Seems the ports are not used.
    So you should try some simple program
    Download openssl.exe from

    http://www.apache.org/dist/tomcat/tomcat-connectors/native/1.1.14/binaries/win32/
    openssl.exe -nocert -accept 8080
    If that's not fine you have some security problems.

    Regards
    --
    ^(TM)

    ---------------------------------------------------------------------
    To start a new topic, e-mail: users@tomcat.apache.org
    To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
    For additional commands, e-mail: users-help@tomcat.apache.org
  • Mladen Turk at Aug 6, 2008 at 9:54 am

    Charles Lim wrote:
    I try to run, but it says -nocert and -accept commands are invalid:

    C:\Downloads\test program>openssl -nocert -accept 8080
    openssl:Error: '-nocert' is an invalid command.
    Sorry, its
    openssl s_server -nocert -accept 8080

    Regards
    --
    ^(TM)

    ---------------------------------------------------------------------
    To start a new topic, e-mail: users@tomcat.apache.org
    To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
    For additional commands, e-mail: users-help@tomcat.apache.org
  • Charles Lim at Aug 6, 2008 at 10:01 am
    Below is the result. Seems like the port is ok.


    C:\Users\Charles\Downloads\java\apache>openssl s_server -nocert -accept 8080
    Loading 'screen' into random state - done
    Using default temp DH parameters
    Using default temp ECDH parameters
    ACCEPT

    On Wed, Aug 6, 2008 at 5:54 PM, Mladen Turk wrote:

    Charles Lim wrote:
    I try to run, but it says -nocert and -accept commands are invalid:

    C:\Downloads\test program>openssl -nocert -accept 8080
    openssl:Error: '-nocert' is an invalid command.
    Sorry, its
    openssl s_server -nocert -accept 8080


    Regards
    --
    ^(TM)

    ---------------------------------------------------------------------
    To start a new topic, e-mail: users@tomcat.apache.org
    To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
    For additional commands, e-mail: users-help@tomcat.apache.org
  • Charles Lim at Aug 8, 2008 at 12:54 pm
    Finally the issue was solved. It was due to the Norman
    Anti-virus+Firwall. Although I have disable the firewall, stopped all
    Norman services that can be stopped, i still get the Permission Denied
    error. Only after I have uninstalled Norman can Tomcat start.

    After which I
    1) installed AVG free antivirus to replace Norman,
    2) activate User Account Control
    3) activated Windows Vista Firewall (started automatically)

    Tomcat was still able to start.

    Also during this time, I have also send in support request to
    Microsoft to see if Vista is the one causing the problem, below is
    their initial steps to resolve it. Althought it did not solve my
    problem, still like to attach it here to benefit others:

    Let's focus on our issue. The issue may occur due to the user account
    permission settings. Please follow the steps below to troubleshoot the
    issue.

    ------------------------------ START OF SUGGESTION FROM MICROSOFT
    SUPPORT -----------------------------------
    Step1 Active and log in Vista's build-in administrator account
    =================================
    1. Click Start, click "All Programs", please find and open "Accessories" folder.
    2. Please right-click on "Command Prompt" item and select "Run as
    administrator".
    3. Please type the following command line in to the coming window.

    net user administrator /active:yes

    Note: There is a space between "Administrator" and "/active:yes".

    4. Log off the current account and log on the "Administrator" account.

    Step 2 Turn off UAC (User Account Control)
    ============================
    1. Click Start. Go to the Search textbox. Type MSCONFIG, and press Enter.
    2. Click Tools.
    3. Highlight Disable UAC, click Launch.
    4. Restart the computer.
    ------------------------------ END OF SUGGESTION FROM MICROSOFT
    SUPPORT -----------------------------------

    Thanks Mladen for all your help. This thread should be able to help
    others with the similar encounter.



    On Wed, Aug 6, 2008 at 6:00 PM, Charles Lim wrote:
    Below is the result. Seems like the port is ok.

    C:\Users\Charles\Downloads\java\apache>openssl s_server -nocert -accept 8080
    Loading 'screen' into random state - done
    Using default temp DH parameters
    Using default temp ECDH parameters
    ACCEPT

    On Wed, Aug 6, 2008 at 5:54 PM, Mladen Turk wrote:

    Charles Lim wrote:
    I try to run, but it says -nocert and -accept commands are invalid:

    C:\Downloads\test program>openssl -nocert -accept 8080
    openssl:Error: '-nocert' is an invalid command.
    Sorry, its
    openssl s_server -nocert -accept 8080

    Regards
    --
    ^(TM)

    ---------------------------------------------------------------------
    To start a new topic, e-mail: users@tomcat.apache.org
    To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
    For additional commands, e-mail: users-help@tomcat.apache.org
    ---------------------------------------------------------------------
    To start a new topic, e-mail: users@tomcat.apache.org
    To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
    For additional commands, e-mail: users-help@tomcat.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriestomcat
postedAug 6, '08 at 5:22a
activeAug 8, '08 at 12:54p
posts8
users2
websitetomcat.apache.org
irc#tomcat

2 users in discussion

Charles Lim: 5 posts Mladen Turk: 3 posts

People

Translate

site design / logo © 2022 Grokbase