FAQ
Hi,

Attempting to install Catalyst-Runtime-5.80030.

All required modules loaded:

- Class::Data::Inheritable ...loaded. (0.08)
- Test::Exception ...loaded. (0.31)
- Test::More ...loaded. (0.96 >= 0.88)
- List::MoreUtils ...loaded. (0.22)
- namespace::autoclean ...loaded. (0.11 >= 0.09)
- namespace::clean ...loaded. (0.20 >= 0.13)
- B::Hooks::EndOfScope ...loaded. (0.09 >= 0.08)
- MooseX::Emulate::Class::Accessor::Fast ...loaded. (0.00903 >= 0.00903)
- Class::MOP ...loaded. (1.12 >= 0.95)
- Moose ...loaded. (1.21 >= 1.03)
- MooseX::MethodAttributes::Inheritable ...loaded. (0.24 >= 0.24)
- MooseX::Role::WithOverloading ...loaded. (0.08 >= 0.05)
- Carp ...loaded. (1.04)
- Class::C3::Adopt::NEXT ...loaded. (0.13 >= 0.07)
- CGI::Simple::Cookie ...loaded. (1.112 >= 1.109)
- Data::Dump ...loaded. (1.17)
- Data::OptList ...loaded. (0.106)
- HTML::Entities ...loaded. (3.68)
- HTML::HeadParser ...loaded. (3.66)
- HTTP::Body ...loaded. (1.10 >= 1.06)
- HTTP::Headers ...loaded. (5.835 >= 1.64)
- HTTP::Request ...loaded. (5.827 >= 5.814)
- HTTP::Response ...loaded. (5.836 >= 5.813)
- HTTP::Request::AsCGI ...loaded. (1.2 >= 1.0)
- LWP::UserAgent ...loaded. (5.835)
- Module::Pluggable ...loaded. (3.9 >= 3.9)
- Path::Class ...loaded. (0.21 >= 0.09)
- Scalar::Util ...loaded. (1.23)
- Sub::Exporter ...loaded. (0.982)
- Text::SimpleTable ...loaded. (2.03 >= 0.03)
- Time::HiRes ...loaded. (1.86)
- Tree::Simple ...loaded. (1.18 >= 1.15)
- Tree::Simple::Visitor::FindByPath ...loaded. (0.03)
- URI ...loaded. (1.56 >= 1.35)
- Task::Weaken ...loaded. (1.03)
- Text::Balanced ...loaded. (1.95)
- MRO::Compat ...loaded. (0.11)
- MooseX::Getopt ...loaded. (0.33 >= 0.30)
- MooseX::Types ...loaded. (0.24)
- MooseX::Types::Common::Numeric ...loaded. (0.001001)
- String::RewritePrefix ...loaded. (0.005 >= 0.004)

t/01use.t ............................................................. 1/1
# Failed test 'use Catalyst;'
# at t/01use.t line 3.
# Tried to use 'Catalyst'.
# Error: Couldn't load class (Catalyst::Exception::Basic) because: Can't use an undefined value as a HASH reference at /opt/.../lib/perl5/site_perl/5.8.8/i686-linux/MooseX/Role/WithOverloading/Meta/Role/Application.pm line 45.
# Compilation failed in require at /opt/.../lib/perl5/site_perl/5.8.8/i686-linux/Class/MOP.pm line 114.

Does this for most of its test suite.

Am running:

Class::MOP 1.12
Moose.pm 1.21

Anyone else experienced this/know how to fix?

Thanks,
Anthony

Search Discussions

  • Tomas Doran at Jan 26, 2011 at 12:08 pm

    On 26 Jan 2011, at 11:23, Anthony Gladdish wrote:
    Anyone else experienced this/know how to fix?
    Run package-stash-conflicts

    Upgrade the modules it tells you to.

    Cheers
    t0m
  • Anthony Gladdish at Jan 26, 2011 at 12:33 pm

    Run package-stash-conflicts

    Upgrade the modules it tells you to.

    Cheers
    t0m
    Awesome! ( in this case, culprit was MooseX::Role::WithOverloading ).

    Cheers,
    Anthony
  • Tomas Doran at Jan 26, 2011 at 12:40 pm

    On 26 Jan 2011, at 12:33, Anthony Gladdish wrote:
    Awesome! ( in this case, culprit was MooseX::Role::WithOverloading ).
    Ack, the next release already depends on the latest version to avoid
    this.

    Cheers
    t0m

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedJan 26, '11 at 11:23a
activeJan 26, '11 at 12:40p
posts4
users2
websitecatalystframework.org
irc#catalyst

2 users in discussion

Tomas Doran: 2 posts Anthony Gladdish: 2 posts

People

Translate

site design / logo © 2022 Grokbase