FAQ
Hello,

Redirects after login stopped working after this latest upgrade, as if
Root::end() isn't ignoring 3xx status'. I've downgraded
Catalyst::Action::RenderView from 0.15 to 0.14 and the redirects work
again. Bad end() code or bug?

My end looks like

sub end : ActionClass('RenderView')
{
my ($self, $c) = @_;

# test: skip redirects
return if $c->res->status == 302;

my $view;
if ($c->stash->{printwrapper}) {
$view = 'App::View::TTPrint';
}

<snip> . . . .


Thanks

Ryan

Search Discussions

  • Tomas Doran at Jan 5, 2011 at 11:17 am

    On 5 Jan 2011, at 11:12, ryan lauterbach wrote:

    Hello,

    Redirects after login stopped working after this latest upgrade, as if
    Root::end() isn't ignoring 3xx status'. I've downgraded
    Catalyst::Action::RenderView from 0.15 to 0.14 and the redirects work
    again. Bad end() code or bug?
    No sure, can you confirm the version of Catalyst that you're using
    with this?

    Cheers
    t0m
  • Ryan lauterbach at Jan 5, 2011 at 11:19 am

    No sure, can you confirm the version of Catalyst that you're using with
    this?

    5.80030


    Thanks
  • Ryan lauterbach at Jan 5, 2011 at 2:06 pm

    On 05/01/11 11:17, Tomas Doran wrote:
    On 5 Jan 2011, at 11:12, ryan lauterbach wrote:

    Hello,

    Redirects after login stopped working after this latest upgrade, as if
    Root::end() isn't ignoring 3xx status'. I've downgraded
    Catalyst::Action::RenderView from 0.15 to 0.14 and the redirects work
    again. Bad end() code or bug?
    No sure, can you confirm the version of Catalyst that you're using
    with this?
    5.80030

    Cheers
  • Tomas Doran at Jan 5, 2011 at 7:33 pm

    On 5 Jan 2011, at 11:12, ryan lauterbach wrote:

    Hello,

    Redirects after login stopped working after this latest upgrade, as if
    Root::end() isn't ignoring 3xx status'. I've downgraded
    This is a bug and entirely my fault.

    I have just uploaded a fixed version.

    Apologies for the inconvenience.

    Cheers
    t0m
  • Ryan lauterbach at Jan 5, 2011 at 9:53 pm

    On 5 January 2011 19:34, Tomas Doran wrote:
    On 5 Jan 2011, at 11:12, ryan lauterbach wrote:

    Hello,

    Redirects after login stopped working after this latest upgrade, as if
    Root::end() isn't ignoring 3xx status'. ?I've downgraded
    This is a bug and entirely my fault.

    I have just uploaded a fixed version.

    Apologies for the inconvenience.
    Awesome, thanks

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedJan 5, '11 at 11:12a
activeJan 5, '11 at 9:53p
posts6
users3
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase