FAQ
Hi guys,
If you're running a Catalyst app with the fastcgi script (as found in
scripts/myapp_name_fastcgi.pl), then is there a way to enable the debug
mode. (eg. like running scripts/myapp_server.pl -d)

I've tried setting CATALYST_DEBUG and MYAPP_DEBUG in the shell
environment, but that doesn't seem to work. Either that or else fastcgi
is discarding the output somewhere in our case. (I've messed with the
-keeperr option too)

Cheers,
Toby

Search Discussions

  • Wallace Reis at Jan 18, 2010 at 5:44 pm

    On 18/01/2010, at 03:03, Toby Corkindale wrote:
    Hi guys,
    If you're running a Catalyst app with the fastcgi script (as found in scripts/myapp_name_fastcgi.pl), then is there a way to enable the debug mode. (eg. like running scripts/myapp_server.pl -d)

    I've tried setting CATALYST_DEBUG and MYAPP_DEBUG in the shell environment, but that doesn't seem to work. Either that or else fastcgi is discarding the output somewhere in our case. (I've messed with the -keeperr option too)
    Take a look in the ML archive.

    http://www.mail-archive.com/catalyst@lists.scsys.co.uk/msg03847.html

    Regards,

    --
    wallace reis/wreis Catalyst and DBIx::Class consultancy with a clue
    Software Engineer and a commit bit: http://shadowcat.co.uk/catalyst/
    Shadowcat Systems Limited
    http://www.shadowcat.co.uk http://www.linkedin.com/in/wallacereis
  • Adam Mackler at Jan 18, 2010 at 7:53 pm
    Hi Toby:

    The output might be going to your web server log. Try starting your
    fastcgi script with a -e option (with CATALYST_DEBUG set as well).

    Adam
    On Mon, Jan 18, 2010 at 05:03:23PM +1100, Toby Corkindale wrote:
    Hi guys,
    If you're running a Catalyst app with the fastcgi script (as found in
    scripts/myapp_name_fastcgi.pl), then is there a way to enable the debug
    mode. (eg. like running scripts/myapp_server.pl -d)

    I've tried setting CATALYST_DEBUG and MYAPP_DEBUG in the shell
    environment, but that doesn't seem to work. Either that or else fastcgi
    is discarding the output somewhere in our case. (I've messed with the
    -keeperr option too)

    Cheers,
    Toby

    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/
  • David Schmidt at Jan 18, 2010 at 8:37 pm
    I am pretty sure debug output went to apache's error log when I last checked.
    On Mon, Jan 18, 2010 at 8:54 PM, Adam Mackler wrote:
    Hi Toby:

    The output might be going to your web server log. ?Try starting your
    fastcgi script with a -e option (with CATALYST_DEBUG set as well).

    Adam
    On Mon, Jan 18, 2010 at 05:03:23PM +1100, Toby Corkindale wrote:
    Hi guys,
    If you're running a Catalyst app with the fastcgi script (as found in
    scripts/myapp_name_fastcgi.pl), then is there a way to enable the debug
    mode. (eg. like running scripts/myapp_server.pl -d)

    I've tried setting CATALYST_DEBUG and MYAPP_DEBUG in the shell
    environment, but that doesn't seem to work. Either that or else fastcgi
    is discarding the output somewhere in our case. (I've messed with the
    -keeperr option too)

    Cheers,
    Toby

    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/
    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/


    --
    David Schmidt | http://www.fm5.at
  • Toby Corkindale at Jan 19, 2010 at 12:26 am

    On 19/01/10 06:54, Adam Mackler wrote:
    Hi Toby:

    The output might be going to your web server log. Try starting your
    fastcgi script with a -e option (with CATALYST_DEBUG set as well).
    Looking at the previous posts that Wallace directed me to, it sounds
    like the debug options with fastcgi have been a little broken for some
    time now..
    As I said, I've tried the -e (same as -keeperr) options in combination
    with the *_DEBUG environment variables.

    I have a vague recollection of having this trouble before, and resorting
    to overriding Catalyst::Log to send things to syslog or a standalone log
    file.

    (The front-end apache servers aren't logging any catalyst debug output
    anywhere; possibly this is a config error there, or possibly intentional
    on the part of sysadmins - however either way it's not something I'm
    about to change.)

    Hmm, thanks for looking guys.

    For what it's worth, or anyone reading this in the archives in the
    future - this is still on Catalyst Runtime 5.8.16.
    (.17 was busted, .18 doesn't work out of the box in our environment due
    to some of the changes and so isn't considered production ready by us
    just yet.)
    So I'm not sure if the new Cat ScriptRunner code will have fixed the
    issue there.

    cheers,
    Toby.
    On Mon, Jan 18, 2010 at 05:03:23PM +1100, Toby Corkindale wrote:
    Hi guys,
    If you're running a Catalyst app with the fastcgi script (as found in
    scripts/myapp_name_fastcgi.pl), then is there a way to enable the debug
    mode. (eg. like running scripts/myapp_server.pl -d)

    I've tried setting CATALYST_DEBUG and MYAPP_DEBUG in the shell
    environment, but that doesn't seem to work. Either that or else fastcgi
    is discarding the output somewhere in our case. (I've messed with the
    -keeperr option too)

    Cheers,
    Toby
  • Tomas Doran at Jan 19, 2010 at 10:43 am

    On 19 Jan 2010, at 00:26, Toby Corkindale wrote:
    As I said, I've tried the -e (same as -keeperr) options in
    combination with the *_DEBUG environment variables.
    That should (and does) work here..
    (The front-end apache servers aren't logging any catalyst debug
    output anywhere; possibly this is a config error there, or possibly
    intentional on the part of sysadmins - however either way it's not
    something I'm about to change.)
    Yeah, that's got to be config of some sort, Catalyst does log down the
    fcgi socket by default..
    For what it's worth, or anyone reading this in the archives in the
    future - this is still on Catalyst Runtime 5.8.16.
    (.17 was busted, .18 doesn't work out of the box in our environment
    due to some of the changes and so isn't
    considered production ready by us just yet.)
    I don't see a bug report for this anywhere? Did I miss it?
    So I'm not sure if the new Cat ScriptRunner code will have fixed the
    issue there.
    It fixed the short options for scripts, but that's the only change
    which has been made.

    It hasn't (at any point) changed the environment variable handling for
    debug.

    Cheers
    t0m
  • Toby Corkindale at Jan 20, 2010 at 5:38 am

    On 19/01/10 21:45, Tomas Doran wrote:
    On 19 Jan 2010, at 00:26, Toby Corkindale wrote:
    As I said, I've tried the -e (same as -keeperr) options in combination
    with the *_DEBUG environment variables.
    That should (and does) work here..
    Hmm. That's interesting to know.. I swear it isn't working on the
    machines I was testing this on the other day. Many things are old on
    them, so maybe it's something in a fastcgi library or other.
    I'll investigate some more.
    (The front-end apache servers aren't logging any catalyst debug output
    anywhere; possibly this is a config error there, or possibly
    intentional on the part of sysadmins - however either way it's not
    something I'm about to change.)
    Yeah, that's got to be config of some sort, Catalyst does log down the
    fcgi socket by default..
    For what it's worth, or anyone reading this in the archives in the
    future - this is still on Catalyst Runtime 5.8.16.
    (.17 was busted, .18 doesn't work out of the box in our environment
    due to some of the changes and so isn't
    considered production ready by us just yet.)
    I don't see a bug report for this anywhere? Did I miss it?
    "make catalyst_par" doesn't produce a working PAR, as the
    Catalyst::ScriptRunner modules is not included inside the PAR.
    Introduced in 5.8.17. Reported 15 Dec 2009.

    Temporary fix is to add to Makefile.PL:
    catalyst_par_classes('Catalyst::ScriptRunner');
    catalyst_par_classes('Catalyst::Script::FastCGI');
    ..etc..

    but of course if you do that, the package will fail to build on older
    pre-version-17 setups, and I didn't really want to get into the
    Makefile.PL complexity of optionally including them based on revisions
    of modules..

    Cheers,
    Toby

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedJan 18, '10 at 6:03a
activeJan 20, '10 at 5:38a
posts7
users5
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase