FAQ
Hi,

I found that in Catalyst::Runtime 5.80016 the following error still appears
when there is a bug in the current application:

[error] Caught exception in engine "Can't use string
("8e6ef33a63f84c0132bf6e605898b7cc") as a HASH ref while "strict refs" in
use at E:/perl510/site/lib/Catalyst/Engine.pm line 117."

The debug is not printed in the browser, but a "Cannot find server" only.

Octavian

Search Discussions

  • Florian Ragwitz at Dec 18, 2009 at 2:04 pm

    On Fri, Dec 18, 2009 at 12:53:52PM +0200, Octavian Râşniţă wrote:
    I found that in Catalyst::Runtime 5.80016 the following error still appears
    when there is a bug in the current application:
    Yes, that's a regression in 5.80016, introduce with the changes to not
    dump the __MOP__ attribute of certain objects.


    --
    BOFH excuse #80:
    That's a great computer you have there; have you considered how it would
    work as a BSD machine?
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: Digital signature
    Url : http://lists.scsys.co.uk/pipermail/catalyst/attachments/20091218/5db6cf2b/attachment.pgp
  • Hakim Cassimally at Dec 18, 2009 at 2:24 pm

    2009/12/18 Florian Ragwitz <rafl@debian.org>:
    On Fri, Dec 18, 2009 at 12:53:52PM +0200, Octavian R??ni?? wrote:
    I found that in Catalyst::Runtime 5.80016 the following error still appears
    when there is a bug in the current application:
    Yes, that's a regression in 5.80016, introduce with the changes to not
    dump the __MOP__ attribute of certain objects.
    I just reported this bug as https://rt.cpan.org/Ticket/Display.html?idR898

    osf'
  • Tomas Doran at Dec 18, 2009 at 7:58 pm

    On 18 Dec 2009, at 14:24, Hakim Cassimally wrote:

    2009/12/18 Florian Ragwitz <rafl@debian.org>:
    On Fri, Dec 18, 2009 at 12:53:52PM +0200, Octavian R??ni?? wrote:
    I found that in Catalyst::Runtime 5.80016 the following error
    still appears
    when there is a bug in the current application:
    Yes, that's a regression in 5.80016, introduce with the changes to
    not
    dump the __MOP__ attribute of certain objects.
    I just reported this bug as https://rt.cpan.org/Ticket/Display.html?idR898
    And fixed here:
    http://dev.catalystframework.org/svnweb/Catalyst/revision?rev431

    Cheers
    t0m

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedDec 18, '09 at 10:53a
activeDec 18, '09 at 7:58p
posts4
users4
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase