FAQ
Hot on the heels of Catalyst-Runtime 5.80014, I'd like to announce a
development release, Catalyst 5.80014_01.

This release has a potentially behavior changing fix for the CGI and
FastCGI engines to do with outputting UTF-8. This fixes a serious bug
with outputting utf-8 pages using Catalyst::Plugin::Unicode::Encoding
at least..

I _NEED_ people using FastCGI and dealing with high bit characters in
their applications to test this release for me and let me know if they
see any issues. If you do see any issues in your app which previously
worked with any other 5.80 version, please reply to this mail or log a
bug in RT.

You can try it out by typing:
cpan -i BOBTFISH/Catalyst-5.80014_01.tar.gz

The changelog is included below as usual. Thanks in advance to anyone
helping test this release.

Cheers
t0m

--
5.80014_01 2009-11-22 20:01:23

Bug fixes:
- Filehandle now forced to binmode in CGI and FastCGI engines.
This appears
to correct some UTF-8 issues, but may break people's code which
relies
on the old behaviour.

Refactoring / cleanups:
- Plugins which inherit from Catalyst::Controller or
Catalyst::Component
are deprecated and now issue warnings.

Search Discussions

  • Frank Wiegand at Nov 24, 2009 at 9:36 am

    Am Montag, den 23.11.2009, 23:54 +0000 schrieb Tomas Doran:
    You can try it out by typing:
    cpan -i BOBTFISH/Catalyst-5.80014_01.tar.gz
    Setting TEST_HTTP=1 and TEST_THREADS=1, I got two test errors:

    t/optional_http-server-restart.t ...................................... Can't locate Catalyst/Engine/HTTP/Restarter/Watcher.pm in @INC (@INC contains: /home/fw/tmp/Catalyst-Runtime-5.80014_01/inc /home/fw/tmp/Catalyst-Runtime-5.80014_01/blib/lib /home/fw/tmp/Catalyst-Runtime-5.80014_01/blib/arch /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at t/optional_http-server-restart.t line 16.
    BEGIN failed--compilation aborted at t/optional_http-server-restart.t line 16.
    t/optional_http-server-restart.t ...................................... Dubious, test returned 2 (wstat 512, 0x200)
    No subtests run

    and

    t/optional_threads.t .................................................. 1/3
    # Failed test 'Executed actions'
    # at t/optional_threads.t line 54.
    # got: 'TestApp::Controller::Action::Default->begin, TestApp::Controller::Action::Default->default, TestApp::View::Dump::Request->process, TestApp::Controller::Root->end'
    # expected: 'TestApp::Controller::Action::Default->begin, TestApp::Controller::Action::Default->default, TestApp::View::Dump::Request->process, TestApp->end'
    # Looks like you failed 1 test of 3.
    t/optional_threads.t .................................................. Dubious, test returned 1 (wstat 256, 0x100)
    Failed 1/3 subtests

    The last one already has a ticket at http://rt.cpan.org/Public/Bug/Display.html?idP039


    Bye, Frank
  • Tomas Doran at Aug 26, 2010 at 12:24 am

    On 24 Nov 2009, at 09:36, Frank Wiegand wrote:

    t/
    optional_threads
    .t .................................................. 1/3
    # Failed test 'Executed actions'
    # at t/optional_threads.t line 54.
    # got: 'TestApp::Controller::Action::Default->begin,
    TestApp::Controller::Action::Default->default,
    TestApp::View::Dump::Request->process, TestApp::Controller::Root->end'
    # expected: 'TestApp::Controller::Action::Default->begin,
    TestApp::Controller::Action::Default->default,
    TestApp::View::Dump::Request->process, TestApp->end'
    # Looks like you failed 1 test of 3.
    t/
    optional_threads
    .t .................................................. Dubious, test
    returned 1 (wstat 256, 0x100)
    Failed 1/3 subtests
    Fixed in r13546

    Cheers
    t0m
  • Vladimir Timofeev at Nov 24, 2009 at 10:04 am
    At first glance all ok. I can't find any encoding issues with my
    application (all templates and data in koi8-r). But I do not try to
    print any chars, all data - bytes.
    On Tue, Nov 24, 2009 at 02:54, Tomas Doran wrote:
    Hot on the heels of Catalyst-Runtime 5.80014, I'd like to announce a
    development release, Catalyst 5.80014_01.

    This release has a potentially behavior changing fix for the CGI and FastCGI
    engines to do with outputting UTF-8. This fixes a serious bug with
    outputting utf-8 pages using Catalyst::Plugin::Unicode::Encoding at least..

    I _NEED_ people using FastCGI and dealing with high bit characters in their
    applications to test this release for me and let me know if they see any
    issues. If you do see any issues in your app which previously worked with
    any other 5.80 version, please reply to this mail or log a bug in RT.

    You can try it out by typing:
    cpan -i BOBTFISH/Catalyst-5.80014_01.tar.gz

    The changelog is included below as usual. Thanks in advance to anyone
    helping test this release.

    Cheers
    t0m

    --
    5.80014_01 2009-11-22 20:01:23

    ?Bug fixes:
    ? - Filehandle now forced to binmode in CGI and FastCGI engines. This
    appears
    ? ? to correct some UTF-8 issues, but may break people's code which relies
    ? ? on the old behaviour.

    ?Refactoring / cleanups:
    ? - Plugins which inherit from Catalyst::Controller or Catalyst::Component
    ? ? are deprecated and now issue warnings.


    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/


    --
    -- vovkasm

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedNov 23, '09 at 11:51p
activeAug 26, '10 at 12:24a
posts4
users3
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase