FAQ
Hello,

I'm building a Catalyst application, and am now trying to add Session
support, but having a lot of difficulty. This is what I am attempting
to use,

use Catalyst qw/-Debug
ConfigLoader
Static::Simple

Session
Session::Store::FastMmap
Session::State::Cookie

Log::Handler
StackTrace
/;

I have installed all of the related Session plugins successfully, but
receive the following error when I attempt to start my server.

# perl funnelscope_server.pl
Can't load '/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/Cache/FastMmap/CImpl/CImpl.bundle'
for module Cache::FastMmap::CImpl:
dlopen(/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/Cache/FastMmap/CImpl/CImpl.bundle,
1): Symbol not found: _PL_op
Referenced from:
/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/Cache/FastMmap/CImpl/CImpl.bundle
Expected in: dynamic lookup
at /Library/Perl/5.8.8/darwin-thread-multi-2level/Cache/FastMmap/CImpl.pm
line 21
Compilation failed in require at
/Library/Perl/5.8.8/darwin-thread-multi-2level/Cache/FastMmap.pm line
292.
BEGIN failed--compilation aborted at
/Library/Perl/5.8.8/darwin-thread-multi-2level/Cache/FastMmap.pm line
292.
Compilation failed in require at
/Library/Perl/5.8.8/Catalyst/Plugin/Session/Store/FastMmap.pm line 11.
BEGIN failed--compilation aborted at
/Library/Perl/5.8.8/Catalyst/Plugin/Session/Store/FastMmap.pm line 11.
Compilation failed in require at /Library/Perl/5.8.8/Catalyst/Utils.pm line 274.
Compilation failed in require at funnelscope_server.pl line 55.

As you can guess, I'm running Mac OS X. Here are my relevant versions,

Mac OS X 10.5.7
perl 5.8.8
Catalyst::Runtime 5.71001
Catalyst::Plugin::Session 0.20
Catalyst::Plugin::Session::Store::FastMmap 0.09

Admittedly, my Catalyst app is slightly out of the ordinary. I am
using 5.7 because I am using Class::DBI for my model. I have not had
any problems, but I think that this may be related to some version
conflicts.

I have also tried using Catalyst::Plugin::Session::Store::File and I
get the following error upon startup,

Undefined subroutine &Class::MOP::get_metaclass_by_name called at
/Library/Perl/5.8.8/Any/Moose.pm line 61.
BEGIN failed--compilation aborted at
/Library/Perl/5.8.8/Data/Visitor/Callback.pm line 4.
Compilation failed in require at
/Library/Perl/5.8.8/Catalyst/Plugin/ConfigLoader.pm line 8.
BEGIN failed--compilation aborted at
/Library/Perl/5.8.8/Catalyst/Plugin/ConfigLoader.pm line 8.
Compilation failed in require at /Library/Perl/5.8.8/Catalyst/Utils.pm line 274.
Compilation failed in require at funnelscope_server.pl line 55.

Versions:
Any::Moose 0.09
Class::MOP 0.84

I'm pretty stumped on this. Any ideas?

Thanks,

- Jon

Search Discussions

  • Tomas Doran at Jun 6, 2009 at 3:26 pm

    On 5 Jun 2009, at 16:44, Jon wrote:
    # perl funnelscope_server.pl
    Can't load '/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/
    Cache/FastMmap/CImpl/CImpl.bundle'
    for module Cache::FastMmap::CImpl:
    Right, your 'Cache::FastMmap' module is buggered. Try re-installing
    it, or use a different session store (I'd recommend memcache
    personally).
    As you can guess, I'm running Mac OS X. Here are my relevant
    versions,

    Admittedly, my Catalyst app is slightly out of the ordinary. I am
    using 5.7 because I am using Class::DBI for my model.
    How is that relevant?

    Catalyst 5.80 is backwards compatible - unless you've got a bug you
    haven't reported?
    I have also tried using Catalyst::Plugin::Session::Store::File and I
    get the following error upon startup,

    Undefined subroutine &Class::MOP::get_metaclass_by_name called at
    /Library/Perl/5.8.8/Any/Moose.pm line 61.
    BEGIN failed--compilation aborted at
    /Library/Perl/5.8.8/Data/Visitor/Callback.pm line 4.
    Compilation failed in require at
    /Library/Perl/5.8.8/Catalyst/Plugin/ConfigLoader.pm line 8.
    BEGIN failed--compilation aborted at
    /Library/Perl/5.8.8/Catalyst/Plugin/ConfigLoader.pm line 8.
    Compilation failed in require at /Library/Perl/5.8.8/Catalyst/
    Utils.pm line 274.
    Compilation failed in require at funnelscope_server.pl line 55.
    This is to do with incompatibility between your version (new) of
    Moose and the (old) version of Any::Moose which Data::Visitor is
    happy with.

    Install the new version of Catalyst::Plugin::Configloader, which will
    requires new Data::Visitor, which in turn will pull in a fixed
    version of Any::Moose.

    Cheers
    t0m

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedJun 5, '09 at 3:44p
activeJun 6, '09 at 3:26p
posts2
users2
websitecatalystframework.org
irc#catalyst

2 users in discussion

Jon: 1 post Tomas Doran: 1 post

People

Translate

site design / logo © 2022 Grokbase