FAQ
Hi,

I'm having problems getting the config for a custom DBI based model module
loaded from my config file. The module starts off with

package Timerec::Model::DB;
use strict;
use base 'Catalyst::Model::DBI';
use POSIX;
__PACKAGE__->config(
dsn => "dbi:mysql:timerec",
user => "timerec",
password => "foobar",
);

Now i want to move this into my config file (timerec.conf), in which I put:

<Model DB>
dsn dbi:mysql:timerec
user timerec
password foobar
</Model>

This works fine on my local development machine, but doesn't work on the
deployment server. The software versions are slightly older on the server
(Catalyst 5.7006 on Perl 5.8.8, as opposed to Catalyst 5.7014 on Perl 5.10).
I'm looking for hints as to what could be wrong or how I could work around
this problem...

Thanks in advance!
Richard
--
View this message in context: http://www.nabble.com/Model-config-not-being-loaded-tp19958254p19958254.html
Sent from the Catalyst Web Framework mailing list archive at Nabble.com.

Search Discussions

  • Brian Cassidy at Oct 14, 2008 at 12:04 pm

    On Tue, Oct 14, 2008 at 7:40 AM, dfx wrote:
    This works fine on my local development machine, but doesn't work on the
    deployment server. The software versions are slightly older on the server
    (Catalyst 5.7006 on Perl 5.8.8, as opposed to Catalyst 5.7014 on Perl 5.10).
    I'm looking for hints as to what could be wrong or how I could work around
    this problem...
    Is Config::General installed on the server?

    -Brian
  • Dfx at Oct 14, 2008 at 12:31 pm

    Brian Cassidy-2 wrote:
    On Tue, Oct 14, 2008 at 7:40 AM, dfx wrote:
    This works fine on my local development machine, but doesn't work on the
    deployment server. The software versions are slightly older on the server
    (Catalyst 5.7006 on Perl 5.8.8, as opposed to Catalyst 5.7014 on Perl
    5.10).
    I'm looking for hints as to what could be wrong or how I could work
    around
    this problem...
    Is Config::General installed on the server?

    -Brian
    Hi,

    yes, sorry for not mentioning this. In fact the section from the config file
    appears in the $c->config hash in both cases (under the key "Model::DB") as
    expected.

    Thanks,
    cheers
    Richard
    --
    View this message in context: http://www.nabble.com/Model-config-not-being-loaded-tp19958254p19971660.html
    Sent from the Catalyst Web Framework mailing list archive at Nabble.com.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedOct 14, '08 at 11:40a
activeOct 14, '08 at 12:31p
posts3
users2
websitecatalystframework.org
irc#catalyst

2 users in discussion

Dfx: 2 posts Brian Cassidy: 1 post

People

Translate

site design / logo © 2021 Grokbase