FAQ
Hello all.

I have a Catalyst app running fine with the _server.pl script, but trying to
deploy it with mod_perl for Apache 2 has proven itself impossible... %-|

Here is the file I include at the end of my httpd.conf:

-----------------------------------------------------------------
PerlOptions +GlobalRequest
PerlSwitches -I/home/LookingGlass/LookingGlass/lib/
PerlSwitches -I/home/LookingGlass/LookingGlass/lib/Net
PerlModule LookingGlass


<Location />
SetHandler modperl
PerlResponseHandler LookingGlass
</Location>

<VirtualHost *>
DocumentRoot /home/LookingGlass/LookingGlass/lib/

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

<Directory /home/LookingGlass/LookingGlass/root/src/ >
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ErrorLog /var/log/httpd/LookingGlass_error.log

LogLevel warn

CustomLog /var/log/httpd/LookingGlass_access.log combined
ServerSignature On

</VirtualHost>
-----------------------------------------------------------------

And here is a typical error msg when going to https://localhost/:
-----------------------------------------------------------------
Request

bless({
action => "index",
address => "10.137.9.24",
arguments => [],
base => bless(do{\(my $o = "https://lgdeploy/")},
"URI::https"),
body_parameters => {},
captures => [],
cookies => {
lookingglass_session => bless({
name => "lookingglass_session",
path => "/",
value =>
["e56ac9d37cac79e47e1c6de681dc67313b0da6e0"],
}, "CGI::Simple::Cookie"),
},
headers => bless({
"accept" =>
"text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8",
"accept-charset" =>
"ISO-8859-1,utf-8;q=0.7,*;q=0.7",
"accept-encoding" => "gzip,deflate",
"accept-language" => "en-us,en;q=0.5",
connection => "keep-alive",
cookie =>
"lookingglass_session=e56ac9d37cac79e47e1c6de681dc67313b0da6e0",
host => "lgdeploy",
"keep-alive" => 300,
"user-agent" => "Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1",
}, "HTTP::Headers"),
hostname => undef,
match => "",
method => "GET",
parameters => {},
path => "",
protocol => "HTTP/1.1",
query_parameters => {},
secure => 1,
uploads => {},
uri => bless(do{\(my $o = "https://lgdeploy/")},
"URI::https"),
user => undef,
}, "Catalyst::Request")

Response

bless({
body => "",
cookies => {},
headers => bless({
"content-type" => "text/html; charset=utf-8",
"x-catalyst" => "5.7014",
}, "HTTP::Headers"),
status => 200,
}, "Catalyst::Response")

Stash

{}

Config

do {
my $a = {
"Plugin::Authentication" => {},
"Plugin::ConfigLoader" => {},
debug => {
ignore_classes => [
"DBIx::Class::ResultSource::Table",
"DBIx::Class::ResultSourceHandle",
"DateTime",
],
scrubber_func => sub { "???" },
},
form => {},
home => "/home/LookingGlass/LookingGlass",
name => "LookingGlass",
root => bless({
dirs => ["", "home", "LookingGlass", "LookingGlass", "root"],
file_spec_class => undef,
volume => "",
}, "Path::Class::Dir"),
session => {
cookie_name => "lookingglass_session",
expires => 7200,
namespace => "",
storage => "/tmp/lookingglass/session/data",
verify_address => 0,
},
static => {
debug => 1,
dirs => [],
ignore_dirs => [],
ignore_extensions => ["tmpl", "tt", "tt2", "html", "xhtml"],
include_path => ['fix'],
mime_types => {},
mime_types_obj => bless({}, "MIME::Types"),
no_logs => 1,
},
};
$a->{static}{include_path}[0] = $a->{root};
$a;
}

Session ID

"e56ac9d37cac79e47e1c6de681dc67313b0da6e0"

Session

{
__created => 1221670415,
__updated => 1221671167,
command_detail => { config => { type => "normal" }, name => "show diag",
param_list => [] },
user => { groups => [{ id => 1, name => "Admin" }], id => 1, name =>
"Admin" },
}
-----------------------------------------------------------------

Here is Apache's ssl.conf:
-----------------------------------------------------------------
LoadModule ssl_module modules/mod_ssl.so
Listen 443
AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl .crl
SSLPassPhraseDialog builtin
SSLSessionCache shmcb:/var/cache/mod_ssl/scache(512000)
SSLSessionCacheTimeout 300
SSLMutex default
SSLRandomSeed startup file:/dev/urandom 256
SSLRandomSeed connect builtin
SSLCryptoDevice builtin
<VirtualHost _default_:443>
ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
LogLevel warn
SSLEngine on
SSLProtocol all -SSLv2
SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
SSLCertificateFile /etc/pki/tls/certs/localhost.crt
SSLCertificateKeyFile /etc/pki/tls/private/localhost.key
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
<Directory "/var/www/cgi-bin">
SSLOptions +StdEnvVars
</Directory>

SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0

CustomLog logs/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

</VirtualHost>
-----------------------------------------------------------------

And here is what I usually get in the server script debug output:

[info] *** Request 1 (0.167/s) [30473] [Wed Sep 17 18:23:35 2008] ***
[debug] "GET" request for "/" from "10.137.9.24"
[debug] Rendering template "index.tt"
[error] Couldn't render template "file error - index.tt: not found"
[error] Couldn't render template "file error - index.tt: not found"
[info] Request took 0.069101s (14.472/s)
.----------------------------------------------------------------+-----------.
Action | Time
+----------------------------------------------------------------+-----------+
/index | 0.000914s

/end | 0.008844s

-> LookingGlass::View::HTML->process | 0.004835s
'----------------------------------------------------------------+-----------'



Is there a way to know what path Catalyst is looking for the file? What was
the precise error? Whatever info more you need, I am able to provide. Please
help me...

Thanks for your time reading this,

Bruno
--
View this message in context: http://www.nabble.com/Help%21-Need-help-deploying-app-to-Apache-tp19536440p19536440.html
Sent from the Catalyst Web Framework mailing list archive at Nabble.com.

Search Discussions

  • Ali Mesdaq at Sep 17, 2008 at 6:25 pm
    Did you try also looking at the apache error log? Might have useful information in there about file paths or permissions

    Thanks,
    ------------------------------------------
    Ali Mesdaq (CISSP, GIAC-GREM)
    Sr. Security Researcher
    Websense Security Labs
    http://www.WebsenseSecurityLabs.com
    ------------------------------------------


    -----Original Message-----
    From: sardaukar_siet
    Sent: Wednesday, September 17, 2008 9:47 AM
    To: catalyst@lists.scsys.co.uk
    Subject: [Catalyst] Help! Need help deploying app to Apache


    Hello all.

    I have a Catalyst app running fine with the _server.pl script, but trying to
    deploy it with mod_perl for Apache 2 has proven itself impossible... %-|

    Here is the file I include at the end of my httpd.conf:

    -----------------------------------------------------------------
    PerlOptions +GlobalRequest
    PerlSwitches -I/home/LookingGlass/LookingGlass/lib/
    PerlSwitches -I/home/LookingGlass/LookingGlass/lib/Net
    PerlModule LookingGlass


    <Location />
    SetHandler modperl
    PerlResponseHandler LookingGlass
    </Location>

    <VirtualHost *>
    DocumentRoot /home/LookingGlass/LookingGlass/lib/

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    <Directory /home/LookingGlass/LookingGlass/root/src/ >
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>

    ErrorLog /var/log/httpd/LookingGlass_error.log

    LogLevel warn

    CustomLog /var/log/httpd/LookingGlass_access.log combined
    ServerSignature On

    </VirtualHost>
    -----------------------------------------------------------------

    And here is a typical error msg when going to https://localhost/:
    -----------------------------------------------------------------
    Request

    bless({
    action => "index",
    address => "10.137.9.24",
    arguments => [],
    base => bless(do{\(my $o = "https://lgdeploy/")},
    "URI::https"),
    body_parameters => {},
    captures => [],
    cookies => {
    lookingglass_session => bless({
    name => "lookingglass_session",
    path => "/",
    value =>
    ["e56ac9d37cac79e47e1c6de681dc67313b0da6e0"],
    }, "CGI::Simple::Cookie"),
    },
    headers => bless({
    "accept" =>
    "text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8",
    "accept-charset" =>
    "ISO-8859-1,utf-8;q=0.7,*;q=0.7",
    "accept-encoding" => "gzip,deflate",
    "accept-language" => "en-us,en;q=0.5",
    connection => "keep-alive",
    cookie =>
    "lookingglass_session=e56ac9d37cac79e47e1c6de681dc67313b0da6e0",
    host => "lgdeploy",
    "keep-alive" => 300,
    "user-agent" => "Mozilla/5.0 (X11; U; Linux i686;
    en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1",
    }, "HTTP::Headers"),
    hostname => undef,
    match => "",
    method => "GET",
    parameters => {},
    path => "",
    protocol => "HTTP/1.1",
    query_parameters => {},
    secure => 1,
    uploads => {},
    uri => bless(do{\(my $o = "https://lgdeploy/")},
    "URI::https"),
    user => undef,
    }, "Catalyst::Request")

    Response

    bless({
    body => "",
    cookies => {},
    headers => bless({
    "content-type" => "text/html; charset=utf-8",
    "x-catalyst" => "5.7014",
    }, "HTTP::Headers"),
    status => 200,
    }, "Catalyst::Response")

    Stash

    {}

    Config

    do {
    my $a = {
    "Plugin::Authentication" => {},
    "Plugin::ConfigLoader" => {},
    debug => {
    ignore_classes => [
    "DBIx::Class::ResultSource::Table",
    "DBIx::Class::ResultSourceHandle",
    "DateTime",
    ],
    scrubber_func => sub { "???" },
    },
    form => {},
    home => "/home/LookingGlass/LookingGlass",
    name => "LookingGlass",
    root => bless({
    dirs => ["", "home", "LookingGlass", "LookingGlass", "root"],
    file_spec_class => undef,
    volume => "",
    }, "Path::Class::Dir"),
    session => {
    cookie_name => "lookingglass_session",
    expires => 7200,
    namespace => "",
    storage => "/tmp/lookingglass/session/data",
    verify_address => 0,
    },
    static => {
    debug => 1,
    dirs => [],
    ignore_dirs => [],
    ignore_extensions => ["tmpl", "tt", "tt2", "html", "xhtml"],
    include_path => ['fix'],
    mime_types => {},
    mime_types_obj => bless({}, "MIME::Types"),
    no_logs => 1,
    },
    };
    $a->{static}{include_path}[0] = $a->{root};
    $a;
    }

    Session ID

    "e56ac9d37cac79e47e1c6de681dc67313b0da6e0"

    Session

    {
    __created => 1221670415,
    __updated => 1221671167,
    command_detail => { config => { type => "normal" }, name => "show diag",
    param_list => [] },
    user => { groups => [{ id => 1, name => "Admin" }], id => 1, name =>
    "Admin" },
    }
    -----------------------------------------------------------------

    Here is Apache's ssl.conf:
    -----------------------------------------------------------------
    LoadModule ssl_module modules/mod_ssl.so
    Listen 443
    AddType application/x-x509-ca-cert .crt
    AddType application/x-pkcs7-crl .crl
    SSLPassPhraseDialog builtin
    SSLSessionCache shmcb:/var/cache/mod_ssl/scache(512000)
    SSLSessionCacheTimeout 300
    SSLMutex default
    SSLRandomSeed startup file:/dev/urandom 256
    SSLRandomSeed connect builtin
    SSLCryptoDevice builtin
    <VirtualHost _default_:443>
    ErrorLog logs/ssl_error_log
    TransferLog logs/ssl_access_log
    LogLevel warn
    SSLEngine on
    SSLProtocol all -SSLv2
    SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
    SSLCertificateFile /etc/pki/tls/certs/localhost.crt
    SSLCertificateKeyFile /etc/pki/tls/private/localhost.key
    <Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
    </Files>
    <Directory "/var/www/cgi-bin">
    SSLOptions +StdEnvVars
    </Directory>

    SetEnvIf User-Agent ".*MSIE.*" \
    nokeepalive ssl-unclean-shutdown \
    downgrade-1.0 force-response-1.0

    CustomLog logs/ssl_request_log \
    "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

    </VirtualHost>
    -----------------------------------------------------------------

    And here is what I usually get in the server script debug output:

    [info] *** Request 1 (0.167/s) [30473] [Wed Sep 17 18:23:35 2008] ***
    [debug] "GET" request for "/" from "10.137.9.24"
    [debug] Rendering template "index.tt"
    [error] Couldn't render template "file error - index.tt: not found"
    [error] Couldn't render template "file error - index.tt: not found"
    [info] Request took 0.069101s (14.472/s)
    .----------------------------------------------------------------+-----------.
    Action | Time
    +----------------------------------------------------------------+-----------+
    /index | 0.000914s

    /end | 0.008844s

    -> LookingGlass::View::HTML->process | 0.004835s
    '----------------------------------------------------------------+-----------'



    Is there a way to know what path Catalyst is looking for the file? What was
    the precise error? Whatever info more you need, I am able to provide. Please
    help me...

    Thanks for your time reading this,

    Bruno
    --
    View this message in context: http://www.nabble.com/Help%21-Need-help-deploying-app-to-Apache-tp19536440p19536440.html
    Sent from the Catalyst Web Framework mailing list archive at Nabble.com.


    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/


    Protected by Websense Messaging Security -- www.websense.com
  • Bruno Antunes at Sep 17, 2008 at 6:33 pm
    I sent an example of the errors in Apache's error_log, it was like this:

    [Wed Sep 17 18:30:18 2008] [notice] Apache/2.2.3 (CentOS) configured --
    resuming normal operations
    [info] *** Request 1 (0.143/s) [30709] [Wed Sep 17 18:30:24 2008] ***
    [debug] "GET" request for "/" from "10.137.9.24"
    [debug] Rendering template "index.tt"
    [error] Couldn't render template "file error - index.tt: not found"
    [error] Couldn't render template "file error - index.tt: not found"
    [info] Request took 0.066461s (15.046/s)
    .----------------------------------------------------------------+-----------.
    Action | Time
    +----------------------------------------------------------------+-----------+
    /index | 0.000804s

    /end | 0.008121s

    -> LookingGlass::View::HTML->process | 0.004464s
    '----------------------------------------------------------------+-----------'


    Not very helpful, was hoping Catalyst could be more verbose.
    On Wed, Sep 17, 2008 at 18:25, Mesdaq, Ali wrote:

    Did you try also looking at the apache error log? Might have useful
    information in there about file paths or permissions

    Thanks,
    ------------------------------------------
    Ali Mesdaq (CISSP, GIAC-GREM)
    Sr. Security Researcher
    Websense Security Labs
    http://www.WebsenseSecurityLabs.com
    ------------------------------------------


    -----Original Message-----
    From: sardaukar_siet
    Sent: Wednesday, September 17, 2008 9:47 AM
    To: catalyst@lists.scsys.co.uk
    Subject: [Catalyst] Help! Need help deploying app to Apache


    Hello all.

    I have a Catalyst app running fine with the _server.pl script, but trying
    to
    deploy it with mod_perl for Apache 2 has proven itself impossible... %-|

    Here is the file I include at the end of my httpd.conf:

    -----------------------------------------------------------------
    PerlOptions +GlobalRequest
    PerlSwitches -I/home/LookingGlass/LookingGlass/lib/
    PerlSwitches -I/home/LookingGlass/LookingGlass/lib/Net
    PerlModule LookingGlass


    <Location />
    SetHandler modperl
    PerlResponseHandler LookingGlass
    </Location>

    <VirtualHost *>
    DocumentRoot /home/LookingGlass/LookingGlass/lib/

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    <Directory /home/LookingGlass/LookingGlass/root/src/ >
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>

    ErrorLog /var/log/httpd/LookingGlass_error.log

    LogLevel warn

    CustomLog /var/log/httpd/LookingGlass_access.log combined
    ServerSignature On

    </VirtualHost>
    -----------------------------------------------------------------

    And here is a typical error msg when going to https://localhost/:
    -----------------------------------------------------------------
    Request

    bless({
    action => "index",
    address => "10.137.9.24",
    arguments => [],
    base => bless(do{\(my $o = "https://lgdeploy/")},
    "URI::https"),
    body_parameters => {},
    captures => [],
    cookies => {
    lookingglass_session => bless({
    name => "lookingglass_session",
    path => "/",
    value =>
    ["e56ac9d37cac79e47e1c6de681dc67313b0da6e0"],
    }, "CGI::Simple::Cookie"),
    },
    headers => bless({
    "accept" =>
    "text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8",
    "accept-charset" =>
    "ISO-8859-1,utf-8;q=0.7,*;q=0.7",
    "accept-encoding" => "gzip,deflate",
    "accept-language" => "en-us,en;q=0.5",
    connection => "keep-alive",
    cookie =>
    "lookingglass_session=e56ac9d37cac79e47e1c6de681dc67313b0da6e0",
    host => "lgdeploy",
    "keep-alive" => 300,
    "user-agent" => "Mozilla/5.0 (X11; U; Linux i686;
    en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1",
    }, "HTTP::Headers"),
    hostname => undef,
    match => "",
    method => "GET",
    parameters => {},
    path => "",
    protocol => "HTTP/1.1",
    query_parameters => {},
    secure => 1,
    uploads => {},
    uri => bless(do{\(my $o = "https://lgdeploy/")},
    "URI::https"),
    user => undef,
    }, "Catalyst::Request")

    Response

    bless({
    body => "",
    cookies => {},
    headers => bless({
    "content-type" => "text/html; charset=utf-8",
    "x-catalyst" => "5.7014",
    }, "HTTP::Headers"),
    status => 200,
    }, "Catalyst::Response")

    Stash

    {}

    Config

    do {
    my $a = {
    "Plugin::Authentication" => {},
    "Plugin::ConfigLoader" => {},
    debug => {
    ignore_classes => [
    "DBIx::Class::ResultSource::Table",
    "DBIx::Class::ResultSourceHandle",
    "DateTime",
    ],
    scrubber_func => sub { "???" },
    },
    form => {},
    home => "/home/LookingGlass/LookingGlass",
    name => "LookingGlass",
    root => bless({
    dirs => ["", "home", "LookingGlass", "LookingGlass", "root"],
    file_spec_class => undef,
    volume => "",
    }, "Path::Class::Dir"),
    session => {
    cookie_name => "lookingglass_session",
    expires => 7200,
    namespace => "",
    storage => "/tmp/lookingglass/session/data",
    verify_address => 0,
    },
    static => {
    debug => 1,
    dirs => [],
    ignore_dirs => [],
    ignore_extensions => ["tmpl", "tt", "tt2", "html", "xhtml"],
    include_path => ['fix'],
    mime_types => {},
    mime_types_obj => bless({}, "MIME::Types"),
    no_logs => 1,
    },
    };
    $a->{static}{include_path}[0] = $a->{root};
    $a;
    }

    Session ID

    "e56ac9d37cac79e47e1c6de681dc67313b0da6e0"

    Session

    {
    __created => 1221670415,
    __updated => 1221671167,
    command_detail => { config => { type => "normal" }, name => "show diag",
    param_list => [] },
    user => { groups => [{ id => 1, name => "Admin" }], id => 1, name =>
    "Admin" },
    }
    -----------------------------------------------------------------

    Here is Apache's ssl.conf:
    -----------------------------------------------------------------
    LoadModule ssl_module modules/mod_ssl.so
    Listen 443
    AddType application/x-x509-ca-cert .crt
    AddType application/x-pkcs7-crl .crl
    SSLPassPhraseDialog builtin
    SSLSessionCache shmcb:/var/cache/mod_ssl/scache(512000)
    SSLSessionCacheTimeout 300
    SSLMutex default
    SSLRandomSeed startup file:/dev/urandom 256
    SSLRandomSeed connect builtin
    SSLCryptoDevice builtin
    <VirtualHost _default_:443>
    ErrorLog logs/ssl_error_log
    TransferLog logs/ssl_access_log
    LogLevel warn
    SSLEngine on
    SSLProtocol all -SSLv2
    SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
    SSLCertificateFile /etc/pki/tls/certs/localhost.crt
    SSLCertificateKeyFile /etc/pki/tls/private/localhost.key
    <Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
    </Files>
    <Directory "/var/www/cgi-bin">
    SSLOptions +StdEnvVars
    </Directory>

    SetEnvIf User-Agent ".*MSIE.*" \
    nokeepalive ssl-unclean-shutdown \
    downgrade-1.0 force-response-1.0

    CustomLog logs/ssl_request_log \
    "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

    </VirtualHost>
    -----------------------------------------------------------------

    And here is what I usually get in the server script debug output:

    [info] *** Request 1 (0.167/s) [30473] [Wed Sep 17 18:23:35 2008] ***
    [debug] "GET" request for "/" from "10.137.9.24"
    [debug] Rendering template "index.tt"
    [error] Couldn't render template "file error - index.tt: not found"
    [error] Couldn't render template "file error - index.tt: not found"
    [info] Request took 0.069101s (14.472/s)

    .----------------------------------------------------------------+-----------.
    Action | Time
    +----------------------------------------------------------------+-----------+
    /index | 0.000914s
    /end | 0.008844s
    -> LookingGlass::View::HTML->process | 0.004835s
    '----------------------------------------------------------------+-----------'



    Is there a way to know what path Catalyst is looking for the file? What was
    the precise error? Whatever info more you need, I am able to provide.
    Please
    help me...

    Thanks for your time reading this,

    Bruno
    --
    View this message in context:
    http://www.nabble.com/Help%21-Need-help-deploying-app-to-Apache-tp19536440p19536440.html
    Sent from the Catalyst Web Framework mailing list archive at Nabble.com.


    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive:
    http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/


    Protected by Websense Messaging Security -- www.websense.com

    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive:
    http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/


    --
    Bruno
    http://iruel.net
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20080917/f396e49f/attachment.htm
  • Ashley Pond V at Sep 17, 2008 at 6:52 pm

    On Sep 17, 2008, at 10:33 AM, Bruno Antunes wrote:
    I sent an example of the errors in Apache's error_log, it was like
    this:

    [Wed Sep 17 18:30:18 2008] [notice] Apache/2.2.3 (CentOS)
    configured -- resuming normal operations
    [info] *** Request 1 (0.143/s) [30709] [Wed Sep 17 18:30:24 2008] ***
    [debug] "GET" request for "/" from "10.137.9.24"
    [debug] Rendering template "index.tt"
    [error] Couldn't render template "file error - index.tt: not found"
    [error] Couldn't render template "file error - index.tt: not found"
    [info] Request took 0.066461s (15.046/s)
    Not very helpful, was hoping Catalyst could be more verbose.

    If software could debug itself there would be no bugs. The error in
    that batch seems pretty clear: Couldn't render template "file error -
    index.tt: not found"

    Looks like you either don't have an "index.tt" or you have the
    INCLUDE_PATH set badly in your TT stuff.

    -Ashley

    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20080917/9e9be3f0/attachment.htm
  • Bruno Antunes at Sep 17, 2008 at 8:35 pm
    I was not hoping for the situation to resolve itself - frankly, there
    shouldn't be one since it runs in the test server perfectly. And obviously,
    the index.tt file is were it is supposed to be as far as making it work with
    the test server.

    I was wishing for more verbosity in saying where it is looking for the file,
    so I can track the error in my httpd.conf and fix it. But thanks for your
    remarks.
    On Wed, Sep 17, 2008 at 18:52, Ashley wrote:

    On Sep 17, 2008, at 10:33 AM, Bruno Antunes wrote:

    I sent an example of the errors in Apache's error_log, it was like this:

    [Wed Sep 17 18:30:18 2008] [notice] Apache/2.2.3 (CentOS) configured --
    resuming normal operations
    [info] *** Request 1 (0.143/s) [30709] [Wed Sep 17 18:30:24 2008] ***
    [debug] "GET" request for "/" from "10.137.9.24"
    [debug] Rendering template "index.tt"
    [error] Couldn't render template "file error - index.tt: not found"
    [error] Couldn't render template "file error - index.tt: not found"
    [info] Request took 0.066461s (15.046/s)


    Not very helpful, was hoping Catalyst could be more verbose.


    If software could debug itself there would be no bugs. The error in that
    batch seems pretty clear: Couldn't render template "file error - index.tt:
    not found"

    Looks like you either don't have an "index.tt" or you have
    the INCLUDE_PATH set badly in your TT stuff.

    -Ashley

    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive:
    http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/

    --
    Bruno
    http://iruel.net
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20080917/0c975b81/attachment.htm
  • Ashley Pond V at Sep 17, 2008 at 8:45 pm

    On Sep 17, 2008, at 12:35 PM, Bruno Antunes wrote:
    I was not hoping for the situation to resolve itself - frankly,
    there shouldn't be one since it runs in the test server perfectly.
    And obviously, the index.tt file is were it is supposed to be as
    far as making it work with the test server.

    I was wishing for more verbosity in saying where it is looking for
    the file, so I can track the error in my httpd.conf and fix it. But
    thanks for your remarks.
    Yep. Sorry, I didn't read the rest of the of the diagnostic info when
    the error log info ended up on top. :(


    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20080917/2a9404a0/attachment.htm
  • Peter Flanigan at Sep 17, 2008 at 7:28 pm

    Bruno Antunes wrote:

    [error] Couldn't render template "file error - index.tt
    <http://index.tt>: not found"
    Type ps -ef | grep apache
    Make a note of the user that apache is running as. Su to root. Su to the
    user that apache is running as. Cd into the directory that index.tt is
    in. Cat index.tt. Do not chmod everything 777. Directories should be 755
    and files 644 (mostly if your not too worried about tight permissions)

    Also please post as text not HTML your above error is getting mangled

    --

    Regards
  • Tomas Doran at Sep 17, 2008 at 9:54 pm

    Is there a way to know what path Catalyst is looking for the file?
    What was
    the precise error? Whatever info more you need, I am able to
    provide. Please
    help me...

    Thanks for your time reading this,
    strace is your friend.

    Copy your apache config to /tmp, reset it to a high port for testing,
    reduce the MinSpareServers to 0, MinSpareServers to 1, and set
    StartServers to 1 (assuming the prefork mpm here..

    Then start your apache with strace -f, and grep out index.tt (i.e.
    say something like: sudo strace -f /usr/sbin/apache2 -f /tmp/
    debugapache.conf 2>&1 | grep index.tt | tee /tmp/apache-syscalls.log)

    Then hit the index page of your app, and you'll get what you want in
    the output...

    Cheers
    t0m
  • Bruno Antunes at Sep 17, 2008 at 10:53 pm
    Wow. Thanks for the info, I'll try this tomorrow!
    On Wed, Sep 17, 2008 at 21:54, Tomas Doran wrote:

    Is there a way to know what path Catalyst is looking for the file? What was
    the precise error? Whatever info more you need, I am able to provide.
    Please
    help me...

    Thanks for your time reading this,
    strace is your friend.

    Copy your apache config to /tmp, reset it to a high port for testing,
    reduce the MinSpareServers to 0, MinSpareServers to 1, and set StartServers
    to 1 (assuming the prefork mpm here..

    Then start your apache with strace -f, and grep out index.tt (i.e. say
    something like: sudo strace -f /usr/sbin/apache2 -f /tmp/debugapache.conf
    2>&1 | grep index.tt | tee /tmp/apache-syscalls.log)

    Then hit the index page of your app, and you'll get what you want in the
    output...

    Cheers
    t0m





    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive:
    http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/


    --
    Bruno
    http://iruel.net
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20080917/238bcea4/attachment.htm
  • Bruno Antunes at Sep 18, 2008 at 12:48 pm
    Tomas, you have made me see the light! I moved the DocumentRoot to
    /LookingGlass and chowned it to apache.apache and everything works, now!
    Here is my command line (Fedora 9):

    sudo strace -f /usr/sbin/httpd -f /tmp/httpd.conf -X

    And here is the .conf I used:

    --------------------------------------------------------------------------------
    ServerName lg01pc01
    Listen 80
    PidFile run/httpd.pid

    User apache
    Group apache

    LoadModule perl_module modules/mod_perl.so

    <IfModule prefork.c>
    StartServers 1
    MinSpareServers 1
    MaxSpareServers 1
    ServerLimit 256
    MaxClients 256
    MaxRequestsPerChild 4000
    </IfModule>


    PerlOptions +GlobalRequest
    PerlSwitches -I/LookingGlass/lib
    PerlSwitches -I/LookingGlass/lib/Net
    PerlSetEnv LookingGlassRoot /LookingGlass
    PerlModule LookingGlass

    DocumentRoot /LookingGlass/root/

    <Location />
    SetHandler modperl
    PerlResponseHandler LookingGlass
    </Location>
    --------------------------------------------------------------------------------

    It was lame to assume that Apache could just cd into a directory under my
    home and access it - I guess there is a folder hierarchy it has to tranverse
    and my home folder is not +x to others... duh. I'll just my app's deployment
    folder to this root location and chown it all.

    Thanks! Now to merge this with the server's httpd.conf into a VirtualHost
    entry!

    On Wed, Sep 17, 2008 at 21:54, Tomas Doran wrote:

    Is there a way to know what path Catalyst is looking for the file? What was
    the precise error? Whatever info more you need, I am able to provide.
    Please
    help me...

    Thanks for your time reading this,
    strace is your friend.

    Copy your apache config to /tmp, reset it to a high port for testing,
    reduce the MinSpareServers to 0, MinSpareServers to 1, and set StartServers
    to 1 (assuming the prefork mpm here..

    Then start your apache with strace -f, and grep out index.tt (i.e. say
    something like: sudo strace -f /usr/sbin/apache2 -f /tmp/debugapache.conf
    2>&1 | grep index.tt | tee /tmp/apache-syscalls.log)

    Then hit the index page of your app, and you'll get what you want in the
    output...

    Cheers
    t0m





    _______________________________________________
    List: Catalyst@lists.scsys.co.uk
    Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
    Searchable archive:
    http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
    Dev site: http://dev.catalyst.perl.org/


    --
    Bruno
    http://iruel.net
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20080918/4e0f3995/attachment.htm

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedSep 17, '08 at 5:47p
activeSep 18, '08 at 12:48p
posts10
users5
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase