FAQ
Hello dear All,

I am stuck on plugin installation...

cpan[2]> install Catalyst::Plugin::Authentication
Running install for module Catalyst::Plugin::Authentication
Running make for N/NU/NUFFIN/Catalyst-Plugin-Authentication-0.09.tar.gz
Is already unwrapped into directory /root/.cpan/build/Catalyst-Plugin-Authentication-0.09
Has already been processed within this session
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/04_authentication....ok
t/05_password..........ok
t/06_user..............ok
t/live_app.............ok
t/live_app_session.....NOK 7
# Failed test 'session ID was restored'
# in t/lib/AuthSessionTestApp.pm at line 38.
t/live_app_session.....NOK 8
# Failed test 'user exists'
# in t/lib/AuthSessionTestApp.pm at line 39.
t/live_app_session.....NOK 9
# Failed test 'a user was also restored'
# in t/lib/AuthSessionTestApp.pm at line 40.
t/live_app_session.....NOK 10
# Failed test in t/lib/AuthSessionTestApp.pm at line 41.
# Structures begin differing at:
# $got = User::SessionRestoring=HASH(0x86bb4c4)
# $expected = 'restored user is the right one (deep test - store might change identity)'
t/live_app_session.....NOK 12
# Failed test 'no session ID was restored'
# in t/lib/AuthSessionTestApp.pm at line 49.
t/live_app_session.....NOK 17
# Failed test 'valid session'
# in t/lib/AuthSessionTestApp.pm at line 66.
# Looks like you failed 6 tests of 20.
t/live_app_session.....dubious
Test returned status 6 (wstat 1536, 0x600)
DIED. FAILED tests 7-10, 12, 17
Failed 6/20 tests, 70.00% okay
t/pod..................skipped
all skipped: set TEST_POD to enable this test
t/pod_coverage.........skipped
all skipped: set TEST_POD to enable this test
Failed Test Stat Wstat Total Fail Failed List of Failed
-------------------------------------------------------------------------------
t/live_app_session.t 6 1536 20 6 30.00% 7-10 12 17
2 tests skipped.
Failed 1/7 test scripts, 85.71% okay. 6/50 subtests failed, 88.00% okay.
*** Error code 255

Stop in /root/.cpan/build/Catalyst-Plugin-Authentication-0.09.
/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force
Failed during this command:
NUFFIN/Catalyst-Plugin-Authentication-0.09.tar.gz: make_test NO
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20070330/dab22fb4/attachment.htm

Search Discussions

  • Alex Pavlovic at Apr 2, 2007 at 5:14 am
    It's in the ports tree under:

    www/p5-Catalyst-Plugin-Authentication

    Try that instead.
    On Thursday 29 March 2007 17:18, MORGUN Alexander wrote:
    Hello dear All,

    I am stuck on plugin installation...

    cpan[2]> install Catalyst::Plugin::Authentication
    Running install for module Catalyst::Plugin::Authentication
    Running make for N/NU/NUFFIN/Catalyst-Plugin-Authentication-0.09.tar.gz
    Is already unwrapped into directory
    /root/.cpan/build/Catalyst-Plugin-Authentication-0.09 Has already been
    processed within this session
    Running make test
    PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
    "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/04_authentication....ok
    t/05_password..........ok
    t/06_user..............ok
    t/live_app.............ok
    t/live_app_session.....NOK 7
    # Failed test 'session ID was restored'
    # in t/lib/AuthSessionTestApp.pm at line 38.
    t/live_app_session.....NOK 8
    # Failed test 'user exists'
    # in t/lib/AuthSessionTestApp.pm at line 39.
    t/live_app_session.....NOK 9
    # Failed test 'a user was also restored'
    # in t/lib/AuthSessionTestApp.pm at line 40.
    t/live_app_session.....NOK 10
    # Failed test in t/lib/AuthSessionTestApp.pm at line 41.
    # Structures begin differing at:
    # $got = User::SessionRestoring=HASH(0x86bb4c4)
    # $expected = 'restored user is the right one (deep test - store might
    change identity)' t/live_app_session.....NOK 12
    # Failed test 'no session ID was restored'
    # in t/lib/AuthSessionTestApp.pm at line 49.
    t/live_app_session.....NOK 17
    # Failed test 'valid session'
    # in t/lib/AuthSessionTestApp.pm at line 66.
    # Looks like you failed 6 tests of 20.
    t/live_app_session.....dubious
    Test returned status 6 (wstat 1536, 0x600)
    DIED. FAILED tests 7-10, 12, 17
    Failed 6/20 tests, 70.00% okay
    t/pod..................skipped
    all skipped: set TEST_POD to enable this test
    t/pod_coverage.........skipped
    all skipped: set TEST_POD to enable this test
    Failed Test Stat Wstat Total Fail Failed List of Failed
    ---------------------------------------------------------------------------
    ---- t/live_app_session.t 6 1536 20 6 30.00% 7-10 12 17
    2 tests skipped.
    Failed 1/7 test scripts, 85.71% okay. 6/50 subtests failed, 88.00% okay.
    *** Error code 255

    Stop in /root/.cpan/build/Catalyst-Plugin-Authentication-0.09.
    /usr/bin/make test -- NOT OK
    Running make install
    make test had returned bad status, won't install without force
    Failed during this command:
    NUFFIN/Catalyst-Plugin-Authentication-0.09.tar.gz: make_test NO
    --
    Alex Pavlovic - CTO
    TF-1 Inc. ( Custom development, consultancy and training )
    http://taskforce-1.com

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedMar 30, '07 at 1:17a
activeApr 2, '07 at 5:14a
posts2
users2
websitecatalystframework.org
irc#catalyst

2 users in discussion

MORGUN Alexander: 1 post Alex Pavlovic: 1 post

People

Translate

site design / logo © 2022 Grokbase