FAQ
hi,
i have charset problem.
i use apache2 and fascgi(standalone mode).
In main apache2.conf I added
AddDefaultCharset cp1251

and modify end action(adding content-type header)

But I get wrong charset in output : (
With LiveHeaders plugin of Firefox i see that Content-Type header is
correct:
Content-Type: text/html; charset=cp1251

What can be wrong?

Encoding of templates are OK, because when I start my_app with
catalyst build-in server, charset-encoding is OK(http://site.com:3000).
So problem is in fastcgi and apache2

Search Discussions

  • Jonathan Rockway at Jan 10, 2007 at 9:42 pm

    denis@uzvik.kiev.ua wrote:
    hi,
    i have charset problem.
    i use apache2 and fascgi(standalone mode).
    In main apache2.conf I added
    AddDefaultCharset cp1251

    and modify end action(adding content-type header)

    But I get wrong charset in output : (
    With LiveHeaders plugin of Firefox i see that Content-Type header is
    correct:
    Content-Type: text/html; charset=cp1251

    What can be wrong?

    Encoding of templates are OK, because when I start my_app with
    catalyst build-in server, charset-encoding is OK(http://site.com:3000).
    So problem is in fastcgi and apache2
    Do you ever encode your data to the target charset? Take a look at
    http://www.catalystframework.org/calendar/2006/21 for information on how
    to handle unicode and non-ascii charsets.

    --
    package JAPH;use Catalyst qw/-Debug/;($;=JAPH)->config(name => do {
    $,.=reverse qw[Jonathan tsu rehton lre rekca Rockway][$_].[split //,
    ";$;"]->[$_].q; ;for 1..4;$,=~s;^.;;;$,});$;->setup;

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedJan 10, '07 at 8:54p
activeJan 10, '07 at 9:42p
posts2
users2
websitecatalystframework.org
irc#catalyst

2 users in discussion

Jonathan Rockway: 1 post Denis: 1 post

People

Translate

site design / logo © 2021 Grokbase