FAQ
Hi all,

Wasn't there a plan to remove a dependency on YAML or switch to
YAML::Syck with a fallback to YAML? While Ingy has no longer made YAML
dependent on Spiffy, it appears to require Test::Base which, in turn,
requires Spiffy. Since I can't install Spiffy, I can't install
Test::Base and thus can't upgrade YAML.

Cheers,
Ovid

--
If this message is a response to a question on a mailing list, please send follow up questions to the list.

Web Programming with Perl -- http://users.easystreet.com/ovid/cgi_course/

Search Discussions

  • Sebastian Riedel at Feb 25, 2006 at 11:02 pm

    25.02.2006 22:20 Ovid:
    Wasn't there a plan to remove a dependency on YAML or switch to
    YAML::Syck with a fallback to YAML? While Ingy has no longer made
    YAML
    dependent on Spiffy, it appears to require Test::Base which, in turn,
    requires Spiffy. Since I can't install Spiffy, I can't install
    Test::Base and thus can't upgrade YAML.
    Test::Base and Spiffy are build prereqs and bundled in newer YAML
    releases, so there is no need to install them.
    YAML support is now a plugin, which has been included in the core.


    --
    sebastian
  • John Beppu at Feb 26, 2006 at 9:25 am

    On 2/25/06, Ovid wrote:
    Hi all,

    Wasn't there a plan to remove a dependency on YAML or switch to
    YAML::Syck with a fallback to YAML? While Ingy has no longer made YAML
    dependent on Spiffy, it appears to require Test::Base which, in turn,
    requires Spiffy. Since I can't install Spiffy, I can't install
    Test::Base and thus can't upgrade YAML.
    Is a force install out the question?
  • Curtis "Ovid" Poe at Feb 27, 2006 at 7:37 pm

    --- John Beppu wrote:

    requires Spiffy. Since I can't install Spiffy, I can't install
    Test::Base and thus can't upgrade YAML.
    Is a force install out the question?
    I can probably do that. I didn't have time to dig into the errors, but
    they appeared to be simple formatting errors which would be unlikely to
    affect behavior. However, Spippy is strange enough (and large enough)
    that I feel considerably less comfortable forcing it than I would
    another module. However, since this is only for tests, I'll probably
    go that route.

    Cheers,
    Ovid

    --
    If this message is a response to a question on a mailing list, please send follow up questions to the list.

    Web Programming with Perl -- http://users.easystreet.com/ovid/cgi_course/
  • Marcus Ramberg at Mar 1, 2006 at 9:24 am
    Just force install YAML instead? :)

    Marcus
    On 2/27/06, Ovid wrote:

    --- John Beppu wrote:
    requires Spiffy. Since I can't install Spiffy, I can't install
    Test::Base and thus can't upgrade YAML.
    Is a force install out the question?
    I can probably do that. I didn't have time to dig into the errors, but
    they appeared to be simple formatting errors which would be unlikely to
    affect behavior. However, Spippy is strange enough (and large enough)
    that I feel considerably less comfortable forcing it than I would
    another module. However, since this is only for tests, I'll probably
    go that route.

    Cheers,
    Ovid

    --
    If this message is a response to a question on a mailing list, please send
    follow up questions to the list.

    Web Programming with Perl -- http://users.easystreet.com/ovid/cgi_course/

    _______________________________________________
    Catalyst mailing list
    Catalyst at lists.rawmode.org
    http://lists.rawmode.org/mailman/listinfo/catalyst


    --
    With regards
    Marcus Ramberg
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.rawmode.org/pipermail/catalyst/attachments/20060301/22e9a532/attachment.htm
  • Aristotle Pagaltzis at Mar 1, 2006 at 9:33 am
    * Marcus Ramberg [2006-03-01 10:30]:
    On 2/27/06, Ovid wrote:
    --- John Beppu wrote:
    Is a force install out the question?
    I can probably do that. [...]
    Just force install YAML instead? :)
    Errm. Must not be your reading comprehension day. :-)

    Regards,
    --
    Aristotle Pagaltzis // <http://plasmasturm.org/>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedFeb 25, '06 at 9:20p
activeMar 1, '06 at 9:33a
posts6
users5
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase