FAQ
Hi,

I'm trying catalyst for a project I'm working on, and no matter what I
try (My app, the tutorial, the scaffolding example) I get the following
error:

Couldn't forward to "tutorial".
Does not implement "tutorial::Controller::Users"

This in the case of the tutorial app. The same happens for the other
apps, substituting appropriately.

I believe that I must be forgetting something in all r cases. I went
back and rechecked everything in tutorial and the scaffolding
examples... but hit the same spot.

Any suggestions?

TIA,

--
ServiSMART
servimos o seu neg?cio
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3470 bytes
Desc: S/MIME Cryptographic Signature
Url : http://lists.rawmode.org/pipermail/catalyst/attachments/20060223/e866f354/attachment.bin

Search Discussions

  • Ricardo J. Sousa at Feb 24, 2006 at 11:51 am
    Ricardo J. Sousa wrote:

    [snip]
    Couldn't forward to "tutorial".
    Does not implement "tutorial::Controller::Users"
    Apparently changing the forward in end action to $c->forward('') fixes
    that error :(

    regards
    --
    ServiSMART
    servimos o seu neg?cio
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: smime.p7s
    Type: application/x-pkcs7-signature
    Size: 3470 bytes
    Desc: S/MIME Cryptographic Signature
    Url : http://lists.rawmode.org/pipermail/catalyst/attachments/20060224/38302cf1/attachment.bin
  • Kieren Diment at Feb 24, 2006 at 1:26 pm

    On 24/02/06, Ricardo J. Sousa wrote:
    Ricardo J. Sousa wrote:

    [snip]
    Couldn't forward to "tutorial".
    Does not implement "tutorial::Controller::Users"
    Apparently changing the forward in end action to $c->forward('') fixes
    that error :(


    Strange error. I posted the tutorial application to the front page of the
    wiki (in Documentation section) so you can check if it's your system or your
    typing errors causing you trouble.

    http://dev.catalyst.perl.org/attachment/wiki/WikiStart/tutorial.tar.gz
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.rawmode.org/pipermail/catalyst/attachments/20060225/f374d4d0/attachment.htm
  • Matt S Trout at Feb 24, 2006 at 11:58 am

    On Thu, Feb 23, 2006 at 06:48:43PM +0000, Ricardo J. Sousa wrote:
    Hi,

    I'm trying catalyst for a project I'm working on, and no matter what I
    try (My app, the tutorial, the scaffolding example) I get the following
    error:

    Couldn't forward to "tutorial".
    Does not implement "tutorial::Controller::Users"

    This in the case of the tutorial app. The same happens for the other
    apps, substituting appropriately.

    I believe that I must be forgetting something in all r cases. I went
    back and rechecked everything in tutorial and the scaffolding
    examples... but hit the same spot.

    Any suggestions?
    Show us suitable bits of your code so we can try and figure out what you're
    forgetting? As it is it could be one of three million potential typos or
    silly mistakes (I speak from experience of making them :)

    --
    Matt S Trout Offering custom development, consultancy and support
    Technical Director contracts for Catalyst, DBIx::Class and BAST. Contact
    Shadowcat Systems Ltd. mst (at) shadowcatsystems.co.uk for more information

    + Help us build a better perl ORM: http://dbix-class.shadowcatsystems.co.uk/ +

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedFeb 23, '06 at 6:48p
activeFeb 24, '06 at 1:26p
posts4
users3
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase