FAQ
Hi,

I just installed Catalyst, and was trying the example given at
http://search.cpan.org/~sri/Catalyst-5.61/lib/Catalyst/Manual/Intro.pod ,
but I get the following error when I try to access localhost:3000. What am I
doing wrong? :-|

<output>

~/tmp/catalyst/MyApp$ script/myapp_server.pl
[Tue Dec 13 10:53:34 2005] [catalyst] [debug] Debug messages enabled
[Tue Dec 13 10:53:34 2005] [catalyst] [debug] Loaded dispatcher
"Catalyst::Dispatcher"
[Tue Dec 13 10:53:34 2005] [catalyst] [debug] Loaded engine
"Catalyst::Engine::HTTP"
[Tue Dec 13 10:53:34 2005] [catalyst] [debug] Found home
"/home/swaroop/tmp/catalyst/MyApp/script/.."
[Tue Dec 13 10:53:34 2005] [catalyst] [debug] Loaded components
.=----------------------------------------------------------------------------=.

MyApp::C::Library::Login
'=----------------------------------------------------------------------------='

[Tue Dec 13 10:53:34 2005] [catalyst] [debug] Loaded private actions
.=-------------------------------------+--------------------------------------=.
Private |
Class |
=-------------------------------------+--------------------------------------=|
/default |
MyApp |
/library/login/default |
MyApp::C::Library::Login |
'=-------------------------------------+--------------------------------------='

[Tue Dec 13 10:53:34 2005] [catalyst] [info] MyApp powered by Catalyst 5.23
You can connect to your server at http://localhost:3000/
Initializer for response must be hash reference at
/home/y/lib/perl5/site_perl/5.6.1/Catalyst/Engine/HTTP/Daemon.pm line 71

</output>

Thanks,
--
Swaroop C H
www.swaroopch.info
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rawmode.org/pipermail/catalyst/attachments/20051213/3cc66372/attachment.htm

Search Discussions

  • Adam Herzog at Dec 13, 2005 at 7:11 am

    [Tue Dec 13 10:53:34 2005] [catalyst] [info] MyApp powered by
    Catalyst 5.23
    You can connect to your server at http://localhost:3000/
    Initializer for response must be hash reference at
    /home/y/lib/perl5/site_perl/5.6.1/Catalyst/Engine/HTTP/Daemon.pm line
    71
    I'm not familiar with this exact error, but I know that a lot has
    changed since version 5.23. You should try and upgrade to the latest
    version if possible.

    Also, the path to Daemon.pm seems to imply that you're running Perl
    5.6.1. Is that right? Catalyst requires 5.8.1, I think. Definitely make
    sure you have 5.8.1 or later.

    -A

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedDec 13, '05 at 6:19a
activeDec 13, '05 at 7:11a
posts2
users2
websitecatalystframework.org
irc#catalyst

2 users in discussion

Adam Herzog: 1 post Swaroop C H: 1 post

People

Translate

site design / logo © 2022 Grokbase