Hi all,

I have a problem with the rabbitmq-management plugin where it doesn't display any queue or exchange information.
ie. even the /api calls return an empty list, yet rabbitmqctl list_queues and its' counterparts correctly show queue information.

rabbitmq, management, management-agent, mochiweb all show version 2.7.0
and the erlang version is R14B04

Any ideas?

Thanks,
Brendan

Search Discussions

  • Joefitzgerald at Dec 21, 2011 at 3:44 pm
    Hey Brendan,

    Are you running RabbitMQ in Windows? I've noticed a bug where the
    Windows installer installs RabbitMQ as a service, but when it is
    started, nothing really works. The fix for me was to:

    * rabbitmq-service.bat stop
    * rabbitmq-service.bat remove
    * rabbitmq-service.bat install
    * rabbitmq-service.bat start

    Hope that helps. I haven't figured out the root cause of it, but I
    have definitely seen this for 2.7.0 and 2.7.1 on Windows.

    -Joe
    On Dec 21, 8:38?am, Brendan Hay wrote:
    Hi all,

    I have a problem with the rabbitmq-management plugin where it doesn't display any queue or exchange information.
    ie. even the /api calls return an empty list, yet rabbitmqctl list_queues and its' counterparts correctly show queue information.

    rabbitmq, management, management-agent, mochiweb all show version 2.7.0
    and the erlang version is R14B04

    Any ideas?

    Thanks,
    Brendan

    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-disc... at lists.rabbitmq.comhttps://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
  • Matthias Radestock at Dec 22, 2011 at 8:01 pm

    On 21/12/11 15:44, joefitzgerald wrote:
    I've noticed a bug where the Windows installer installs RabbitMQ as a
    service, but when it is started, nothing really works.
    Is this reproducible?
    The fix for me was to:

    * rabbitmq-service.bat stop
    * rabbitmq-service.bat remove
    * rabbitmq-service.bat install
    * rabbitmq-service.bat start
    These, minus the 'remove', are necessary steps when enabling/disabling
    plugins in the RabbitMQ Windows service. See
    http://www.rabbitmq.com/plugins.html#windows-restart

    Matthias.
  • Matthias Radestock at Dec 24, 2011 at 12:19 am
    Brendan,
    On 21/12/11 15:38, Brendan Hay wrote:
    I have a problem with the rabbitmq-management plugin where it doesn't
    display any queue or exchange information. ie. even the /api calls
    return an empty list, yet rabbitmqctl list_queues and its'
    counterparts correctly show queue information.

    rabbitmq, management, management-agent, mochiweb all show version
    2.7.0 and the erlang version is R14B04

    Any ideas?
    Does the overview page work ok? Are there any errors in the logs? Could
    be a permission problem - see
    http://www.rabbitmq.com/management.html#permissions for the permissions
    model employed by the management plug-in.

    You may want to upgrade to 2.7.1, which fixed a number of bugs in the
    management plug-in and elsewhere.


    Regards,

    Matthias.
  • Brendan Hay at Dec 24, 2011 at 10:49 am
    Overview worked fine, permissions and tags were all set correctly for the user.
    I ended up having to restart rabbit to get the queues/exchanges showing up correctly.

    Thanks,
    Brendan
    On 24/12/2011, at 1:19 AM, Matthias Radestock wrote:

    Brendan,
    On 21/12/11 15:38, Brendan Hay wrote:
    I have a problem with the rabbitmq-management plugin where it doesn't
    display any queue or exchange information. ie. even the /api calls
    return an empty list, yet rabbitmqctl list_queues and its'
    counterparts correctly show queue information.

    rabbitmq, management, management-agent, mochiweb all show version
    2.7.0 and the erlang version is R14B04

    Any ideas?
    Does the overview page work ok? Are there any errors in the logs? Could be a permission problem - see http://www.rabbitmq.com/management.html#permissions for the permissions model employed by the management plug-in.

    You may want to upgrade to 2.7.1, which fixed a number of bugs in the management plug-in and elsewhere.


    Regards,

    Matthias.
  • Matthias Radestock at Dec 24, 2011 at 10:59 am
    Brendan,
    On 24/12/11 10:49, Brendan Hay wrote:
    Overview worked fine, permissions and tags were all set correctly for the user.
    I ended up having to restart rabbit to get the queues/exchanges showing up correctly.
    Glad you got it working. I'd still recommend upgrading to 2.7.1.

    Regards,

    Matthias

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprabbitmq-discuss @
categoriesrabbitmq
postedDec 21, '11 at 3:38p
activeDec 24, '11 at 10:59a
posts6
users3
websiterabbitmq.com
irc#rabbitmq

People

Translate

site design / logo © 2022 Grokbase