Hello,I am start the rabbitmq-server in my centos5.6 , when i execute rabbitmq-server script(without add -detached argument) ,the script stop here "0 plugins activated", i must type 'Ctrl+C' , the script go on execute ..... ,why??
Picture1. execute ./rabbitmq-server ,always stop here .

Picture2 . type 'Ctrl+C' abort ,then the rabbitmq-server go on ....



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20111024/eba325eb/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 1.jpg
Type: image/jpeg
Size: 14291 bytes
Desc: not available
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20111024/eba325eb/attachment.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 2.jpg
Type: image/jpeg
Size: 30015 bytes
Desc: not available
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20111024/eba325eb/attachment-0001.jpg>

Search Discussions

  • Marek Majkowski at Oct 24, 2011 at 10:31 am
    2011/10/24 _-^? z-- <mejozn at 163.com>
    Hello,I am start the rabbitmq-server in my centos5.6 , when i execute rabbitmq-server script(without add ?-detached argument) ,the script stop here "0 plugins activated", i must type 'Ctrl+C' , the script go on execute ..... ,why??
    `rabbitmq-server` command is a bash script that is responsible for
    running Erlang virtual machine.

    What you see is a erlang vm behaviour. It's actually pretty cool, try typing
    something like
    5 + 2. or
    io:format("asd~n").
    Yes... This is an interactive prompt.

    Although in most situations you don't need it. That's why -detached option
    allows you to run the vm in the background.

    Generally, you shouldn't need to run `rabbitmq-server`. You should
    use packaged rabbitmq server release and let your operating
    system to run and manage it.
    On linux startup and stop is often managed by
    /etc/init.d/rabbitmq-server script.

    Hope that helps.

    Cheers,
    Marek
  • Marek Majkowski at Oct 24, 2011 at 11:01 am

    On Mon, Oct 24, 2011 at 11:31, Marek Majkowski wrote:
    2011/10/24 _-^? z-- <mejozn at 163.com>
    Hello,I am start the rabbitmq-server in my centos5.6 , when i execute rabbitmq-server script(without add ?-detached argument) ,the script stop here "0 plugins activated", i must type 'Ctrl+C' , the script go on execute ..... ,why??
    Right, I answered the wrong question. Let me try again.

    `rabbitmq-server` runs erlang interpreter twice. First as
    'prelaunch' and later usual 'rabbitmq' stuff.

    What you see is an erlang getting stuck at first run.

    This is quite weird. It shouldn't happen. My gut feeling is that
    you have something wrong with epmd/dns/hostname settings.

    Are you able to run $ ping `hostname` command?

    Take a look here: http://cms02.phys.ntu.edu.tw/tracs/env/ticket/317

    Cheers,
    Marek

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprabbitmq-discuss @
categoriesrabbitmq
postedOct 24, '11 at 9:19a
activeOct 24, '11 at 11:01a
posts3
users2
websiterabbitmq.com
irc#rabbitmq

2 users in discussion

Marek Majkowski: 2 posts _-^明 z--: 1 post

People

Translate

site design / logo © 2022 Grokbase