After some time trying why the explanations at http://www.rabbitmq.com/ssl.html
didn't work for me without any error message, just the

started SSL Listener on ?:5671

never appearing in the log,

I eventually discovered that the working syntax for the
ssl_listeners in rabbitmq.config is the one specifying the interface explicitly:

{ssl_listeners, [{"127.0.0.1", 5671}] },

and not

{ssl_listeners, [5671] },

Env. : OpenSuse LE 11.3 (in VM under OS X 10.6)

Could be useful to update the documentation:

"Some Linux config may require the interface to be explicitly specified".

("Why" is still an opened question, if somebody knows?)

Search Discussions

  • Simon MacMullen at Oct 10, 2011 at 2:28 pm

    On 10/10/11 15:19, Pascal Pochet wrote:
    After some time trying why the explanations at http://www.rabbitmq.com/ssl.html
    didn't work for me without any error message, just the

    started SSL Listener on ?:5671

    never appearing in the log,

    I eventually discovered that the working syntax for the
    ssl_listeners in rabbitmq.config is the one specifying the interface explicitly:

    {ssl_listeners, [{"127.0.0.1", 5671}] },

    and not

    {ssl_listeners, [5671] },
    Is this with a recent RabbitMQ version? Older versions require the first
    variant.
    Env. : OpenSuse LE 11.3 (in VM under OS X 10.6)

    Could be useful to update the documentation:

    "Some Linux config may require the interface to be explicitly specified".

    ("Why" is still an opened question, if somebody knows?)
    I'd rather fix the problem, assuming we can find out what it is...

    Cheers, Simon

    --
    Simon MacMullen
    RabbitMQ, VMware
  • Simon MacMullen at Oct 11, 2011 at 9:38 am

    On 10/10/11 19:19, Pascal Pochet wrote:
    Yes it's a recent version:

    otp R14B03
    Rabbit 2.2.0-2.2
    Not recent enough I'm afraid - we changed the way that configuration
    parameter worked when we added IPv6 support in 2.3.0. Before that it
    needed the {IPAddress, Port} tuple.
    (don't miss the point: without the host address the server runs fine, but only on non-SSL port 5672)
    I suspect the broker is failing to read the tcp_listeners configuration
    and defaulting to {"0.0.0.0", 5672}.

    Cheers, Simon
    to find out what it is, it will probably require logging at low level in Erlang itself,
    I suspect low level Unix functions to return something weird when running under a VM
    (currently a Parallels-one but I will try converting to VMWare format and compare?)
    (or a bzero of inet struct missing somewhere? )

    Note also the VM runs with bridged Ethernet-2 port assigned to it (MacPro has 2 Ethernet ports)
    while the Mac OS X host itself is connected to network thru Ethernet-1.

    Anyway even if the solution is trivial, the cause should be found
    to be sure no subtle problem may further prevent hassle-free deployment on VMs in general.

    So sharing of experiences of SSL deployment under VMs of different distribution/different host hardware and OS is welcome?


    Pascal P. Pochet
    P3 Consulting


    Le 10 oct. 2011 ? 16:28, Simon MacMullen a ?crit :
    On 10/10/11 15:19, Pascal Pochet wrote:
    After some time trying why the explanations at http://www.rabbitmq.com/ssl.html
    didn't work for me without any error message, just the

    started SSL Listener on ?:5671

    never appearing in the log,

    I eventually discovered that the working syntax for the
    ssl_listeners in rabbitmq.config is the one specifying the interface explicitly:

    {ssl_listeners, [{"127.0.0.1", 5671}] },

    and not

    {ssl_listeners, [5671] },
    Is this with a recent RabbitMQ version? Older versions require the first variant.
    Env. : OpenSuse LE 11.3 (in VM under OS X 10.6)

    Could be useful to update the documentation:

    "Some Linux config may require the interface to be explicitly specified".

    ("Why" is still an opened question, if somebody knows?)
    I'd rather fix the problem, assuming we can find out what it is...

    Cheers, Simon

    --
    Simon MacMullen
    RabbitMQ, VMware
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

    --
    Simon MacMullen
    RabbitMQ, VMware

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprabbitmq-discuss @
categoriesrabbitmq
postedOct 10, '11 at 2:19p
activeOct 11, '11 at 9:38a
posts3
users2
websiterabbitmq.com
irc#rabbitmq

2 users in discussion

Simon MacMullen: 2 posts Pascal Pochet: 1 post

People

Translate

site design / logo © 2022 Grokbase