Please advise Code Compile error while upgrading rabbitmq 2.4.1 to 2.5.0.

[INFO] Compilation failure

/home/asandhu/kno-workflow/agents/wf-content/src/main/java/com/kno/consumer/ContentProducer.java:[57,51]
<anonymous com.kno.consumer.ContentProducer$1> is not abstract and does not
override abstract method
handleReturn(int,java.lang.String,java.lang.String,java.lang.String,com.rabbitmq.client.AMQP.BasicProperties,byte[])
in com.rabbitmq.client.ReturnListener

/home/asandhu/kno-workflow/agents/wf-content/src/main/java/com/kno/consumer/ContentDownloadConsumer.java:[617,55]
<anonymous com.kno.consumer.ContentDownloadConsumer$1> is not abstract and
does not override abstract method
handleReturn(int,java.lang.String,java.lang.String,java.lang.String,com.rabbitmq.client.AMQP.BasicProperties,byte[])
in com.rabbitmq.client.ReturnListener

/home/asandhu/kno-workflow/agents/wf-content/src/main/java/com/kno/consumer/ContentDownloadConsumer.java:[618,12]
method does not override or implement a method from a supertype


Thanks,
Amarjinder
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20110624/9981210e/attachment.htm>

Search Discussions

  • Joseph Marlin at Jun 24, 2011 at 7:36 pm
    I'm not sure of the exact issue here, but I did have some issues with the
    update and the BasicProperties parts of my code as well when I went from
    2.4.1 to 2.5.0.

    http://www.rabbitmq.com/javadoc/com/rabbitmq/client/BasicProperties.html
    http://www.rabbitmq.com/javadoc/com/rabbitmq/client/impl/AMQBasicProperties.html
    http://www.rabbitmq.com/javadoc/com/rabbitmq/client/AMQP.BasicProperties.html

    These pages helped me through it though, my problem seems to be something
    similar to what you are facing.

    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20110624/8bc695f6/attachment.htm>
  • Matthias Radestock at Jun 27, 2011 at 9:22 am
    Amarjinder,
    On 24/06/11 19:46, Amarjinder Sandhu wrote:
    Please advise Code Compile error while upgrading rabbitmq 2.4.1 to 2.5.0.

    [INFO] Compilation failure

    /home/asandhu/kno-workflow/agents/wf-content/src/main/java/com/kno/consumer/ContentProducer.java:[57,51]
    <anonymous com.kno.consumer.ContentProducer$1> is not abstract and does
    not override abstract method
    handleReturn(int,java.lang.String,java.lang.String,java.lang.String,com.rabbitmq.client.AMQP.BasicProperties,byte[])
    in com.rabbitmq.client.ReturnListener
    I suspect you get the above because ReturnListener.handleBasicReturn got
    renamed to handleReturn. But that happened in 2.4.0, so it's strange
    that you are running into this only now.

    Regards,

    Matthias.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprabbitmq-discuss @
categoriesrabbitmq
postedJun 24, '11 at 6:46p
activeJun 27, '11 at 9:22a
posts3
users3
websiterabbitmq.com
irc#rabbitmq

People

Translate

site design / logo © 2022 Grokbase