Hi,

I have an RHEL5.6 Server and I installed rabbitmq 2.4.0 today.
When trying to enable the management plugin, I got the following
error:

Activating RabbitMQ plugins ...
ERROR: generation of boot script file /var/lib/rabbitmq/mnesia/
rabbit at ovl-db03-plugins-expand/rabbit.script failed:
{{module_not_found,mochiweb,mochiweb_request_tests},
{mochiweb_request_tests,'$$ignore$$',mochiweb,"1.4.1",
"/usr/lib/erlang/lib/mochiweb-1.4.1/ebin"}}

It seems I have erlang-mochiweb 1.4.1 installed (it is required as
dependency for another application), but the management plugin depends
on the mochiweb 1.3 (as far as I can tell from unzipping the
mochiweb-2.4.0.ez and looking at the mochiweb.app file).

Am I correct to understand that rabbitmq (incorrectly) tries to use
the installed erlang-mochiweb 1.4.1 rpm instead of the plugin
mochiweb-2.4.0.ez?

Any idea how I can solve this issue?

Thanks in advance,

Jeroen Janssen

Search Discussions

  • Simon MacMullen at Apr 6, 2011 at 10:37 am
    Hi Jeroen.
    On 06/04/11 11:12, Jeroen Janssen wrote:
    It seems I have erlang-mochiweb 1.4.1 installed (it is required as
    dependency for another application), but the management plugin depends
    on the mochiweb 1.3 (as far as I can tell from unzipping the
    mochiweb-2.4.0.ez and looking at the mochiweb.app file).
    Yeah, we should make that clearer (and hopefully will soon, there are
    some cleanups to our packaging coming).
    Am I correct to understand that rabbitmq (incorrectly) tries to use
    the installed erlang-mochiweb 1.4.1 rpm instead of the plugin
    mochiweb-2.4.0.ez?
    Ouch.

    Yes, it looks like we're picking up the Mochiweb from the RPM. The
    trouble is, there's no very obvious way to avoid doing that - looks like
    that RPM is installing Mochiweb into the standard Erlang lib location,
    so I don't see how we could avoid seeing it.

    I don't think that's a terribly good way to package Erlang code as it
    forces that version on everything on the system.

    We'll have a look and see if there's any way for the boot script builder
    to work around this, but I'm not too hopeful.

    I admit I haven't been keeping up with Mochiweb changes, but what
    happens if you remove the Mochiweb .ez and try to run with 1.4.1?

    Cheers, Simon

    --
    Simon MacMullen
    Staff Engineer, RabbitMQ
    SpringSource, a division of VMware
  • Jeroen Janssen at Apr 6, 2011 at 10:51 am
    Hi,
    On Apr 6, 12:37?pm, Simon MacMullen wrote:
    I admit I haven't been keeping up with Mochiweb changes, but what
    happens if you remove the Mochiweb .ez and try to run with 1.4.1?
    Thanks for this suggestion!

    I removed the mochiweb.ez file and rabbitmq starts up without any
    issues and I can now view the management console aswell!

    Best regards,

    Jeroen Janssen
  • Matthias Radestock at Apr 6, 2011 at 12:40 pm

    On 06/04/11 11:51, Jeroen Janssen wrote:
    On Apr 6, 12:37 pm, Simon MacMullenwrote:
    I admit I haven't been keeping up with Mochiweb changes, but what
    happens if you remove the Mochiweb .ez and try to run with 1.4.1?
    Thanks for this suggestion!

    I removed the mochiweb.ez file and rabbitmq starts up without any
    issues and I can now view the management console aswell!
    FWIW, the error you were getting actually indicates a problem with the
    mochiweb rpm. Specifically, the mochiweb.app file in the rpm contains a
    reference to a mochiweb_request_tests module but no such module is
    included in the rpm. I am cc'ing the Peter Lemenkov, the package maintainer.

    Regards,

    Matthias.
  • Peter Lemenkov at Apr 7, 2011 at 7:29 am
    Hello Jeroen.

    2011/4/6 Jeroen Janssen <jeroen.janssen at gmail.com>:
    Hi,

    I have an RHEL5.6 Server and I installed rabbitmq 2.4.0 today.
    When trying to enable the management plugin, I got the following
    error:

    Activating RabbitMQ plugins ...
    ERROR: generation of boot script file /var/lib/rabbitmq/mnesia/
    rabbit at ovl-db03-plugins-expand/rabbit.script failed:
    {{module_not_found,mochiweb,mochiweb_request_tests},
    ?{mochiweb_request_tests,'$$ignore$$',mochiweb,"1.4.1",
    ? ? ? ? ? ? ? ? ? ? ? ? "/usr/lib/erlang/lib/mochiweb-1.4.1/ebin"}}

    That's a known issue - please, upgrade to latest build from epel-testing:

    sudo yum upgrade erlang-mochiweb --enablerepo epel-testing

    And sorry for the inconvenience.

    --
    With best regards, Peter Lemenkov.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprabbitmq-discuss @
categoriesrabbitmq
postedApr 6, '11 at 10:12a
activeApr 7, '11 at 7:29a
posts5
users4
websiterabbitmq.com
irc#rabbitmq

People

Translate

site design / logo © 2022 Grokbase