Hello,



Could use some assistance in installing RabbitMQ.



OS: RHEL 4

RabbitMQ server-2.3.1-1.noarch.rpm

erlang R14B01 or R12B-3



I installed erlang R14B01 from source to default location and tested
successfully. Then I performed a test install of the RabbitMQ rpm, but
receive a dependency error

stating that erlang R12B-3 is required, but noted on the RabbitMQ
download page R12b-3 and up is supported. I removed R14B01 and installed

R12B-3 to default location tested successfully and still same dependency
error when trying to install the RabbitMQ rpm.



Thanks

-John







-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20110308/c692cc4f/attachment-0001.htm>

Search Discussions

  • Emile Joubert at Mar 9, 2011 at 9:58 am
    Hi John,

    On 09/03/11 00:03, John Beaulaurier -X (jbeaulau - Advanced Network Info
    at Cisco) wrote:

    I installed erlang R14B01 from source to default location and tested
    successfully. Then I performed a test install of the RabbitMQ rpm, but
    receive a dependency error
    This is a package management issue. If you built Erlang R14B01 from
    source instead of installing it from a package then the package manager
    has no way of knowing that the dependency has been met. One way of
    getting around this is to turn off dependency checking when installing
    the RabbitMQ rpm. The RPM website has more information about dependency
    management: http://rpm.org/

    Some users have also had some success installing from a modified Erlang
    SRPM:
    http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/2011-January/010629.html

    If you have a choice between R14B01 and R12B-3 then use R14B01.


    Regards

    Emile
  • Simon MacMullen at Mar 9, 2011 at 11:01 am

    On 09/03/11 09:58, Emile Joubert wrote:
    Some users have also had some success installing from a modified Erlang
    SRPM:
    http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/2011-January/010629.html
    Actually there is now a binary RPM for R14B01 available.

    Mentioned here:
    http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/2011-February/011117.html

    I think you just add http://repos.fedorapeople.org/repos/peter/erlang/
    to yum, although I'm not a RHEL / CentOS user.
    If you have a choice between R14B01 and R12B-3 then use R14B01.
    Very much so.

    Cheers, Simon

    --
    Simon MacMullen
    Staff Engineer, RabbitMQ
    SpringSource, a division of VMware
  • Brendan Doyle at Mar 9, 2011 at 2:41 pm
    John

    I believe It is looking for an installed erlang rpm. If you have installed erlang from source because there is no suitably up to date erlang package for your distribution, that's fine. As long as the erlang binaries are in the global PATH, you can install the rabbitmq rpm with '--nodeps' option and it works fine. At least in my experience so far ;)

    Brendan

    From: "John Beaulaurier -X (jbeaulau - Advanced Network Info at Cisco)" <jbeaulau at cisco.com<mailto:jbeaulau at cisco.com>>
    Date: Tue, 8 Mar 2011 18:03:55 -0600
    To: "rabbitmq-discuss at lists.rabbitmq.com<mailto:rabbitmq-discuss at lists.rabbitmq.com>" <rabbitmq-discuss at lists.rabbitmq.com<mailto:rabbitmq-discuss at lists.rabbitmq.com>>
    Subject: [rabbitmq-discuss] Install error erlang not found but is installed

    Hello,

    Could use some assistance in installing RabbitMQ.

    OS: RHEL 4
    RabbitMQ server-2.3.1-1.noarch.rpm
    erlang R14B01 or R12B-3

    I installed erlang R14B01 from source to default location and tested successfully. Then I performed a test install of the RabbitMQ rpm, but receive a dependency error
    stating that erlang R12B-3 is required, but noted on the RabbitMQ download page R12b-3 and up is supported. I removed R14B01 and installed
    R12B-3 to default location tested successfully and still same dependency error when trying to install the RabbitMQ rpm.

    Thanks
    -John



    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20110309/6d81268d/attachment.htm>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprabbitmq-discuss @
categoriesrabbitmq
postedMar 9, '11 at 12:03a
activeMar 9, '11 at 2:41p
posts4
users4
websiterabbitmq.com
irc#rabbitmq

People

Translate

site design / logo © 2022 Grokbase