Grokbase Groups R r-devel April 2004
FAQ
Full_Name: rodney sparapani
Version: 1.9.0
OS: Solaris 9
Submission from: (NULL) (141.106.120.97)


I'm following the instructions for the Sun Forte compiler. I had success with
1.8.1 so I think the compiler settings are correct (config.site):
CC="cc -xarch=v8plusa"
CFLAGS="-xO5 -xlibmil -dalign"
F77="f95 -xarch=v8plusa"
FFLAGS="-xO5 -xlibmil -dalign"
CXX="CC -xarch=v8plusa"
CXXFLAGS="-xO5 -xlibmil -dalign"
Actually, there is one thing that I didn't specify above, but I'm not sure how.
The Sun Performance library is a BLAS library. In LAPACK, you specify it as
BLASLIB ="-xlic_lib=sunperf"
Is there a simple way to specify that in config.site? Anyways, that's probably
not the problem that I'm having, but if you have any advice...
Here's the real problem, make fails at:
MAKE="make" R_LIBS= ../../../bin/R CMD INSTALL -l ../../../library foreign.tgz
* Installing *source* package 'foreign' ...
checking for gcc... make[3]: Entering directory `/tmp/R.INSTALL.8673/foreign'
cc -xarch=v8plusa
make[3]: Leaving directory `/tmp/R.INSTALL.8673/foreign'
checking for C compiler default output... configure: error: C compiler cannot
create executables
See `config.log' for more details.
error: configuration failed for package 'foreign': No such file or directory for
reading errors.
** Removing '/fw/src/R/R-1.9.0/library/foreign'
make[2]: *** [foreign.ts] Error 1
make[2]: Leaving directory `/fw/src/R/R-1.9.0/src/library/Recommended'
make[1]: *** [recommended-packages] Error 2
make[1]: Leaving directory `/fw/src/R/R-1.9.0/src/library/Recommended'
make: *** [stamp-recommended] Error 2

foreign seems to be having a compiler problem that other recommended packages
did not. Any ideas?

Search Discussions

  • Prof Brian Ripley at Apr 23, 2004 at 8:32 pm
    The instructions in R-admin *have* been tested. It does tell you how to
    specify the sunperf BLAS, so please read it -- it probably even selects it
    by default.

    I don't see any evidence of a bug in R here, rather of a problem in your
    setup. Please seek local advice. My suspicion is that you want
    "-xarch=v8plusa" in CFLAGS and not in CC.

    You might want to try untaring foreign and installing it, then looking at
    config.log.

    Please ask questions on R-help not R-bugs: the R FAQ explains rather
    plainly when R-bugs is appropriate.

    On Fri, 23 Apr 2004 rsparapa@mcw.edu wrote:

    Full_Name: rodney sparapani
    Version: 1.9.0
    OS: Solaris 9
    Submission from: (NULL) (141.106.120.97)


    I'm following the instructions for the Sun Forte compiler. I had success with
    1.8.1 so I think the compiler settings are correct (config.site):
    CC="cc -xarch=v8plusa"
    CFLAGS="-xO5 -xlibmil -dalign"
    F77="f95 -xarch=v8plusa"
    FFLAGS="-xO5 -xlibmil -dalign"
    CXX="CC -xarch=v8plusa"
    CXXFLAGS="-xO5 -xlibmil -dalign"
    Actually, there is one thing that I didn't specify above, but I'm not sure how.
    The Sun Performance library is a BLAS library. In LAPACK, you specify it as
    BLASLIB ="-xlic_lib=sunperf"
    Is there a simple way to specify that in config.site? Anyways, that's probably
    not the problem that I'm having, but if you have any advice...
    Here's the real problem, make fails at:
    MAKE="make" R_LIBS= ../../../bin/R CMD INSTALL -l ../../../library foreign.tgz
    * Installing *source* package 'foreign' ...
    checking for gcc... make[3]: Entering directory `/tmp/R.INSTALL.8673/foreign'
    cc -xarch=v8plusa
    make[3]: Leaving directory `/tmp/R.INSTALL.8673/foreign'
    checking for C compiler default output... configure: error: C compiler cannot
    create executables
    See `config.log' for more details.
    error: configuration failed for package 'foreign': No such file or directory for
    reading errors.
    ** Removing '/fw/src/R/R-1.9.0/library/foreign'
    make[2]: *** [foreign.ts] Error 1
    make[2]: Leaving directory `/fw/src/R/R-1.9.0/src/library/Recommended'
    make[1]: *** [recommended-packages] Error 2
    make[1]: Leaving directory `/fw/src/R/R-1.9.0/src/library/Recommended'
    make: *** [stamp-recommended] Error 2

    foreign seems to be having a compiler problem that other recommended packages
    did not. Any ideas?

    ______________________________________________
    r-devel@stat.math.ethz.ch mailing list
    https://www.stat.math.ethz.ch/mailman/listinfo/r-devel
    --
    Brian D. Ripley, ripley@stats.ox.ac.uk
    Professor of Applied Statistics, http://www.stats.ox.ac.uk/~ripley/
    University of Oxford, Tel: +44 1865 272861 (self)
    1 South Parks Road, +44 1865 272866 (PA)
    Oxford OX1 3TG, UK Fax: +44 1865 272595
  • Prof Brian Ripley at Apr 24, 2004 at 6:50 pm
    Why is this a bug report. The instruction in R-admin work here with Sun
    Forte compilers. However, you did not follow them.
    On Fri, 23 Apr 2004 rsparapa@mcw.edu wrote:

    Full_Name: rodney sparapani
    Version: 1.9.0
    OS: Solaris 9
    Submission from: (NULL) (141.106.120.97)


    I'm following the instructions for the Sun Forte compiler. I had success with
    1.8.1 so I think the compiler settings are correct (config.site):
    CC="cc -xarch=v8plusa"
    CFLAGS="-xO5 -xlibmil -dalign"
    F77="f95 -xarch=v8plusa"
    FFLAGS="-xO5 -xlibmil -dalign"
    CXX="CC -xarch=v8plusa"
    CXXFLAGS="-xO5 -xlibmil -dalign"
    Actually, there is one thing that I didn't specify above, but I'm not sure how.
    The Sun Performance library is a BLAS library. In LAPACK, you specify it as
    BLASLIB ="-xlic_lib=sunperf"
    Is there a simple way to specify that in config.site? Anyways, that's probably
    not the problem that I'm having, but if you have any advice...
    Here's the real problem, make fails at:
    MAKE="make" R_LIBS= ../../../bin/R CMD INSTALL -l ../../../library foreign.tgz
    * Installing *source* package 'foreign' ...
    checking for gcc... make[3]: Entering directory `/tmp/R.INSTALL.8673/foreign'
    cc -xarch=v8plusa
    make[3]: Leaving directory `/tmp/R.INSTALL.8673/foreign'
    checking for C compiler default output... configure: error: C compiler cannot
    create executables
    See `config.log' for more details.
    error: configuration failed for package 'foreign': No such file or directory for
    reading errors.
    ** Removing '/fw/src/R/R-1.9.0/library/foreign'
    make[2]: *** [foreign.ts] Error 1
    make[2]: Leaving directory `/fw/src/R/R-1.9.0/src/library/Recommended'
    make[1]: *** [recommended-packages] Error 2
    make[1]: Leaving directory `/fw/src/R/R-1.9.0/src/library/Recommended'
    make: *** [stamp-recommended] Error 2

    foreign seems to be having a compiler problem that other recommended packages
    did not. Any ideas?

    ______________________________________________
    r-devel@stat.math.ethz.ch mailing list
    https://www.stat.math.ethz.ch/mailman/listinfo/r-devel
    --
    Brian D. Ripley, ripley@stats.ox.ac.uk
    Professor of Applied Statistics, http://www.stats.ox.ac.uk/~ripley/
    University of Oxford, Tel: +44 1865 272861 (self)
    1 South Parks Road, +44 1865 272866 (PA)
    Oxford OX1 3TG, UK Fax: +44 1865 272595
  • Prof Brian Ripley at Apr 24, 2004 at 6:52 pm
    Sorry, sent in error: this was an earlier draft that got interrupted and I
    have already sent a more complete answer.
    On Sat, 24 Apr 2004, Prof Brian Ripley wrote:

    Why is this a bug report. The instruction in R-admin work here with Sun
    Forte compilers. However, you did not follow them.
    That means the CC etc are different from those in R-admin.
    On Fri, 23 Apr 2004 rsparapa@mcw.edu wrote:

    Full_Name: rodney sparapani
    Version: 1.9.0
    OS: Solaris 9
    Submission from: (NULL) (141.106.120.97)


    I'm following the instructions for the Sun Forte compiler. I had success with
    1.8.1 so I think the compiler settings are correct (config.site):
    CC="cc -xarch=v8plusa"
    CFLAGS="-xO5 -xlibmil -dalign"
    F77="f95 -xarch=v8plusa"
    FFLAGS="-xO5 -xlibmil -dalign"
    CXX="CC -xarch=v8plusa"
    CXXFLAGS="-xO5 -xlibmil -dalign"
    Actually, there is one thing that I didn't specify above, but I'm not sure how.
    The Sun Performance library is a BLAS library. In LAPACK, you specify it as
    BLASLIB ="-xlic_lib=sunperf"
    Is there a simple way to specify that in config.site? Anyways, that's probably
    not the problem that I'm having, but if you have any advice...
    Here's the real problem, make fails at:
    MAKE="make" R_LIBS= ../../../bin/R CMD INSTALL -l ../../../library foreign.tgz
    * Installing *source* package 'foreign' ...
    checking for gcc... make[3]: Entering directory `/tmp/R.INSTALL.8673/foreign'
    cc -xarch=v8plusa
    make[3]: Leaving directory `/tmp/R.INSTALL.8673/foreign'
    checking for C compiler default output... configure: error: C compiler cannot
    create executables
    See `config.log' for more details.
    error: configuration failed for package 'foreign': No such file or directory for
    reading errors.
    ** Removing '/fw/src/R/R-1.9.0/library/foreign'
    make[2]: *** [foreign.ts] Error 1
    make[2]: Leaving directory `/fw/src/R/R-1.9.0/src/library/Recommended'
    make[1]: *** [recommended-packages] Error 2
    make[1]: Leaving directory `/fw/src/R/R-1.9.0/src/library/Recommended'
    make: *** [stamp-recommended] Error 2

    foreign seems to be having a compiler problem that other recommended packages
    did not. Any ideas?

    ______________________________________________
    r-devel@stat.math.ethz.ch mailing list
    https://www.stat.math.ethz.ch/mailman/listinfo/r-devel
    --
    Brian D. Ripley, ripley@stats.ox.ac.uk
    Professor of Applied Statistics, http://www.stats.ox.ac.uk/~ripley/
    University of Oxford, Tel: +44 1865 272861 (self)
    1 South Parks Road, +44 1865 272866 (PA)
    Oxford OX1 3TG, UK Fax: +44 1865 272595

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupr-devel @
categoriesr
postedApr 23, '04 at 8:07p
activeApr 24, '04 at 6:52p
posts4
users2
websiter-project.org
irc#r

2 users in discussion

Prof Brian Ripley: 3 posts Rsparapa: 1 post

People

Translate

site design / logo © 2022 Grokbase