FAQ

PIL will compile and install if you don't have some development
libraries and then simply not work or not work up to full steam when
used.

To avoid this, you need to install the appropriate libraries, among
which are:

libjpeg-devel
freetype-devel
libpng-devel
Dear Albert

Thank you for your reply.
I did install all these libraries.
Testing it with yum shows:

$ yum install libpng-devel
Package 2:libpng-devel-1.2.10-7.1.el5_5.3.x86_64 already installed and
latest version
Package 2:libpng-devel-1.2.10-7.1.el5_5.3.i386 already installed and
latest version

$ yum install libjpeg-devel
Package libjpeg-devel-6b-37.x86_64 already installed and latest version
Package libjpeg-devel-6b-37.i386 already installed and latest version

$ yum install libpng-devel
Package 2:libpng-devel-1.2.10-7.1.el5_5.3.x86_64 already installed and
latest version
Package 2:libpng-devel-1.2.10-7.1.el5_5.3.i386 already installed and
latest version


Re-Compiling PIL shows:

$ python setup.py build_ext -i

--------------------------------------------------------------------
*** TKINTER support not available
--- JPEG support available
--- ZLIB (PNG/ZIP) support available
--- FREETYPE2 support available
*** LITTLECMS support not available
--------------------------------------------------------------------

However, running the selftest still fails:
$ python selftest.py
*** The _imaging C module is not installed

Regards
Nico

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedMay 6, '11 at 6:55a
activeMay 6, '11 at 6:55a
posts1
users1
websitepython.org

1 user in discussion

Nico Grubert: 1 post

People

Translate

site design / logo © 2022 Grokbase