FAQ
Hello,

I'm to plot some results but it doesn't work.
I got this error :

/usr/local/libre_rep/python-2.6.1/RHEL_5__x86_64/lib/python2.6/site-
packages/matplotlib/backends/__init__.py:41: UserWarning:
Your currently selected backend, 'agg' does not support show().
Please select a GUI backend in your matplotlibrc file ('/usr/local/
libre_rep/python-2.6.1/RHEL_5__x86_64/lib/python2.6/site-packages/
matplotlib/mpldata/matplotlibrc')
or with matplotlib.use()

Any idea to fix it ?

Thanks

Search Discussions

  • Baloan at Aug 25, 2009 at 9:52 am

    On Aug 25, 10:12?am, Pierre wrote:
    Hello,

    I'm to plot some results but it doesn't work.
    I got this error :

    /usr/local/libre_rep/python-2.6.1/RHEL_5__x86_64/lib/python2.6/site-
    packages/matplotlib/backends/__init__.py:41: UserWarning:
    Your currently selected backend, 'agg' does not support show().
    Please select a GUI backend in your matplotlibrc file ('/usr/local/
    libre_rep/python-2.6.1/RHEL_5__x86_64/lib/python2.6/site-packages/
    matplotlib/mpldata/matplotlibrc')
    or with matplotlib.use()

    Any idea to fix it ?

    Thanks
    Try:

    import matplotlib
    matplotlib.use('TkAgg')

    before coding anything else

    from the examples section of the matplotlib documentation
    http://matplotlib.sourceforge.net/examples/user_interfaces/embedding_in_tk.html

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedAug 25, '09 at 8:12a
activeAug 25, '09 at 9:52a
posts2
users2
websitepython.org

2 users in discussion

Pierre: 1 post Baloan: 1 post

People

Translate

site design / logo © 2022 Grokbase