FAQ
So 0.9 is getting in shape and there is one issue that keeps me from
releasing 0.9 and that is the upgrade path. 0.9 is vastely different
from 0.8 so a special upgrade script has been written to aid with
this. Now i have tested this on some gozerbot users but i need a more
broader audience that wants to test this for me. So if you run a 0.8
gozerbot you could help me out with testing the 0.9 upgrade script,
testing can be done along side your own bot so you dont loose your old
configuration.

To test do the following:

1) hg clone http://core.gozerbot.org/hg/dev/0.9 0.9bot
2) cd 0.9bot
3) hg clone http://core.gozerbot.org/hg/plugs/gozerplugs
4) ./bin/gozerbot-upgrade <oldbotdir> .
5) ./bin/gozerbot

Check if the bot has converted your data properly with the !size
command. As a last step you can test the plugins with the !test-plugs
command.
If you have any problems with testing gozerbot 0.9 let me know on
#dunkbots IRCnet or at bthate at gmail.com .. THNX ;]

Bart

see http://gozerbot.org/newsite/0.9/ for more information about the
upcoming 0.9 release

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedJan 2, '09 at 10:04p
activeJan 2, '09 at 10:04p
posts1
users1
websitepython.org

1 user in discussion

Bart Thate: 1 post

People

Translate

site design / logo © 2022 Grokbase