FAQ
I am trying to install mysqldb-1.2.2 on my PPC running 10.5.2 and
Activepython 2.5.1.1
when I get this error:

running build
running build_py
copying MySQLdb/release.py -> build/lib.macosx-10.3-fat-2.5/MySQLdb
running build_ext
building '_mysql' extension
gcc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -
Wno-long-double -no-cpp-precomp -mno-fused-madd -fPIC -fno-common -
dynamic -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -
Dversion_info=(1,2,2,'final',0) -D__version__=1.2.2 -I/usr/local/mysql/
include -I/Library/Frameworks/Python.framework/Versions/2.5/include/
python2.5 -c _mysql.c -o build/temp.macosx-10.3-fat-2.5/_mysql.o -g -
Os -arch ppc64 -fno-common -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE
-DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT -
DDONT_DECLARE_CXA_PURE_VIRTUAL
In file included from /Library/Frameworks/Python.framework/Versions/
2.5/include/python2.5/Python.h:57,
from pymemcompat.h:10,
from _mysql.c:29:
/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5/
pyport.h:734:2: error: #error "LONG_BIT definition appears wrong for
platform (bad gcc/glibc config?)."
In file included from _mysql.c:35:
/usr/local/mysql/include/my_config.h:1095:1: warning: "SIZEOF_LONG"
redefined
In file included from /Library/Frameworks/Python.framework/Versions/
2.5/include/python2.5/Python.h:8,
from pymemcompat.h:10,
from _mysql.c:29:
/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5/
pyconfig.h:807:1: warning: this is the location of the previous
definition
error: command 'gcc' failed with exit status 1

Anyone know what is going on?

Cheers
Tommy

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedMay 29, '08 at 3:02p
activeMay 29, '08 at 3:02p
posts1
users1
websitepython.org

1 user in discussion

Tommy Grav: 1 post

People

Translate

site design / logo © 2022 Grokbase