FAQ
Hi,
I am new on everything about web development. I did many things to get the
error at the end.
My system has Apache 1.3 by default. I could install Apache 2.2 with no
problem. I had to change all binaries in /usr/bin and /usr/sbin to new
apache binaries. All ok. System came with python 2.3.1. I removed everything
related to 2.3.1 and installed python 2.5.1.
Then compiled mod_python successfully with parameters: ./configure
--apxs=/usr/sbin/apxs --python=/usr/bin/python
make
sudo make install
sudo make install_dso
$ python -V
Python 2.5.1
$ strings /usr/local/apache2/modules/mod_python.so =>
python_init
mod_python/3.3.1
2.5.1
$ env |grep PATH
PATH=/Library/Frameworks/Python.framework/Versions/Current/bin:/bin:/sbin:/usr/bin:/usr/sbin

$ sudo apachectl start
httpd: Syntax error on line 54 of /usr/local/apache2/conf/httpd.conf: Cannot
load /usr/local/apache2/modules/mod_python.so into server: Library not
loaded: /System/Library/Frameworks/Python.framework/Versions/2.3/Python\n
Referenced from: /usr/local/apache2/modules/mod_python.so\n Reason: image
not found
/usr/sbin/apachectl start: httpd could not be started


How is it possible that LoadModule still seek at path Versions/2.3 ?

Regards,
Deniz
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/python-list/attachments/20080201/bef0ac48/attachment.htm

Search Discussions

  • Pnrdnz at Feb 1, 2008 at 11:48 pm
    I could correct version mismatch by handling files under:

    $ ls -l /usr/lib |grep python
    lrwxr-xr-x 1 root wheel 16 Feb 2 01:17 libpython.dy ->
    libpython2.dylib
    lrwxr-xr-x 1 root wheel 16 Feb 2 01:11 libpython2.5.dylib ->
    libpython2.dylib
    lrwxr-xr-x 1 root wheel 72 Feb 2 01:11 libpython2.dylib ->
    ../../System/Library/Frameworks/Python.framework/Versions/Current/Python
    lrwxr-xr-x 1 root wheel 79 Feb 2 01:10 python2.5 ->
    ../../System/Library/Frameworks/Python.framework/Versions/Current/lib/python2.5

    /Developer/SDKs/MacOSX10.4u.sdk/usr/include and
    /Developer/SDKs/MacOSX10.4u.sdk/System/Library/Frameworks/Python.framework/Versions
    Then re-compile apache & mod_python ..

    Regards,
    Deniz
    On Feb 1, 2008 11:47 PM, wrote:

    Hi,
    I am new on everything about web development. I did many things to get the
    error at the end.
    My system has Apache 1.3 by default. I could install Apache 2.2 with no
    problem. I had to change all binaries in /usr/bin and /usr/sbin to new
    apache binaries. All ok. System came with python 2.3.1. I removed
    everything related to 2.3.1 and installed python 2.5.1.
    Then compiled mod_python successfully with parameters: ./configure
    --apxs=/usr/sbin/apxs --python=/usr/bin/python
    make
    sudo make install
    sudo make install_dso
    $ python -V
    Python 2.5.1
    $ strings /usr/local/apache2/modules/mod_python.so =>
    python_init
    mod_python/3.3.1
    2.5.1
    $ env |grep PATH

    PATH=/Library/Frameworks/Python.framework/Versions/Current/bin:/bin:/sbin:/usr/bin:/usr/sbin

    $ sudo apachectl start
    httpd: Syntax error on line 54 of /usr/local/apache2/conf/httpd.conf:
    Cannot load /usr/local/apache2/modules/mod_python.so into server: Library
    not loaded:
    /System/Library/Frameworks/Python.framework/Versions/2.3/Python\n
    Referenced from: /usr/local/apache2/modules/mod_python.so\n Reason: image
    not found
    /usr/sbin/apachectl start: httpd could not be started


    How is it possible that LoadModule still seek at path Versions/2.3 ?

    Regards,
    Deniz
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://mail.python.org/pipermail/python-list/attachments/20080202/b7ede03d/attachment.htm

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedFeb 1, '08 at 9:47p
activeFeb 1, '08 at 11:48p
posts2
users1
websitepython.org

1 user in discussion

Pnrdnz: 2 posts

People

Translate

site design / logo © 2022 Grokbase