FAQ
hi all

i have to use matplotlib on mac os x. on the official site of
matplotlib, i found a link to precompiled python packages for mac os x:

http://pythonmac.org/packages/py24-fat/index.html

so first, i installed python 2.4. that works great! if i type 'python'
in the terminal, it loads python 2.4.
after that, i loaded and installed the matplotlib package from this
site. if i type in python 'import matplotlib' no error appiers. so far,
so well...

so i went back to the tutorial page of matplotlib to crab a test... but
they use overall 'import pylab'. witch doesn't work in my python... so
i went back to the packages site again, loaded and installed numpy. now
hurray, python can do something with 'import pylab', but:

[code]
import pylab
RuntimeError: module compiled against version 1000009 of C-API but this
version of numpy is 1000002

The import of the numpy version of the _transforms module,
_ns_transforms, failed. This is is either because numpy was
unavailable when matplotlib was compiled, because a dependency of
_ns_transforms could not be satisfied, or because the build flag for
this module was turned off in setup.py. If it appears that
_ns_transforms was not built, make sure you have a working copy of
numpy and then re-install matplotlib. Otherwise, the following
traceback gives more details:

Traceback (most recent call last):
File "<stdin>", line 1, in ?
File
"/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/pylab.py",
line 1, in ?
from matplotlib.pylab import *
File
"/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/pylab.py",
line 201, in ?
from axes import Axes, PolarAxes
File
"/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/axes.py",
line 14, in ?
from artist import Artist, setp
File
"/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/artist.py",
line 4, in ?
from transforms import identity_transform
File
"/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/transforms.py",
line 223, in ?
from _transforms import Value, Point, Interval, Bbox, Affine
File
"/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/_transforms.py",
line 17, in ?
from matplotlib._ns_transforms import *
ImportError: numpy.core.multiarray failed to import
[/code]

The error tells me, i have to install the packages in right order. so i
did it again:

1. numarray
2. numpy
3. matplotlib

But after that, the same error message appiers. i was never so near
that it will works :(
Can anybody help me?

Big thanks!
spross

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedNov 3, '06 at 8:02a
activeNov 3, '06 at 8:02a
posts1
users1
websitepython.org

1 user in discussion

Spross: 1 post

People

Translate

site design / logo © 2022 Grokbase