FAQ
I'm using OS X 10.4.5. I have an easy problem that I can't solve:

I have two versions of python installed. 2.3 came with the OS and 2.4 I
installed via fink.

When I call python from the command-line it calls 2.4.
When I just call a *.py file like test.py, it calls 2.3.

1. How do I make both these kinds of calls work with 2.4.
2. How do I uninstall v. 2.3 completely.

Tnx

Search Discussions

  • Kevin Walzer at Mar 17, 2006 at 10:53 pm

    mailpitches at email.com wrote:
    1. How do I make both these kinds of calls work with 2.4.
    Try "/sw/bin/python foo.py" in the terminal and "#!/sw/bin/python" in
    your scripts.
    2. How do I uninstall v. 2.3 completely.
    Don't do that. It will break stuff in the OS that depends on Python.


    --
    Kevin Walzer
    iReveal: File Search Tool
    http://www.wordtech-software.com
  • Scott David Daniels at Mar 17, 2006 at 10:55 pm

    mailpitches at email.com wrote:
    I'm using OS X 10.4.5. I have an easy problem that I can't solve:
    I have two versions of python installed. 2.3 came with the OS and 2.4 I
    installed via fink....
    2. How do I uninstall v. 2.3 completely.
    Probably not the greatest idea, because pieces of OS X may actually use
    the internal Python 2.3.

    --Scott David Daniels
    scott.daniels at acm.org
  • Mailpitches at Mar 17, 2006 at 10:59 pm
    Thanks for the fast responses.>mp
  • Diez B. Roggisch at Mar 17, 2006 at 11:04 pm

    mailpitches at email.com schrieb:
    I'm using OS X 10.4.5. I have an easy problem that I can't solve:

    I have two versions of python installed. 2.3 came with the OS and 2.4 I
    installed via fink.
    That isn't the "proper" version. While it works, you certainly want the
    python 2.4 framework build. That is the specialized OS X variant. If you
    ever want to do work with e.g. PyObjC to create Cocoa-Apps you'll need
    that (AFAIK).
    When I call python from the command-line it calls 2.4.
    When I just call a *.py file like test.py, it calls 2.3.

    1. How do I make both these kinds of calls work with 2.4.
    2. How do I uninstall v. 2.3 completely.
    Bad idea. OS X needs that one.


    Diez

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedMar 17, '06 at 10:47p
activeMar 17, '06 at 11:04p
posts5
users4
websitepython.org

People

Translate

site design / logo © 2022 Grokbase