FAQ
Hello All,

I need a python module to do real time graphs so I chose Matplotlib. I
am trying to compile matplotlib at the moment and I have some problems,
well not really. It compiles fine, it's how it compiles that's the
problem. I am attempting to build it with the Tkinter backend as opposed
to the GTK+ backend. Whenever I build, install, and then try to import I
receive an error stating that my version of PyGTK needs to be updated.
Logically it shouldnt be looking for PyGTK if it is using the TKinter
backend? Any help would be appreciated.

Regards,
Kenneth Miller

Search Discussions

  • Robert Kern at Jun 8, 2005 at 7:53 am

    Kenneth Miller wrote:
    Hello All,

    I need a python module to do real time graphs so I chose Matplotlib. I
    am trying to compile matplotlib at the moment and I have some problems,
    well not really. It compiles fine, it's how it compiles that's the
    problem. I am attempting to build it with the Tkinter backend as opposed
    to the GTK+ backend. Whenever I build, install, and then try to import I
    receive an error stating that my version of PyGTK needs to be updated.
    Logically it shouldnt be looking for PyGTK if it is using the TKinter
    backend? Any help would be appreciated.
    A. You will get better help on the matplotlib mailing list.
    B. Have you edited your .matplotlibrc to use the TkAgg backend?

    --
    Robert Kern
    rkern at ucsd.edu

    "In the fields of hell where the grass grows high
    Are the graves of dreams allowed to die."
    -- Richard Harter

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedJun 8, '05 at 6:35a
activeJun 8, '05 at 7:53a
posts2
users2
websitepython.org

2 users in discussion

Robert Kern: 1 post Kenneth Miller: 1 post

People

Translate

site design / logo © 2022 Grokbase