FAQ
Hi all,

I have a python script that uses the PAMIE libraries to drive IE. It
runs fine from the command line, but it appears to have some
permissions problem when I run it via CGI. Here's the stack trace that
I'm getting.

File "c:\documents and settings\chris\my
documents\cms\com\artfact\cms\model\cPAMIE.py", line 54, in __init__
self._ie = DispatchEx('InternetExplorer.Application')
File "C:\Program Files\Plone
2\Python\lib\site-packages\win32com\client\__init__.py", line 112, in
DispatchEx
dispatch = pythoncom.CoCreateInstanceEx(clsid, None, clsctx,
serverInfo, (pythoncom.IID_IDispatch,))[0]
com_error: (-2147024891, 'Access is denied.', None, None)

I found this thread in the archives, but the changes made there don't
seem to have helped.

http://groups-beta.google.com/group/comp.lang.python/browse_thread/thread/3273ca109892b275/0da814cb9f341568?q=win32com+iis&rnum=2#0da814cb9f341568

Any suggestions?

Search Discussions

  • Chris Curvey at May 10, 2005 at 5:00 pm
    my OS is Win2K (server, I think) if that makes any difference.
  • Roger Upole at May 11, 2005 at 12:18 am
    Are you authenticating when you connect to the web server ?
    If you're connected as an anonymous user, you don't have
    enough privilege.

    Roger

    "Chris Curvey" <ccurvey at gmail.com> wrote in message
    news:1115744207.222691.276160 at f14g2000cwb.googlegroups.com...
    Hi all,

    I have a python script that uses the PAMIE libraries to drive IE. It
    runs fine from the command line, but it appears to have some
    permissions problem when I run it via CGI. Here's the stack trace that
    I'm getting.

    File "c:\documents and settings\chris\my
    documents\cms\com\artfact\cms\model\cPAMIE.py", line 54, in __init__
    self._ie = DispatchEx('InternetExplorer.Application')
    File "C:\Program Files\Plone
    2\Python\lib\site-packages\win32com\client\__init__.py", line 112, in
    DispatchEx
    dispatch = pythoncom.CoCreateInstanceEx(clsid, None, clsctx,
    serverInfo, (pythoncom.IID_IDispatch,))[0]
    com_error: (-2147024891, 'Access is denied.', None, None)

    I found this thread in the archives, but the changes made there don't
    seem to have helped.

    http://groups-beta.google.com/group/comp.lang.python/browse_thread/thread/3273ca109892b275/0da814cb9f341568?q=win32com+iis&rnum=2#0da814cb9f341568

    Any suggestions?


    ----== Posted via Newsfeeds.Com - Unlimited-Uncensored-Secure Usenet News==----
    http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
    ----= East and West-Coast Server Farms - Total Privacy via Encryption =----

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedMay 10, '05 at 4:56p
activeMay 11, '05 at 12:18a
posts3
users2
websitepython.org

2 users in discussion

Chris Curvey: 2 posts Roger Upole: 1 post

People

Translate

site design / logo © 2022 Grokbase