FAQ
I have installed Python-2.3.3 in the SUSE Linux 9.1 system and am
trying to rebuild an application rpm that was implemented in Python, I
got the following error when compiling the application extension
module,

/usr/Python-2.3.3/Include/pymem.h: In function '__declspec'
/usr/Python-2.3.3/Include/pymem.h:51: error: parse error before
'__declspec'
/usr/Python-2.3.3/Include/pymem.h:50: error: declaration for parameter
'PyMem_Malloc' but no such parameter

:

line 50 and 51 of pymem.h are the following,

PyAPI_FUNC(void*) PyMem_Malloc(size_t)
PYAPI_FUNC(void*) PyMem_Realloc(void *, size_t);

I thought '__declspec' was used to specify the Windows DLLs, but I am
running in the linux environment, do I need to run something else to
setup the correct environment first?

Thanks.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedMar 7, '05 at 11:49p
activeMar 7, '05 at 11:49p
posts1
users1
websitepython.org

1 user in discussion

Pythonnewbie: 1 post

People

Translate

site design / logo © 2022 Grokbase