FAQ
Hello:

I am trying to install pymat on my linux red hat 9 from the .rpm available at sourceforge

http://prdownloads.sourceforge.net/pymat/pymat-1.1.90-1.i386.rpm?download

and when doing rpm -i pymat-1.1.90-1.i386.rpm

I get the following error:

error: Failed dependencies:
libeng.so is needed by pymat-1.1.90-1
libmat.so is needed by pymat-1.1.90-1
libmx.so is needed by pymat-1.1.90-1
libut.so is needed by pymat-1.1.90-1

What should I do to get those missing libraries ? What are they ?

Thanks
Roy

Search Discussions

  • John Hunter at Jun 10, 2004 at 3:36 pm
    "Roy" == Roy Yves <yves.roy at umontreal.ca> writes:
    Roy> error: Failed dependencies: libeng.so is needed by
    Roy> pymat-1.1.90-1 libmat.so is needed by pymat-1.1.90-1 libmx.so
    Roy> is needed by pymat-1.1.90-1 libut.so is needed by
    Roy> pymat-1.1.90-1

    Roy> What should I do to get those missing libraries ? What are
    Roy> they ?

    These are matlab libraries (pymat requires matlab). On my system
    (linux), they are located in /usr/local/matlab/extern/lib/glnx86. I'm
    not sure how RPM handles the resolution of shared libraries. It may
    be enough to add the path containing these libraries to
    LD_LIBRARY_PATH and then run /sbin/ldconfig before rerunning the rpm
    installer.

    JDH

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedJun 10, '04 at 2:21p
activeJun 10, '04 at 3:36p
posts2
users2
websitepython.org

2 users in discussion

John Hunter: 1 post Roy Yves: 1 post

People

Translate

site design / logo © 2022 Grokbase