FAQ
Hi, I'm using python 2.2 under windows...when I use the 'Agg ' backend it
works fine but when I try to use the 'TkAgg' one I've an error message that
says :
....
....
"import tkagg # Paint image to Tk photo blitter extension
File "D:\PYTHON~1.3\Lib\site-packages\matplotlib\backends\tkagg.py", line
1, in ?
import _tkagg
ImportError: DLL load failed: " impossible to find the specified procedure

What do I need? with windows installers Agg and TkAgg should work without
install any requirements or not?
Thanks

Search Discussions

  • Todd Miller at Apr 19, 2004 at 7:41 pm

    Federico wrote:
    Hi, I'm using python 2.2 under windows...when I use the 'Agg ' backend it
    works fine but when I try to use the 'TkAgg' one I've an error message that
    says :
    ....
    ....
    "import tkagg # Paint image to Tk photo blitter extension
    File "D:\PYTHON~1.3\Lib\site-packages\matplotlib\backends\tkagg.py", line
    1, in ?
    import _tkagg
    ImportError: DLL load failed: " impossible to find the specified procedure
    It's not just you... I develop the TkAgg backend with Python 2.3 (on
    Linux and Solaris and win32) and didn't test the 2.2 installer for
    windows. TkAgg is apparently broken for Python-2.2 on windows.
    What do I need?
    Nothing. I think there's a bug in the way the tkagg backend is
    currently built for Windows. The _tkagg.pyd file appears to be
    dependent on Tcl/Tk 8.4 and I think for Python-2.2 it needs 8.3.

    If you're willing to upgrade to Python-2.3, you can have matplotlib with
    TkAgg today.

    Regards,
    Todd Miller

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedApr 18, '04 at 6:02p
activeApr 19, '04 at 7:41p
posts2
users2
websitepython.org

2 users in discussion

Todd Miller: 1 post Federico: 1 post

People

Translate

site design / logo © 2022 Grokbase