FAQ
hi

First my config:
Athlon 1.8 GHZ
latest gentoo-linux and w2k
python2.2 and python 2.0.1

I have a problem with python 2.0. I use Blender (2.25) wich has a built
in python engine (python2.0).
I tried to import the socket module, but I get the error message module
_socket not found. I added a python 2.0.1 installation for blender, so
that I have all modules.

Its so that blender python doesn't have all builtin modules. On windows
it works because the built in modules are not static linked to
python.exe. On linux the _socket module ins integrated in the python-bin.

How can I compile python 2.0.1 under linux, so that i get the built in
functions as non static modules, so that i can load _socket.so at
runtime. (like in python2.2)

I tried a bit to modify some config files from the source, but nothing
worked :-(

any help would be very welcome :-)))

Search Discussions

  • Martin v. Löwis at Jun 2, 2003 at 9:59 pm

    wavegroom <wavegroom at gmx.net> writes:

    How can I compile python 2.0.1 under linux, so that i get the built in
    functions as non static modules, so that i can load _socket.so at
    runtime. (like in python2.2)
    Uncomment the line

    * shared *

    in Setup. Read Setup for further details.

    Regards,
    Martin

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppython-list @
categoriespython
postedJun 2, '03 at 4:24p
activeJun 2, '03 at 9:59p
posts2
users2
websitepython.org

2 users in discussion

Wavegroom: 1 post Martin v. Löwis: 1 post

People

Translate

site design / logo © 2022 Grokbase