FAQ
Fixed the problem. Recompile gobject-introspection-1.30.0 from sources with debugging symbols enabled and install it. Do an ldconfig to update the library cache and voila?no segfaults and PyGUI starts working.


On Nov 25, 2011, at 6:00 AM, pygui-request at python.org wrote:

Send Pygui mailing list submissions to
pygui at python.org

To subscribe or unsubscribe via the World Wide Web, visit
http://mail.python.org/mailman/listinfo/pygui
or, via email, send a message with subject or body 'help' to
pygui-request at python.org

You can reach the person managing the list at
pygui-owner at python.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Pygui digest..."


Today's Topics:

1. Re: Problem with PyGUI on Ubuntu 11.10 (Greg Ewing)


----------------------------------------------------------------------

Message: 1
Date: Fri, 25 Nov 2011 10:40:01 +1300
From: Greg Ewing <greg.ewing at canterbury.ac.nz>
To: Bhargav Mangipudi <bhargav.1191 at gmail.com>
Cc: pygui at python.org
Subject: Re: [Pygui] Problem with PyGUI on Ubuntu 11.10
Message-ID: <4ECEB9B1.9070308 at canterbury.ac.nz>
Content-Type: text/plain; charset=UTF-8; format=flowed

Bhargav Mangipudi wrote:
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning:
g_boxed_type_register_static: assertion `g_type_from_name (name) == 0'
failed
import gobject._gobject
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning:
specified class size for type `PyGtkGenericCellRenderer' is smaller than
the parent type's `GtkCellRenderer' class size
from gtk import _gtk
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning:
g_type_get_qdata: assertion `node != NULL' failed
from gtk import _gtk
[1] 3181 segmentation fault python grid_view.py
I have no idea what's happening there. It looks like your gtk
or pygtk installation is messed up somehow. You could try asking
about this on the pygtk list.

--
Greg


------------------------------

_______________________________________________
Pygui mailing list
Pygui at python.org
http://mail.python.org/mailman/listinfo/pygui


End of Pygui Digest, Vol 18, Issue 3
************************************

Search Discussions

  • Shankar Giri Venkita Giri at Dec 2, 2011 at 9:15 am
    On further experimentation, libgirepository-1.0.so.1.0.0 is the library that causes the segfault. I rebuilt this library without debugging symbols and even stripped it so that it closely matches the original file packaged with Ubuntu 11.10 in size (there is a slight difference though). And the examples worked without a hitch. Something in the original ubuntu binary is causing a segfault. Since the original binaries are stripped, there is no way to know which version of gcc was used to compile it. Maybe a compiler bug (original binaries may have been compiled by a different version compared to the gcc packaged).
    On Dec 2, 2011, at 2:52 AM, Shankar Giri Venkita Giri wrote:

    Fixed the problem. Recompile gobject-introspection-1.30.0 from sources with debugging symbols enabled and install it. Do an ldconfig to update the library cache and voila?no segfaults and PyGUI starts working.


    On Nov 25, 2011, at 6:00 AM, pygui-request at python.org wrote:

    Send Pygui mailing list submissions to
    pygui at python.org

    To subscribe or unsubscribe via the World Wide Web, visit
    http://mail.python.org/mailman/listinfo/pygui
    or, via email, send a message with subject or body 'help' to
    pygui-request at python.org

    You can reach the person managing the list at
    pygui-owner at python.org

    When replying, please edit your Subject line so it is more specific
    than "Re: Contents of Pygui digest..."


    Today's Topics:

    1. Re: Problem with PyGUI on Ubuntu 11.10 (Greg Ewing)


    ----------------------------------------------------------------------

    Message: 1
    Date: Fri, 25 Nov 2011 10:40:01 +1300
    From: Greg Ewing <greg.ewing at canterbury.ac.nz>
    To: Bhargav Mangipudi <bhargav.1191 at gmail.com>
    Cc: pygui at python.org
    Subject: Re: [Pygui] Problem with PyGUI on Ubuntu 11.10
    Message-ID: <4ECEB9B1.9070308 at canterbury.ac.nz>
    Content-Type: text/plain; charset=UTF-8; format=flowed

    Bhargav Mangipudi wrote:
    /usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning:
    g_boxed_type_register_static: assertion `g_type_from_name (name) == 0'
    failed
    import gobject._gobject
    /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning:
    specified class size for type `PyGtkGenericCellRenderer' is smaller than
    the parent type's `GtkCellRenderer' class size
    from gtk import _gtk
    /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning:
    g_type_get_qdata: assertion `node != NULL' failed
    from gtk import _gtk
    [1] 3181 segmentation fault python grid_view.py
    I have no idea what's happening there. It looks like your gtk
    or pygtk installation is messed up somehow. You could try asking
    about this on the pygtk list.

    --
    Greg


    ------------------------------

    _______________________________________________
    Pygui mailing list
    Pygui at python.org
    http://mail.python.org/mailman/listinfo/pygui


    End of Pygui Digest, Vol 18, Issue 3
    ************************************

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppygui @
categoriespython
postedDec 2, '11 at 7:52a
activeDec 2, '11 at 9:15a
posts2
users1
websitecosc.canterbury.ac.nz...

1 user in discussion

Shankar Giri Venkita Giri: 2 posts

People

Translate

site design / logo © 2019 Grokbase