FAQ
I had the pleasure of spending 2 hours getting mailman to work. : P
I didn't find anything in the archives on my specific problem,
so I'm posting the fix.

Package: exim
Version: 2.05-1

Package: mailman
Version: 1.0rc1-1
This version does not include the INSTALL file. : O

If your exim is setup with good relay controls (aka CORRECTLY!)
all resends will get rejected with the error:

-----------------------------------------------------------------------
1999-05-31 00:07:13 unqualified recipient rejected: <root> H=localhost
(schizo.psychosis.com) [127.0.0.1] (list)
-----------------------------------------------------------------------

You must edit /etc/mailman/mm_cfg.py (/usr/lib/mailman/Mailman/) and
set USE_ENVELOPE_SENDER = 1.


In /etc/exim.conf add this below 'system_aliases:'

mailman_aliases:
driver = aliasfile;
file = /etc/exim.aliases.mailman,
search_type = lsearch
user = list

The debian package defaults mailman to the user 'list'.
With the above you shoudl put mailman aliases in /etc/exim.aliases.mailman

--
http://www.linuxrouter.org/ Linux Router Project

marshall.us-state.gov - - [26/Apr/1999:09:27:40 -0400] "GET /robots.txt
HTTP/1.0" 302 211

Search Discussions

  • Dave Cinege at May 31, 1999 at 5:53 am
    Opps...almost forgot. Exim also needs:

    'localhost' (127.0.0.1) added to 'sender_host_accept_relay'
    or it will not deliver to remote addresses.


    --
    http://www.linuxrouter.org/ Linux Router Project

    "Even if one takes every reefer madness allegation of the prohibitionists
    at face value, marijuana prohibition has done far more harm to far more
    people than marijuana ever could." William F. Buckley, Jr
  • J C Lawrence at Jun 1, 1999 at 6:54 pm

    On Mon, 31 May 1999 00:58:33 -0400 Dave Cinege wrote:

    If your exim is setup with good relay controls (aka CORRECTLY!)
    all resends will get rejected with the error:
    Not entirely true. If you allow locahost (127.0.0.1) to be an open
    relay (which can be a totally acceptable configuration) mailman is
    quite happy.

    --
    J C Lawrence Home: claw at kanga.nu
    ---------(*) Linux/IA64 - Work: claw at varesearch.com
    ... Beware of cromagnons wearing chewing gum and palm pilots ...
  • Dave Cinege at Jun 1, 1999 at 7:14 pm

    J C Lawrence wrote:
    On Mon, 31 May 1999 00:58:33 -0400
    Dave Cinege wrote:
    If your exim is setup with good relay controls (aka CORRECTLY!)
    all resends will get rejected with the error:
    Not entirely true.
    If you read further down in my mail, this problem was because
    USE_ENVELOPE_SENDER = 0. It had nothing to do with it coming from localhost.
    If you allow locahost (127.0.0.1) to be an open
    relay (which can be a totally acceptable configuration) mailman is
    quite happy.
    For some reason allowing 127.0.0.1 makes me warry some hole will be opened to
    allow a spoof. (Call me paranoid) Infact I just changed the SMTPHOST
    to my actual host name and removed the localhost allowence.

    --
    http://www.linuxrouter.org/ Linux Router Project

    Over 750,000 people are now in jail for consensual 'crimes'. 2 million more
    are now on parole or probation. 4 million more will be arrested this year.
    Would someone please remind how 'free' America is again?
  • Harald Meland at Jun 12, 1999 at 3:38 am
    [Dave Cinege]
    I had the pleasure of spending 2 hours getting mailman to work. : P
    I didn't find anything in the archives on my specific problem,
    so I'm posting the fix.

    Package: exim
    Version: 2.05-1

    Package: mailman
    Version: 1.0rc1-1
    This version does not include the INSTALL file. : O
    Presumably the debian package maintainer has been notified about this?
    If your exim is setup with good relay controls (aka CORRECTLY!)
    all resends will get rejected with the error:
    What do you mean by "resends"? All attempts Mailman does to
    distribute a message to any list's members?
    -----------------------------------------------------------------------
    1999-05-31 00:07:13 unqualified recipient rejected: <root> H=localhost
    (schizo.psychosis.com) [127.0.0.1] (list)
    -----------------------------------------------------------------------
    Ummm... this message says that something (running as user `list'
    according to identd) tried issuing a

    RCPT TO:<root>

    command after in a session originating from 127.0.0.1.

    I'm not quite sure why Mailman would try to send anything at all to
    the unqualified address <root>, as Mailman shouldn't allow any
    unqualified addresses to be subscribed to lists.

    However, there seems to be a loophole in bin/newlist -- if you're
    entering a unqualified address as list admin address, it is accepted.
    I'll fix this shortly.


    It goes without saying (or at least I think it _should_ do :) that
    anyone using unqualified addresses as list admins *needs* to configure
    their MTA to qualify these addresses for them (or at least accept them
    unqualified). In Exim 2.* this is done by means of setting
    qualify_domain, qualify_recipient and
    {receiver,sender}_unqualified_{hosts,nets} appropriately -- which I
    believe you have neglected to do.
    You must edit /etc/mailman/mm_cfg.py (/usr/lib/mailman/Mailman/) and
    set USE_ENVELOPE_SENDER = 1.
    I can't see how this should have any effect whatsoever on what RCPT
    TO: SMTP commands Mailman will issue. Could you try to elaborate a
    bit on the message flow of a Mailman-destined message on your system,
    and why such a flow would make this setting necessary?
    --
    Harald

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedMay 31, '99 at 4:58a
activeJun 12, '99 at 3:38a
posts5
users3
websitelist.org

People

Translate

site design / logo © 2022 Grokbase