FAQ
Hi,

I recently set up a mailman server for internal use and as list owner I am getting confirmation emails for every posting even though I set DEFAULT_GENERIC_NONMEMBER_ACTION = 0 in all the lists and restarted mailman.

I'm missing something here. How do I get it to accept all emails from non-members without list owner intervention?

Thanks

Search Discussions

  • Mark Sapiro at Dec 9, 2010 at 3:38 pm

    Roger D. Leonard wrote:
    I recently set up a mailman server for internal use and as list owner I am getting confirmation emails for every posting even though I set DEFAULT_GENERIC_NONMEMBER_ACTION = 0 in all the lists and restarted mailman.

    DEFAULT_GENERIC_NONMEMBER_ACTION is the default setting for newly
    created lists. Changing it has no effect on any existing list.

    Go to the web admin interface Privacy options... -> Sender filters and
    set generic_nonmember_action to Accept or use bin/config_list to set

    generic_nonmember_action = 0

    for the list.

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Roger D. Leonard at Dec 9, 2010 at 4:16 pm
    Thanks mark,

    I did that and it still does it. looking at the config shows it as 0 as well. I even restarted mailman. that's what has me baffled. see output of config_list attached. is there another setting I need to change?


    thanks

    roger

    -----Original Message-----
    From: Mark Sapiro [mailto:mark at msapiro.net]
    Sent: Thursday, December 09, 2010 10:39 AM
    To: Roger D. Leonard; mailman-users at python.org
    Subject: Re: [Mailman-Users] DEFAULT_GENERIC_NONMEMBER_ACTION not working

    Roger D. Leonard wrote:
    I recently set up a mailman server for internal use and as list owner I am getting confirmation emails for every posting even though I set DEFAULT_GENERIC_NONMEMBER_ACTION = 0 in all the lists and restarted mailman.

    DEFAULT_GENERIC_NONMEMBER_ACTION is the default setting for newly
    created lists. Changing it has no effect on any existing list.

    Go to the web admin interface Privacy options... -> Sender filters and
    set generic_nonmember_action to Accept or use bin/config_list to set

    generic_nonmember_action = 0

    for the list.

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Mark Sapiro at Dec 9, 2010 at 4:30 pm

    Roger D. Leonard wrote:
    I did that and it still does it. looking at the config shows it as 0 as well.
    I even restarted mailman. that's what has me baffled. see output of config_list
    attached. is there another setting I need to change?

    For what reason are the messages being held? What does the
    "confirmation email" you receive say?

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Roger D. Leonard at Dec 9, 2010 at 4:34 pm
    Heres a message from another list that just did it.

    The Havana-internal at lists.vivisimo.com mailing list has 1 request(s) waiting for your consideration at:

    http://lists.vivisimo.com/mailman/admindb/havana-internal

    Please attend to this at your earliest convenience. This notice of pending requests, if any, will be sent out daily.


    Pending posts:
    From: trac at hav-secureci.vivisimo.com on Wed Dec 8 20:43:36 2010
    Subject: Re: [HAVANA] #206: Corrupt sqlite database after server crash
    Cause: Message has implicit destination





    -----Original Message-----
    From: Mark Sapiro [mailto:mark at msapiro.net]
    Sent: Thursday, December 09, 2010 11:30 AM
    To: Roger D. Leonard; mailman-users at python.org
    Subject: RE: [Mailman-Users] DEFAULT_GENERIC_NONMEMBER_ACTION not working

    Roger D. Leonard wrote:
    I did that and it still does it. looking at the config shows it as 0 as well.
    I even restarted mailman. that's what has me baffled. see output of config_list
    attached. is there another setting I need to change?

    For what reason are the messages being held? What does the
    "confirmation email" you receive say?

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Mark Sapiro at Dec 9, 2010 at 4:46 pm

    Roger D. Leonard wrote:
    Heres a message from another list that just did it. [...]
    Pending posts:
    From: trac at hav-secureci.vivisimo.com on Wed Dec 8 20:43:36 2010
    Subject: Re: [HAVANA] #206: Corrupt sqlite database after server crash
    Cause: Message has implicit destination

    This message was held because the list was not explicitly addressed in
    a To: or Cc: header of the post. See the settings
    require_explicit_destination and acceptable_aliases on the Privacy
    options... -> Recipient filters page.

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Roger D. Leonard at Dec 9, 2010 at 5:30 pm
    Thank you mark. I will make these changes. I am very new at mailman and I appreciate you helping me out.

    -----Original Message-----
    From: Mark Sapiro [mailto:mark at msapiro.net]
    Sent: Thursday, December 09, 2010 11:47 AM
    To: Roger D. Leonard; mailman-users at python.org
    Subject: RE: [Mailman-Users] DEFAULT_GENERIC_NONMEMBER_ACTION not working

    Roger D. Leonard wrote:
    Heres a message from another list that just did it. [...]
    Pending posts:
    From: trac at hav-secureci.vivisimo.com on Wed Dec 8 20:43:36 2010
    Subject: Re: [HAVANA] #206: Corrupt sqlite database after server crash
    Cause: Message has implicit destination

    This message was held because the list was not explicitly addressed in
    a To: or Cc: header of the post. See the settings
    require_explicit_destination and acceptable_aliases on the Privacy
    options... -> Recipient filters page.

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Geoff Shang at Dec 9, 2010 at 8:34 pm

    On Thu, 9 Dec 2010, Roger D. Leonard wrote:

    I'm missing something here. How do I get it to accept all emails from
    non-members without list owner intervention?
    Apart from what people have already told you, if you want to make a list
    accept *all* non-member postings, you'll also need to set the max number
    of recipients to 0 (unlimited) in Privacy/Recipient Filters, and also set
    the max message size to 0 (unlimited) in General settings.

    Geoff.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedDec 9, '10 at 1:48p
activeDec 9, '10 at 8:34p
posts8
users3
websitelist.org

People

Translate

site design / logo © 2022 Grokbase