FAQ
Apologies if this problem has been dealt with before but I am unable to find
an answer anywhere in the archives.



Problem is this:



I can create a new mailing list no problems and subscribe a handful of users
to it and send out email without any dramas but as soon as I import the
entire mailing list subscribers (152 members so not big by any stretch of
the imagination) nothing goes out. It all appears to work fine but no emails
go out. This is driving me nuts so any help would be greatly appreciated.



Mailman smtp log - Jun 17 20:23:58 2010 (2599)
<001d01cb0e17$ebfc2c80$c3f48580$@com.au> smtp to members for 152 recips,
completed in 14.395 seconds



Mailman post log - Jun 17 20:23:58 2010 (2599) post to members from
paul at amdaat.com.au, size$613,
message-id=<001d01cb0e17$ebfc2c80$c3f48580$@com.au>, success



Regards

Paul

Search Discussions

  • Ralf Hildebrandt at Jun 17, 2010 at 1:33 pm

    * Paul Flower <paul at amdaat.com.au>:

    Mailman smtp log - Jun 17 20:23:58 2010 (2599)
    <001d01cb0e17$ebfc2c80$c3f48580$@com.au> smtp to members for 152 recips,
    completed in 14.395 seconds
    And in your MTA's logs?

    --
    Ralf Hildebrandt
    Gesch?ftsbereich IT | Abteilung Netzwerk
    Charit? - Universit?tsmedizin Berlin
    Campus Benjamin Franklin
    Hindenburgdamm 30 | D-12203 Berlin
    Tel. +49 30 450 570 155 | Fax: +49 30 450 570 962
    ralf.hildebrandt at charite.de | http://www.charite.de
  • Mark Sapiro at Jun 17, 2010 at 1:48 pm

    On 6/17/2010 6:33 AM, Ralf Hildebrandt wrote:
    * Paul Flower <paul at amdaat.com.au>:
    Mailman smtp log - Jun 17 20:23:58 2010 (2599)
    <001d01cb0e17$ebfc2c80$c3f48580$@com.au> smtp to members for 152 recips,
    completed in 14.395 seconds
    And in your MTA's logs?

    As Ralf suggests, this is now a sendmail issue. Mailman has successfully
    delivered the mail to sendmail per the above. How does sendmail deliver?
    does it deliver directly or via a smarthost. If it is via a smarthost,
    it is possible that the mail is being delivered to and relayed by
    sendmail as a single message with 152 RCPTs, and the smarthost doesn't
    accept that many RCPTs. If that is the case, setting say

    SMTP_MAX_RCPTS = 10

    or so in mm_cfg.py may help.

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Paul Flower at Jun 17, 2010 at 2:13 pm
    Should have put this in the first post.

    Jun 17 20:23:42 ns0 sendmail[23013]: o5HCNfne023011: to="|/usr/lib/mailman/mail/mailman post members", ctladdr=(8/0), delay�:00:00, xdelay�:00:00, mailer=prog, priS518, dsn=2.0.0, stat=Sent

    Regards
    Paul

    -----Original Message-----
    From: mailman-users-bounces+paul=amdaat.com.au at python.org [mailto:mailman-users-bounces+paul=amdaat.com.au at python.org] On Behalf Of Ralf Hildebrandt
    Sent: Thursday, 17 June 2010 9:34 PM
    To: mailman-users at python.org
    Subject: Re: [Mailman-Users] sendmail issues

    * Paul Flower <paul at amdaat.com.au>:
    Mailman smtp log - Jun 17 20:23:58 2010 (2599)
    <001d01cb0e17$ebfc2c80$c3f48580$@com.au> smtp to members for 152 recips,
    completed in 14.395 seconds
    And in your MTA's logs?

    --
    Ralf Hildebrandt
    Gesch?ftsbereich IT | Abteilung Netzwerk
    Charit? - Universit?tsmedizin Berlin
    Campus Benjamin Franklin
    Hindenburgdamm 30 | D-12203 Berlin
    Tel. +49 30 450 570 155 | Fax: +49 30 450 570 962
    ralf.hildebrandt at charite.de | http://www.charite.de

    ------------------------------------------------------
    Mailman-Users mailing list Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://wiki.list.org/x/AgA3
    Security Policy: http://wiki.list.org/x/QIA9
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/
    Unsubscribe: http://mail.python.org/mailman/options/mailman-users/paul%40amdaat.com.au


    ---
    avast! Antivirus: Inbound message clean.
    Virus Database (VPS): 100617-0, 17/06/2010
    Tested on: 17/06/2010 9:39:44 PM
    avast! - copyright (c) 1988-2010 ALWIL Software.
    http://www.avast.com
  • Ralf Hildebrandt at Jun 17, 2010 at 2:16 pm

    * Paul Flower <paul at amdaat.com.au>:
    Should have put this in the first post.

    Jun 17 20:23:42 ns0 sendmail[23013]: o5HCNfne023011: to="|/usr/lib/mailman/mail/mailman post members", ctladdr=(8/0), delay�:00:00, xdelay�:00:00, mailer=prog, priS518, dsn=2.0.0, stat=Sent
    And after that? That's goes INTO mailman, and causes the admin mail
    "there's sth to approve"

    Note the timestamp: 20:23:42 + 14.395 < 20:23:58

    Please do grep for the messageid: 001d01cb0e17$ebfc2c80$c3f48580$@com.au
    Mailman smtp log - Jun 17 20:23:58 2010 (2599)
    <001d01cb0e17$ebfc2c80$c3f48580$@com.au> smtp to members for 152 recips,
    completed in 14.395 seconds
    And in your MTA's logs?
  • Mark Sapiro at Jun 17, 2010 at 2:20 pm

    On 6/17/2010 7:13 AM, Paul Flower wrote:
    Should have put this in the first post.

    Jun 17 20:23:42 ns0 sendmail[23013]: o5HCNfne023011: to="|/usr/lib/mailman/mail/mailman post members", ctladdr=(8/0), delay�:00:00, xdelay�:00:00, mailer=prog, priS518, dsn=2.0.0, stat=Sent

    That is the delivery from sendmail to Mailman of the original incoming
    post. It has nothing directly to do with the delivery of the outgoing
    post to the 152 recipients.

    What is in the sendmail log for the delivery from Mailman? Is Mailman
    even delivering to this sendmail (is SMTPHOST set to other than
    'localhost' in mm_cfg.py)?

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Paul Flower at Jun 17, 2010 at 2:56 pm
    A big thank you to everyone who responded your assistance was greatly appreciated.

    The problem has been resolved with the insertion of SMTP_MAX_RCPTS = 10 into mm_cfg.py

    Once again thank you all.

    Regards
    Paul

    -----Original Message-----
    From: Mark Sapiro [mailto:mark at msapiro.net]
    Sent: Thursday, 17 June 2010 10:20 PM
    To: Paul Flower
    Cc: mailman-users at python.org
    Subject: Re: [Mailman-Users] sendmail issues
    On 6/17/2010 7:13 AM, Paul Flower wrote:
    Should have put this in the first post.

    Jun 17 20:23:42 ns0 sendmail[23013]: o5HCNfne023011: to="|/usr/lib/mailman/mail/mailman post members", ctladdr=(8/0), delay�:00:00, xdelay�:00:00, mailer=prog, priS518, dsn=2.0.0, stat=Sent

    That is the delivery from sendmail to Mailman of the original incoming
    post. It has nothing directly to do with the delivery of the outgoing
    post to the 152 recipients.

    What is in the sendmail log for the delivery from Mailman? Is Mailman
    even delivering to this sendmail (is SMTPHOST set to other than
    'localhost' in mm_cfg.py)?

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan


    ---
    avast! Antivirus: Inbound message clean.
    Virus Database (VPS): 100617-0, 17/06/2010
    Tested on: 17/06/2010 10:21:12 PM
    avast! - copyright (c) 1988-2010 ALWIL Software.
    http://www.avast.com
  • Steff Watkins at Jun 17, 2010 at 1:47 pm

    -----Original Message-----
    From: mailman-users-bounces+s.watkins=nhm.ac.uk at python.org
    [mailto:mailman-users-bounces+s.watkins=nhm.ac.uk at python.org] On Behalf Of
    Paul Flower
    Sent: Thursday, June 17, 2010 1:55 PM
    To: mailman-users at python.org
    Subject: [Mailman-Users] sendmail issues

    Problem is this:



    I can create a new mailing list no problems and subscribe a handful of
    users
    to it and send out email without any dramas but as soon as I import the
    entire mailing list subscribers (152 members so not big by any stretch of
    the imagination) nothing goes out. It all appears to work fine but no
    emails go out.
    Immediate diagnostics, as others have suggested, involve looking at the
    logfiles for your MTA and checking that they have actually been "sent".

    It could be that your network provider has a mechanism for
    side-spooling/delaying/blackholing email subsmissions to large numbers
    of recipients. So sending to 20 addresses would be OK, but one you start
    sending to more than that the email is automatically "quarantined" in
    the event that it may prove to be spam.

    Check with your network provider to make sure that there are no "limits"
    in place that may have delayed your outbound emails. Also check with
    your local system's mail spool and make sure that the emails aren't all
    sat in an outbound queue waiting to be cleared/sent.

    Good luck,
    Steff
    ---------------
    Steff Watkins Natural History Museum, Cromwell Road, London, SW7 5BD
    Systems programmer Email: s.watkins at nhm.ac.uk
    Systems Team Phone: +44 (0)20 7942 6000 opt 2
    ========
    Many were increasingly of the opinion that they'd all made a big mistake
    in coming down from the trees in the first place. And some said that
    even the trees had been a bad move, and that no one should ever have
    left the oceans. - HHGTTG

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedJun 17, '10 at 12:54p
activeJun 17, '10 at 2:56p
posts8
users4
websitelist.org

People

Translate

site design / logo © 2022 Grokbase