FAQ
There is an internal inconsistency in the 3.0.2 email package that
shipped with Python 2.4.4 through 2.4.6. This has to do with the
Charset.Charset() constructor setting input_charset to a unicode which
then causes TypeError: decoding Unicode is not supported exceptions in
other parts of the email package. This problem does not seem to occur
with email 3.0.1 and Python 2.4.[123].

This (along with other stuff) is discussed in the bug report at
<https://bugs.launchpad.net/mailman/+bug/328353> and there is a patch
for email/Charset.py at
<http://launchpadlibrarian.net/23670138/Charset.py.patch>

At this point, the best advice seems to be use Python 2.5 or 2.6 with
Mailman 2.1.12.

- --
Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
San Francisco Bay Area, California better use your sense - B. Dylan

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedMar 16, '09 at 5:50p
activeMar 16, '09 at 5:50p
posts1
users1
websitelist.org

1 user in discussion

Mark Sapiro: 1 post

People

Translate

site design / logo © 2022 Grokbase