FAQ
I'm running into a GID problem in the interface between mailman and postfix. Here's the error message:

(Command died with status 2: "/usr/mailman/mail/mailman post mailman". Command output: Group mismatch error. Mailman expected the mail wrapper script to be executed as group "mailman", but the system's mail server executed the mail script as group "nogroup". Try tweaking the mail server to run the script as group "mailman", or re-run configure, providing the command line option `--with-mail-gid=nogroup'.)

In googling the problem I came across one purported solution which involved simply creating a separate aliases file for mailman aliases, whose group ownership was set to mailman. That didn't work, nor did setting the separate aliases file's group ownership to nogroup.

Before I go in and reconfigure mailman I thought I'd check here and in the postfix users group to see if anyone had any other alternative solutions.

- Mark
"Too much sanity may be madness! But maddest of all -- to see life as it is and not as it should be."




__________ Information from ESET NOD32 Antivirus, version of virus signature database 3677 (20081209) __________

The message was checked by ESET NOD32 Antivirus.

http://www.eset.com

Search Discussions

  • Mark Sapiro at Dec 11, 2008 at 6:19 pm

    Mark A. Olbert wrote:
    I'm running into a GID problem in the interface between mailman and postfix. Here's the error message:

    (Command died with status 2: "/usr/mailman/mail/mailman post mailman". Command output: Group mismatch error. Mailman expected the mail wrapper script to be executed as group "mailman", but the system's mail server executed the mail script as group "nogroup". Try tweaking the mail server to run the script as group "mailman", or re-run configure, providing the command line option `--with-mail-gid=nogroup'.)

    The group of the user that ownes the aliases.db file in which the alias

    mailman: "|/usr/mailman/mail/mailman post mailman"

    appears is 'nogroup' which is not what Mailman expects.

    In googling the problem I came across one purported solution which involved simply creating a separate aliases file for mailman aliases, whose group ownership was set to mailman. That didn't work, nor did setting the separate aliases file's group ownership to nogroup.

    It is getting group 'nogroup' it wants group 'mailman'

    The owner of the aliases.db file must have primary group 'mailman'. The
    group of the file itself is irrelevant.

    See <http://www.list.org/mailman-install/node13.html> for the
    recommended whay to set up Mailman with Postfix so that alias
    Maintenance is automatic.

    See also the "DELIVERY RIGHTS" paragraph in "man 8 local" and the FAQ
    at <http://wiki.list.org/x/tYA9>.

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedDec 9, '08 at 5:16p
activeDec 11, '08 at 6:19p
posts2
users2
websitelist.org

2 users in discussion

Mark A. Olbert: 1 post Mark Sapiro: 1 post

People

Translate

site design / logo © 2022 Grokbase