FAQ
Hello List, this is my first post.

I'm trying to use qmail-ldap with mailman.

I've installed mailman with this parameters

make MAILMANDIR=/var/mailman MAIL_GID=qnofiles CGI_GID=www install

I've created two lists:

mailman: works great
test: I received this error for any message that I try to send to the list.

2008-07-04 15:31:28.148486500 delivery 17: deferral:
Group_mismatch_error.__Mailman_expected_the_mail/wrapper_script_to_be_executed_as_group_"vmail",
_but/the_system's_mail_server_executed_the_mail_script_as/group_"qnofiles".
__Try_tweaking_the_mail_server_to_run_the/script_as_group_"vmail",_or_re-run_configure,
_/providing_the_command_line_option_`--with-mail-gid=qnofiles'./


If I chance MAIL_GID=vmail, I received the error to use qnofiles.
If I chance MAIL_GID=qnofiles, I received the error to use vmail.

Have you seen this error before?

Thanks in advance for any help.
Luiz

Search Discussions

  • Mark Sapiro at Jul 4, 2008 at 8:06 pm

    Luiz wrote:
    I've installed mailman with this parameters

    make MAILMANDIR=/var/mailman MAIL_GID=qnofiles CGI_GID=www install

    None of those 3 parameters are in our Makefiles. The mail and cgi
    groups are MAIL_GROUP and CGI_GROUP and the install directory is
    prefix.

    Are you installing our GNU Mailman distribution or someone's package.
    If this is our distribution, those things are normally set at
    configure time with the --prefix=, --with-mail-gid= and
    --with-cgi-gid= configure options.

    If this is pre-configured package, you'll probably need to use the
    support resources of the packager.

    --
    Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Luiz at Jul 5, 2008 at 1:10 am
    Hello Mark,

    Sorry for my mistake.

    Mark Sapiro escreveu:
    Luiz wrote:
    I've installed mailman with this parameters

    make MAILMANDIR=/var/mailman MAIL_GID=qnofiles CGI_GID=www install
    This is for the BSD ports. I've done this:

    #./configure --prefix=/var/mailman --with-mail-gid=qnofiles --with-cgi-gid=www
    #make install

    It?s working now. That error bellow had been fixed with this configuration.

    Thanks any way.

    Luiz.




    None of those 3 parameters are in our Makefiles. The mail and cgi
    groups are MAIL_GROUP and CGI_GROUP and the install directory is
    prefix.

    Are you installing our GNU Mailman distribution or someone's package.
    If this is our distribution, those things are normally set at
    configure time with the --prefix=, --with-mail-gid= and
    --with-cgi-gid= configure options.

    If this is pre-configured package, you'll probably need to use the
    support resources of the packager.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedJul 4, '08 at 6:48p
activeJul 5, '08 at 1:10a
posts3
users2
websitelist.org

2 users in discussion

Luiz: 2 posts Mark Sapiro: 1 post

People

Translate

site design / logo © 2022 Grokbase