FAQ
Hi,

I try to ensure HTTPS communication for the $prefix/admin and $prefix/
private directories. Normal HTTP works fine, so I assume my
configuration of mailman should be ok.

Here the apache configuration:

ScriptAlias /mailman /usr/local/mailman/cgi-bin
<Location /mailman>
SetHandler cgi-script
Options ExecCGI FollowSymLinks
Order allow,deny
Allow from all
<IfModule rewrite_module>
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule admin.*$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R]
RewriteRule private.*$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R]
</IfModule>

This works fine too, the URIs being properly rewritten.

Now here's my problem: I can't change any settings anymore if these
settings are active, the web interface responds normally, anyhow.

Any ideas would be much appreciated!

Greetings,
Andreas Nemeth

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedJul 27, '07 at 8:30a
activeJul 27, '07 at 4:09p
posts2
users2
websitelist.org

2 users in discussion

Andreas Németh: 1 post Mark Sapiro: 1 post

People

Translate

site design / logo © 2022 Grokbase