FAQ
Hi list,

I have 2 different problems with attachments in
archives in mailman lists.

1. The first problem has to do with attachment URLs in

the web archive. The URL is split into two lines where
the first line ends with a '='. If you concatenate the
two lines and omit the '=' the URL works fine. I know
this problem has been already discussed but I haven't
found a working solution yet. The mail is delivered
directly from my mail client to the MTA without any
intermidiate machines.
Is there a solution to the broken link ?

2. The second problem is that mails having an
attachment are displayed fine in the web archives only
if the mail was sent with iso-8859-1 encoding. If I
choose a different encoding in my mail client
(eq. iso-8859-7 or utf-8) mails in the web archives
are displayed scrambled. This is not the case if the
mail does not have an attachment where it is handled
correctly by mailman regadless the encoding of the
mail.

Thank you.


__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Search Discussions

  • Stephen J. Turnbull at May 3, 2007 at 11:41 am
    John Papapanos writes:
    Is there a solution to the broken link ?
    This is not a "problem" that can be "solved". Mailman (or some other
    mail program) here is conforming to the recommendation in the
    standards that lines in mail bodies be broken at a reasonable length.
    Since this behavior is recommended, rather than required, a patch to
    provide an option has a good chance of being accepted I should think.
    (As a supporter of standards, I hope the core developers will choose
    to spend their time improving conforming behavior, not providing
    options for the benefit of those who use non-conforming MUAs!)

    It might also be possible to use an 8-bit transfer encoding for the
    body which might relax the line length limit, I forget exactly what
    the standards say about that. However, I don't think Mailman
    currently supports that as an option. :-(
    2. The second problem is that mails having an
    attachment are displayed fine in the web archives only
    if the mail was sent with iso-8859-1 encoding. If I
    choose a different encoding in my mail client
    (eq. iso-8859-7 or utf-8) mails in the web archives
    are displayed scrambled.
    What do you mean by "scrambled"? Can you give a URL where we can
    observe this? What web browser do you use? How is it configured for
    viewing non-ASCII/ISO-8859-1 encodings?
  • John Papapanos at May 3, 2007 at 12:19 pm

    What do you mean by "scrambled"? Can you give a URL
    where we can
    observe this? What web browser do you use? How is
    it configured for
    viewing non-ASCII/ISO-8859-1 encodings?
    Here is a URL where I created a list for testing
    mailman.

    https://mail.bioacademy.gr/pipermail/testlist2/2007-May/thread.html

    I have sent several mails to the lists using
    iso-8859-1 and iso-8859-7 encodings.

    The 2nd and 3rd mails do not really hava an attachment
    (forgot to actually attach the file)

    Check out the mail with the subject
    [Testlist2] Mail sent as iso-8859-7 image attachment

    It is not readable. I can't figure out what encoding
    is actually used.

    I sent the mails using thunderbird by changing the
    outgoing mail character encoding in the preferences.

    I use firefox to display the web archives. And I
    change
    the character encoding view settings when the encoding

    is not autodetected.


    __________________________________________________
    Do You Yahoo!?
    Tired of spam? Yahoo! Mail has the best spam protection around
    http://mail.yahoo.com
  • Stephen J. Turnbull at May 3, 2007 at 2:55 pm
    Mailman developers: I've submitted a bug on the SF tracker (what, no
    Jira yet?) #1712034. What I write below is all I've got for now, and
    it's on the tracker; bug/patch traffic will followup to the tracker.

    Reply-To set to mailman-users.

    John Papapanos writes:
    Here is a URL where I created a list for testing
    mailman. >
    https://mail.bioacademy.gr/pipermail/testlist2/2007-May/thread.html
    Thanks! As usual, seeing is believing.

    Wow! That's amazingly broken. What's I'm pretty sure is happening is
    that the archive contains raw message content in a MIME QP or
    transfer-encoding, which cannot be properly decoded because the
    Content-Transfer-Encoding header has been stripped (AFAIK it's
    actually prohibited in HTTP, cf RFC 2616 section 19.5).

    The reason that the Greek text-only comes out OK is that your browser
    interprets the { notation in the message body as SGML entities,
    which are Unicode.

    To fix this, you *will* have to patch your Mailman installation, or
    get an alternative archiver (there are instructions for using MHonArc
    in the FAQ). There's not going to be a way to configure around this,
    I'm pretty sure.

    The patch may be trivial, but I won't be able to look at it for a day
    or two. Maybe Mark, Barry, or Tokio can.
  • Tokio Kikuchi at May 4, 2007 at 12:23 am
    Hi,
    Here is a URL where I created a list for testing
    mailman.

    https://mail.bioacademy.gr/pipermail/testlist2/2007-May/thread.html
    Your site use Mailman-2.1.5 which is way too old. Upgrade to the
    current version (2.1.9) and try again.

    --
    Tokio Kikuchi, tkikuchi at is.kochi-u.ac.jp
    http://weather.is.kochi-u.ac.jp/
  • John Papapanos at May 4, 2007 at 12:00 pm

    --- Tokio Kikuchi wrote:
    Your site use Mailman-2.1.5 which is way too old.
    Upgrade to the
    current version (2.1.9) and try again.

    --
    Tokio Kikuchi, tkikuchi at is.kochi-u.ac.jp
    http://weather.is.kochi-u.ac.jp/
    ok that was it. Mailman 2.1.9 solves this problem.
    My initial choice of mailman-2.1.5 was because it was
    provided as a package from my linux dist (ubuntu
    server).

    After I built and configured mailman-2.1.9 from
    scratch
    everything worked as expected. Also the URLs for the
    attachments in the archives pages are not broken
    anymore.

    Many thanks.




    __________________________________________________
    Do You Yahoo!?
    Tired of spam? Yahoo! Mail has the best spam protection around
    http://mail.yahoo.com

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedMay 3, '07 at 10:00a
activeMay 4, '07 at 12:00p
posts6
users3
websitelist.org

People

Translate

site design / logo © 2022 Grokbase