FAQ
Hi All,

I'm fairly new to mailman and have just recently installed it (version
2.1.9) on a Fedora 6 VM.

The installation went well with no major issues. Though the problem I'm
having at the moment is when every time mailman try's to send a message
the following error appears in the smtp-failure log underneath the
mailman logs directory.

"Low level smtp error: (111, 'Connection refused') msgid:"

I'm using sendmail as my mail server version 8.13.8 and my Python
version is 2.4.4

As yet I have been unable to locate a solution to this issue and was
hoping that somebody may be able to provide some guidance.

Thanks,

Ben

Search Discussions

  • Patrick Bogen at Nov 30, 2006 at 3:36 am

    On 11/29/06, Saxvik, Ben wrote:
    "Low level smtp error: (111, 'Connection refused') msgid:"
    Have you overriden the 'SMTPHOST' or 'SMTPPORT' options in mm_cfg.py?
    Alternatively, have you changed one of them in Defaults.py? (The
    latter would be a bad thing).

    The default SMTPHOST is 'localhost', and the port is 0, which means
    the default. If you aren't running an MTA on the machine running
    Mailman (from what I understand, you are?), you'll need to change
    them. If you've changed them to something else, that may be the
    problem.

    --
    - Patrick Bogen
  • Saxvik, Ben at Nov 30, 2006 at 6:01 am
    Hi Patrick,

    Thanks for your reply.

    Yes the MTA is running on the mailman machine.

    No I have not changed the options SMTPHOST and SMTPPORT, they are still
    set to their default settings. SMTPHOST 'localhost' SMTPPORT '0'.

    Regards,

    Ben

    -----Original Message-----
    From: Patrick Bogen [mailto:pdbogen at gmail.com]
    Sent: Thursday, 30 November 2006 2:37 PM
    To: Saxvik, Ben
    Cc: mailman-users at python.org
    Subject: Re: [Mailman-Users] Sending emails via Mailman Issue
    On 11/29/06, Saxvik, Ben wrote:
    "Low level smtp error: (111, 'Connection refused') msgid:"
    Have you overriden the 'SMTPHOST' or 'SMTPPORT' options in mm_cfg.py?
    Alternatively, have you changed one of them in Defaults.py? (The latter
    would be a bad thing).

    The default SMTPHOST is 'localhost', and the port is 0, which means the
    default. If you aren't running an MTA on the machine running Mailman
    (from what I understand, you are?), you'll need to change them. If
    you've changed them to something else, that may be the problem.

    --
    - Patrick Bogen
  • Patrick Bogen at Nov 30, 2006 at 2:50 pm

    On 11/30/06, Saxvik, Ben wrote:
    Yes the MTA is running on the mailman machine.

    No I have not changed the options SMTPHOST and SMTPPORT, they are still
    set to their default settings. SMTPHOST 'localhost' SMTPPORT '0'.
    Can you double-check that your MTA is listening on port 25? Either
    using: netstat -lnp (and looking for port 25) or: telnet localhost 25
    and see if the MTA responds (after a few seconds, probably.)

    --
    - Patrick Bogen
  • Saxvik, Ben at Nov 30, 2006 at 10:45 pm
    Hi Patrick,

    I tired to telnet to port 25 on localhost and got a connection refused
    error.

    I verified that sendmail was running and it was. I then proceeded to
    /etc/hosts file and found that the loopback address for the machine was
    incorrect. Instead of the address being 127.0.0.1 it was ::1. Once I
    change it back it was all sweet.

    I did apply some patches to my system recently so one of them must have
    changed this address.

    Again thanks for your assistance.

    Regards,

    Ben



    -----Original Message-----
    From: Patrick Bogen [mailto:pdbogen at gmail.com]
    Sent: Friday, 1 December 2006 1:50 AM
    To: Saxvik, Ben
    Cc: mailman-users at python.org
    Subject: Re: [Mailman-Users] Sending emails via Mailman Issue
    On 11/30/06, Saxvik, Ben wrote:
    Yes the MTA is running on the mailman machine.

    No I have not changed the options SMTPHOST and SMTPPORT, they are
    still set to their default settings. SMTPHOST 'localhost' SMTPPORT
    '0'.

    Can you double-check that your MTA is listening on port 25? Either
    using: netstat -lnp (and looking for port 25) or: telnet localhost 25
    and see if the MTA responds (after a few seconds, probably.)

    --
    - Patrick Bogen
  • Brad Knowles at Dec 1, 2006 at 6:59 am

    At 9:45 AM +1100 12/1/06, Saxvik, Ben wrote:

    I verified that sendmail was running and it was. I then proceeded to
    /etc/hosts file and found that the loopback address for the machine was
    incorrect. Instead of the address being 127.0.0.1 it was ::1. Once I
    change it back it was all sweet.
    The 127.0.0.1 address is IPv4 localhost, while ::1 is IPv6 localhost.
    So, technically both forms are correct, and which one is preferred
    will depend on which version of the IP stack is loaded on your
    machine, and which IP addresses are assigned to your machine.

    You need to check with your network administrator before you make a
    change like this.

    --
    Brad Knowles, <brad at shub-internet.org>

    Trend Micro has announced that they will cancel the stop.mail-abuse.org
    mail forwarding service as of 15 November 2006. If you have an old
    e-mail account for me at this domain, please make sure you correct that
    with the current address.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedNov 30, '06 at 2:41a
activeDec 1, '06 at 6:59a
posts6
users3
websitelist.org

People

Translate

site design / logo © 2022 Grokbase