FAQ
First let me say I am very new to Mailman, very new to Linux, and very new to mailing lists. (it took me 2 days to get the listserv to even send out :( )

I have the listserv up and sending to my lists; however, I would like to make the lists only emailable from the list owner. I saw one post that referred to a FAQ but it was not very clear to me on how to do it. So, how do I limit the person that can send to the mailing list to only the list owner/administrator/moderator? I have set all list members to be moderated, yet they dont show up on the "tend to pending moderator tasks" link.

Any help would be appreciated.






---------------------------------
Want to start your own business? Learn how on Yahoo! Small Business.

Search Discussions

  • Patrick Bogen at Nov 29, 2006 at 5:28 pm

    On 11/29/06, Ken Cheney wrote:
    First let me say I am very new to Mailman, very new to Linux, and very new to mailing
    lists. (it took me 2 days to get the listserv to even send out :( )

    I have the listserv up and sending to my lists; however, I would like to make the lists only
    emailable from the list owner. I saw one post that referred to a FAQ but it was not very
    clear to me on how to do it. So, how do I limit the person that can send to the mailing list
    to only the list owner/administrator/moderator? I have set all list members to be
    moderated, yet they dont show up on the "tend to pending moderator tasks" link.
    What are 'they'? The users don't show up. If a moderated user sends a
    message, and member_moderation_action is set to 'Hold,' then the
    message will show up in the admin interface.

    The general way to do what you want is: set all members to moderated.
    Set 'default_member_moderation' for the list to 'Yes'. Set
    'member_moderation_action' to 'Hold' if you want to see attempts by
    the members to post, and have the opportunity to approve them. Set it
    to 'reject,' otherwise, which will bounce the message and tell the
    user why. To allow certain users (based on email address) to
    automatically post, add their email addresses to
    accept_these_nonmembers. This is probably the easiest, although least
    secure, way to do this.

    The better (though potentially more complex and difficult) way to do
    this is to include the list password on any emails sent, which will
    automatically bypass the sender filters. There are two ways to do
    this: Either as a header in the email (this can be difficult,
    depending on which email client you're using), or as the first line in
    the email (this can be very tricky if you're sending HTML email. For
    normal text, it should be fairly foolproof). Either way, the
    header/line should look like:

    Approved: <list password>

    --
    - Patrick Bogen
  • Patrick Bogen at Nov 29, 2006 at 6:25 pm

    On 11/29/06, Ken Cheney wrote:
    The "they" i was referring to are the messages that moderated members of the
    list sent to the list. "they" dont show up in the Tend to pending moderator
    requests list link off of the admin page as I would expect them to.
    Are you sure the messages were held, and not discarded or rejected?
    Check the 'member_moderation_action' setting I mentioned.

    Also, please try to keep your replies on-list, so that others can
    chime in when I'm wrong about things, (which is fairly often! :)

    --
    - Patrick Bogen
  • Patrick Bogen at Nov 30, 2006 at 1:22 am
    This is where you want to adjust the setting I mentioned. If it's
    already set to Hold (and not Discard or Reject), then there is
    probably something else wrong, which is why you need to keep the
    conversation on-list. As willing as I am to help, I don't have perfect
    knowledge of Mailman.

    - Patrick Bogen
    On 11/29/06, Ken Cheney wrote:
    I think I found it... Under privacy|sender filters.

    Ken Cheney wrote:

    I will send the solution to the list after this email because I dont want
    the list subscribers to see how stupid I am at this point! Right now I cant
    find where to set member_mod now... I thought it was on one of the web
    screens. Once the list is created do I need to now change it via the
    command line? or is everything available somewhere in the mailman web ui?

    I am pretty sure somewhere along the line i set all the users to be in the
    "hold" space for nonmoderators or list owners. I am wondering if I have
    some other problem since i can't unsubscribe by emailing to
    listname-leave at domain.com ...

    Ken

    Patrick Bogen wrote:
    On 11/29/06, Ken Cheney wrote:
    First let me say I am very new to Mailman, very new to Linux, and very new
    to mailing
    lists. (it took me 2 days to get the listserv to even send out :( )

    I have the listserv up and sending to my lists; however, I would like to
    make the lists only
    emailable from the list owner. I saw one post that referred to a FAQ but
    it was not very
    clear to me on how to do it. So, how do I limit the person that can send
    to the mailing list
    to only the list owner/administrator/moderator? I have set all list
    members to be
    moderated, yet they dont show up on the "tend to pending moderator tasks"
    link.

    What are 'they'? The users don't show up. If a moderated user sends a
    message, and member_moderation_action is set to 'Hold,' then the
    message will show up in the admin interface.

    The general way to do what you want is: set all members to moderated.
    Set 'default_member_moderation' for the list to 'Yes'. Set
    'member_moderation_action' to 'Hold' if you want to see attempts by
    the members to post, and have the opportunity to approve them. Set it
    to 'reject,' otherwise, which will bounce the message and tell the
    user why. To allow certain users (based on email address) to
    automatically post, add their email addresses to
    accept_these_nonmembers. This is probably the easiest, although least
    secure, way to do this.

    The better (though potentially more complex and difficult) way to do
    this is to include the list password on any emails sent, which will
    automatically bypass the sender filters. There are two ways to do
    this: Either as a header in the email (this can be difficult,
    depending on which email client you're using), or as the first line in
    the email (this can be very tricky if you're sending HTML email. For
    normal text, it should be fairly foolproof). Either way, the
    header/line should look like:

    Approved:

    --
    - Patrick Bogen


    ________________________________
    Want to start your own business? Learn how on Yahoo! Small Business.


    ________________________________
    Everyone is raving about the all-new Yahoo! Mail beta.

    --
    - Patrick Bogen
  • Ken Cheney at Nov 30, 2006 at 2:33 am
    Thank you. Here are my settings for Privacy Options:

    Member Filters:
    By Default, should new list member postings be moderated? = Yes
    Action Taken? = Hold
    NonMember Filters:
    Action to take for postings from nonmembers for which no explicit action is defined? = Hold
    Should messages from non-memebers, which are are discarded be fwded to moderator? = Yes

    As a member of the list with the mod box checked I email the list. The list not only doesnt make it to the recipients but it doesnt show up in the "Pending moderator requests" section.

    Here are also things that don't work which could lead to the problem, they dont sound like they would but I will post them anyway.
    emailing to listname-leave at domain.com does not remove members from the list.
    if i email from the list owner the emails go to all the list members except the members of the list that have email addresses on my work domain. Example:
    name1 at yahoo.com - get message
    name2 at yahoo.com - get message
    name at mydomain.com - does not get message

    Thanks!!!

    Patrick Bogen wrote:
    This is where you want to adjust the setting I mentioned. If it's
    already set to Hold (and not Discard or Reject), then there is
    probably something else wrong, which is why you need to keep the
    conversation on-list. As willing as I am to help, I don't have perfect
    knowledge of Mailman.

    - Patrick Bogen
    On 11/29/06, Ken Cheney wrote:
    I think I found it... Under privacy|sender filters.

    Ken Cheney wrote:

    I will send the solution to the list after this email because I dont want
    the list subscribers to see how stupid I am at this point! Right now I cant
    find where to set member_mod now... I thought it was on one of the web
    screens. Once the list is created do I need to now change it via the
    command line? or is everything available somewhere in the mailman web ui?

    I am pretty sure somewhere along the line i set all the users to be in the
    "hold" space for nonmoderators or list owners. I am wondering if I have
    some other problem since i can't unsubscribe by emailing to
    listname-leave at domain.com ...

    Ken

    Patrick Bogen
    wrote:
    On 11/29/06, Ken Cheney wrote:
    First let me say I am very new to Mailman, very new to Linux, and very new
    to mailing
    lists. (it took me 2 days to get the listserv to even send out :( )

    I have the listserv up and sending to my lists; however, I would like to
    make the lists only
    emailable from the list owner. I saw one post that referred to a FAQ but
    it was not very
    clear to me on how to do it. So, how do I limit the person that can send
    to the mailing list
    to only the list owner/administrator/moderator? I have set all list
    members to be
    moderated, yet they dont show up on the "tend to pending moderator tasks"
    link.

    What are 'they'? The users don't show up. If a moderated user sends a
    message, and member_moderation_action is set to 'Hold,' then the
    message will show up in the admin interface.

    The general way to do what you want is: set all members to moderated.
    Set 'default_member_moderation' for the list to 'Yes'. Set
    'member_moderation_action' to 'Hold' if you want to see attempts by
    the members to post, and have the opportunity to approve them. Set it
    to 'reject,' otherwise, which will bounce the message and tell the
    user why. To allow certain users (based on email address) to
    automatically post, add their email addresses to
    accept_these_nonmembers. This is probably the easiest, although least
    secure, way to do this.

    The better (though potentially more complex and difficult) way to do
    this is to include the list password on any emails sent, which will
    automatically bypass the sender filters. There are two ways to do
    this: Either as a header in the email (this can be difficult,
    depending on which email client you're using), or as the first line in
    the email (this can be very tricky if you're sending HTML email. For
    normal text, it should be fairly foolproof). Either way, the
    header/line should look like:

    Approved:

    --
    - Patrick Bogen


    ________________________________
    Want to start your own business? Learn how on Yahoo! Small Business.


    ________________________________
    Everyone is raving about the all-new Yahoo! Mail beta.

    --
    - Patrick Bogen



    ---------------------------------
    Cheap Talk? Check out Yahoo! Messenger's low PC-to-Phone call rates.
  • Patrick Bogen at Nov 30, 2006 at 3:32 am

    On 11/29/06, Ken Cheney wrote:
    Thank you. Here are my settings for Privacy Options:

    Member Filters:
    By Default, should new list member postings be moderated? = Yes
    Action Taken? = Hold
    NonMember Filters:
    Action to take for postings from nonmembers for which no explicit action is defined? = Hold
    Should messages from non-memebers, which are are discarded be fwded to moderator? =
    Yes

    As a member of the list with the mod box checked I email the list. The list not only doesnt
    make it to the recipients but it doesnt show up in the "Pending moderator requests" section.
    Do you have access to the system logs on the machine mailman is
    running on? Can you check mailman's vette log (someone correct me if
    I'm wrong, please) to see what's happening to the messages you post?
    Here are also things that don't work which could lead to the problem, they dont sound like
    they would but I will post them anyway.
    emailing to listname-leave at domain.com does not remove members from the list.
    if i email from the list owner the emails go to all the list members except the members of the
    list that have email addresses on my work domain. Example:
    name1 at yahoo.com - get message
    name2 at yahoo.com - get message
    name at mydomain.com - does not get message
    Is the machine handling mail for mydomain.com the same machine as that
    on which mailman runs?
    Can you check your MTA (e.g., sendmail, postfix, exim, or qmail) logs
    to see what's happening to the request you send to listname-leave?

    --
    - Patrick Bogen
  • Ken Cheney at Nov 30, 2006 at 4:26 pm
    I do have access to the box that mailman is on. The vette log shows:

    Nov 29 08:05:02 2006 (11992) Mailman post from root at listserv.mydomain.org held, message-id=<200611291305.kATD51Gr025658 at listserv.mydomain.org>: Post by non-member to a members-only list

    but the email address I sent to this list from is a member of the list. Is this a problem maybe in the aliases file?

    alias_database = hash:/etc/mailman/aliases
    alias_maps = hash:/etc/mailman/aliases


    Patrick Bogen wrote: On 11/29/06, Ken Cheney wrote:
    Thank you. Here are my settings for Privacy Options:

    Member Filters:
    By Default, should new list member postings be moderated? = Yes
    Action Taken? = Hold
    NonMember Filters:
    Action to take for postings from nonmembers for which no explicit action is defined? = Hold
    Should messages from non-memebers, which are are discarded be fwded to moderator? =
    Yes

    As a member of the list with the mod box checked I email the list. The list not only doesnt
    make it to the recipients but it doesnt show up in the "Pending moderator requests" section.
    Do you have access to the system logs on the machine mailman is
    running on? Can you check mailman's vette log (someone correct me if
    I'm wrong, please) to see what's happening to the messages you post?
    Here are also things that don't work which could lead to the problem, they dont sound like
    they would but I will post them anyway.
    emailing to listname-leave at domain.com does not remove members from the list.
    if i email from the list owner the emails go to all the list members except the members of the
    list that have email addresses on my work domain. Example:
    name1 at yahoo.com - get message
    name2 at yahoo.com - get message
    name at mydomain.com - does not get message
    Is the machine handling mail for mydomain.com the same machine as that
    on which mailman runs?
    Can you check your MTA (e.g., sendmail, postfix, exim, or qmail) logs
    to see what's happening to the request you send to listname-leave?

    --
    - Patrick Bogen



    ---------------------------------
    Everyone is raving about the all-new Yahoo! Mail beta.
  • Patrick Bogen at Nov 30, 2006 at 7:57 pm

    On 11/30/06, Ken Cheney wrote:
    I do have access to the box that mailman is on. The vette log shows:

    Nov 29 08:05:02 2006 (11992) Mailman post from root at listserv.mydomain.org
    held,
    message-id=<200611291305.kATD51Gr025658 at listserv.mydomain.org>:
    Post by non-member to a members-only list
    The address 'root at listserv.mydomain.org' is not a member of the list.
    That is the address you sent the message from. However, this indicates
    the message was held, not rejected or discarded. Are you sure you're
    looking at the correct place when you say it doesn't show up as a
    moderation task?
    but the email address I sent to this list from is a member of the list. Is
    this a problem maybe in the aliases file?

    alias_database = hash:/etc/mailman/aliases
    alias_maps = hash:/etc/mailman/aliases
    I don't think you need both of these. I'm not completely sure,
    however. This might have something to do with why listname-leave isn't
    working.

    --
    - Patrick Bogen
  • Ken Cheney at Nov 30, 2006 at 11:10 pm
    I send email to the list using my corprate Outlook client to mylist at listserv.domain.org what setting do i have in error that logs root at listserv.mydomain.org instead myemail at mydomain.org. I dont have a mail client on the list server at all. Strickly command line shell only.

    The place I am looking is in the main page after login I click on the link on the right that says "Tend to pending moderator requests"

    Patrick Bogen wrote:
    On 11/30/06, Ken Cheney wrote:
    I do have access to the box that mailman is on. The vette log shows:

    Nov 29 08:05:02 2006 (11992) Mailman post from root at listserv.mydomain.org
    held,
    message-id=<200611291305.kATD51Gr025658 at listserv.mydomain.org>:
    Post by non-member to a members-only list
    The address 'root at listserv.mydomain.org' is not a member of the list.
    That is the address you sent the message from. However, this indicates
    the message was held, not rejected or discarded. Are you sure you're
    looking at the correct place when you say it doesn't show up as a
    moderation task?
    but the email address I sent to this list from is a member of the list. Is
    this a problem maybe in the aliases file?

    alias_database = hash:/etc/mailman/aliases
    alias_maps = hash:/etc/mailman/aliases
    I don't think you need both of these. I'm not completely sure,
    however. This might have something to do with why listname-leave isn't
    working.

    --
    - Patrick Bogen



    ---------------------------------
    Cheap Talk? Check out Yahoo! Messenger's low PC-to-Phone call rates.
  • Mark Sapiro at Dec 1, 2006 at 7:49 pm

    Ken Cheney wrote:
    I send email to the list using my corprate Outlook client to mylist at listserv.domain.org what setting do i have in error that logs root at listserv.mydomain.org instead myemail at mydomain.org. I dont have a mail client on the list server at all. Strickly command line shell only.

    Some MTA between your corprate Outlook client and Mailman is rewriting
    the headers in your message. This also explains why you can't
    unsubscribe via mail to listname-leave.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedNov 29, '06 at 4:53p
activeDec 1, '06 at 7:49p
posts10
users3
websitelist.org

People

Translate

site design / logo © 2022 Grokbase