FAQ
Hello,

I'm setting up Mailman and have a bit of a difficulty. I've sent a
'subscribe' email to a list, and received back that it's awaiting
admin approval. I login to the web page, go to the Pending Requests
section and see the subscribe request. I then click the accept radio
button and the Submit All Data. But all that happens is that I get a
security warning window about encrypted communication and the web page
refreshes and resets itself. I can't find anything in the httpd log
files, the mailman log files, or the system log files that explain why
this happens. This happens no matter which action button I choose,
accept, decline, etc.

I've installed packages rather than compiled from scratch so here are
my relevant version stats:

postfix-2.1.5-4.2.RHEL4
httpd-2.0.52-22.ent
mailman-2.1.5.1-34.rhel4.3

Also this appears there is a similar problem when I go to list
management and attempt to add addresses via the mass subscriptions.
In this case, I fill in the information and choose submit changes, and
then it just blanks out the entries and presents the page again.

FWIW: I have added a change to the httpd.conf file to rewrite all
http: requests to https: requests.

Any ideas?

Search Discussions

  • Dragon at Jul 25, 2006 at 9:06 pm
    Tony Stocker sent the message below at 13:34 7/25/2006:
    Hello,

    I'm setting up Mailman and have a bit of a difficulty. I've sent a
    'subscribe' email to a list, and received back that it's awaiting
    admin approval. I login to the web page, go to the Pending Requests
    section and see the subscribe request. I then click the accept radio
    button and the Submit All Data. But all that happens is that I get a
    security warning window about encrypted communication and the web page
    refreshes and resets itself. I can't find anything in the httpd log
    files, the mailman log files, or the system log files that explain why
    this happens. This happens no matter which action button I choose,
    accept, decline, etc.

    I've installed packages rather than compiled from scratch so here are
    my relevant version stats:

    postfix-2.1.5-4.2.RHEL4
    httpd-2.0.52-22.ent
    mailman-2.1.5.1-34.rhel4.3

    Also this appears there is a similar problem when I go to list
    management and attempt to add addresses via the mass subscriptions.
    In this case, I fill in the information and choose submit changes, and
    then it just blanks out the entries and presents the page again.

    FWIW: I have added a change to the httpd.conf file to rewrite all
    http: requests to https: requests.

    Any ideas?
    ---------------- End original message. ---------------------

    You have to have cookies enabled in your browser. If you do not, it won't work.



    Dragon

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Venimus, Saltavimus, Bibimus (et naribus canium capti sumus)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  • Tony Stocker at Jul 25, 2006 at 9:11 pm

    You have to have cookies enabled in your browser. If you do not, it won't work.

    Dragon
    I do have cookies enabled, and just to doublecheck I turned off the
    privacy settings and set it to allow all cookies but the results were
    the same. I have also since tried a second browser program but the
    results are the same. I've now tried Netscape 7.2 and Firefox 1.0.2.
  • Dragon at Jul 25, 2006 at 9:26 pm

    Tony Stocker sent the message below at 14:11 7/25/2006:

    You have to have cookies enabled in your browser. If you do not,
    it won't work.
    Dragon
    I do have cookies enabled, and just to doublecheck I turned off the
    privacy settings and set it to allow all cookies but the results were
    the same. I have also since tried a second browser program but the
    results are the same. I've now tried Netscape 7.2 and Firefox 1.0.2.
    ---------------- End original message. ---------------------

    Hmm... well then I don't know. Generally when people see this
    behavior it is because they have cookies blocked in their browser.

    Somebody with more experience will have to take it from here.

    Dragon

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Venimus, Saltavimus, Bibimus (et naribus canium capti sumus)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  • Tony Stocker at Jul 25, 2006 at 9:33 pm
    FWIW here's the actual popup warning message that I get from Netscape
    upon trying to submite my changes:
    -------------------------------------------------------------------------------------------------------------------
    Although this page is encrypted, the information you have entered is
    to be sent over an
    unencrypted connection and could easily be read by a third party.

    Are you sure you want to continue sending this information?
    -------------------------------------------------------------------------------------------------------------------

    I doubt that that's very helpful, but thought I'd add it anyway. It's
    a little confusing to me since I don't know how/why it thinks it's
    going to send stuff over an unencrypted channel since all connections
    are supposed to be routed to the https port. But I'm wondering if
    that rewriting of the destination could be the problem. I'm going to
    temporarily comment out the rewrite and see what happens.
  • Tony Stocker at Jul 25, 2006 at 9:38 pm

    I doubt that that's very helpful, but thought I'd add it anyway. It's
    a little confusing to me since I don't know how/why it thinks it's
    going to send stuff over an unencrypted channel since all connections
    are supposed to be routed to the https port. But I'm wondering if
    that rewriting of the destination could be the problem. I'm going to
    temporarily comment out the rewrite and see what happens.
    Well that's what it is.

    I disabled the SSL rewrite rule in the httpd.conf file, and tried
    again and it worked. So the Mailman program doesn't like something
    about the URL's getting rewritten I'm guessing. However, I don't want
    to run this program "in the clear" - or any programs really for this
    server - so what do I need to do to fix this issue? Any ideas?
  • Tony Stocker at Jul 25, 2006 at 10:14 pm

    I disabled the SSL rewrite rule in the httpd.conf file, and tried
    again and it worked. So the Mailman program doesn't like something
    about the URL's getting rewritten I'm guessing. However, I don't want
    to run this program "in the clear" - or any programs really for this
    server - so what do I need to do to fix this issue? Any ideas?
    Okay for the sake of posterity here's the fix that I've found:

    Modify mm_cfg.py:
    DEFAULT_URL_PATTERN = 'https://%s/mailman/'
    [NOTE the 's' in 'https']

    Then run:
    $prefix/bin/withlist -l -a -r fix_url

    [This is to fix the URL's in any lists you've created.]

    I then reenabled my rewrite condition in httpd.conf. Then restarted Apache.

    As the saying goes I should have RTFM before posting, sorry about that.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedJul 25, '06 at 8:34p
activeJul 25, '06 at 10:14p
posts7
users2
websitelist.org

2 users in discussion

Tony Stocker: 5 posts Dragon: 2 posts

People

Translate

site design / logo © 2022 Grokbase