FAQ

Has anyone set up mailman and Postfix on their RedHat box??
I am getting the dreaded GID error,
Mar 11 11:21:01 cascade postfix/local[8621]: A84803EF5:
to=<test at cascade.off.ournet.com.au>, relay=local, delay=1,
status=bounced
(Command died with status 2: "/var/mailman/mail/wrapper post test". Command
output: Failure to exec script. WANTED gid 12, GOT gid 99. (Reconfigure to
take 99?)
And have read the mailman help file as to the fix, It suggests rebuilding
mailman with;
./configure --with-mail-gid=thegid
thegid = the result of running;
% python -c'import os; print os.getgid()
as the mailman user (which if I do this, I get thegidA
(Which I am suspect about as 12 or 99 != 41)
If I am installing from a Redhat RPM, I cannot do this... I have altered
the postfix option of:
default_privs = mail
(which is the gid of 12) and this allows me to use mailman, but it may have
some effect on postfix and privs??
Can anyone enlighten me to if this is ok, or if I need to un-install the
RPM and install mailman from source and configure with my options.
Thanks
Brian
-----------------------------------------
Hi Brian, I had also this problem on SUSE (wanted GID 67, GOT 65533), where
65533 was NOBODY user (very strange , no?), but I just edited
/etc/postfix/main.cf and included:

default_privs: mailman

Man, this DESTROYED the ?dread GID? mith :) All is working perfectly! This
is because POSTFIX sometimes messes with GIDs (God knows why!!), thats
because DEFAULT values for GID are created in other areas of the system (I
tried to UNINSTALL, reboot and then REINSTALL postfix again TO NO AVAIL) :(

I?m just putting this add on because there was NO responses from other
forums (I discovered this BY MYSELF), so now people can search for ?GID
errors SUSE?, for example, and try other names, not just mail and mailman.
Thanks , thanks really :) We dont need to reinvent the well :).
--
View this message in context: http://www.nabble.com/Postfix-%2B-Mailman-with-GID-errors---fixed%21-tf1897988.html#a5192191
Sent from the Mailman - Users forum at Nabble.com.

Search Discussions

  • Ivan Aedler at Jul 6, 2006 at 11:52 am
    Yesterday, it also threw the error, while accessing my mail list in FIREFOX:
    ------------------------------
    Mailman CGI error!!!
    The Mailman CGI wrapper encountered a fatal error. This entry is being
    stored in your syslog:

    Failure to exec script. WANTED gid 67, GOT gid 8
    -----------------------------
    The fix: just edit /etc/mailman/mailman.mail-gid
    /etc/mailman/mailman.cgi-gid

    and put the expected GID.
    Just dont ask me why..... I just restarted my PC when this problem occurred
    for the first time. But now it? documented :)
    --
    View this message in context: http://www.nabble.com/Postfix-%2B-Mailman-with-GID-errors---fixed%21-tf1897988.html#a5198176
    Sent from the Mailman - Users forum at Nabble.com.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedJul 6, '06 at 12:58a
activeJul 6, '06 at 11:52a
posts2
users1
websitelist.org

1 user in discussion

Ivan Aedler: 2 posts

People

Translate

site design / logo © 2022 Grokbase