FAQ
I have more than a dozen lists running in Mailman 2.1.4 on my Xserve,
all running fine, except that now on just one list I'm unable to
access the admin pages. The list is still sending messages okay,
individual subscribers can access their subscription options,
archives are fine, etc. -- but I get an error after trying to sign in
with my admin password. It's processing the admin password, because
if I intentionally type the wrong one, I get the authorization failed
message. But if I type the correct password, I get a "Bug in Mailman
2.1.4" message -- starts out like this:

------------begin copy------------

Bug in Mailman version 2.1.4

We're sorry, we hit a bug!
If you would like to help us identify the problem, please email a
copy of this page to the webmaster for this site with a description
of what happened. Thanks!
Traceback:

Traceback (most recent call last):
File "/usr/share/mailman/scripts/driver", line 87, in run_main
main()
File "/usr/share/mailman/Mailman/Cgi/admin.py", line 200, in main
mlist.Save()
File "/usr/share/mailman/Mailman/MailList.py", line 526, in Save
self.__save(dict)
File "/usr/share/mailman/Mailman/MailList.py", line 498, in __save
os.unlink(fname_last)
OSError: [Errno 22] Invalid argument:
'/private/var/mailman/lists/disciples/config.pck.last'

------------end copy------------

Any suggestions on working around this? Admin pages for all other
lists on the same server are working fine!

Bob
--

======================================================================
Bob Bergey -- 215-527-1048 -- Perkasie, PA <mailto:bob at bergey.net>
Internet Services for the Printing Industry <http://www.printweb.org/>
Web Hosting & E-Mail Services: BERGEY.NET <http://www.bergey.net/>
======================================================================

Search Discussions

  • Mark Sapiro at Jun 13, 2006 at 5:21 pm

    Bob Bergey wrote:
    I have more than a dozen lists running in Mailman 2.1.4 on my Xserve,
    all running fine, except that now on just one list I'm unable to
    access the admin pages. The list is still sending messages okay,
    individual subscribers can access their subscription options,
    archives are fine, etc. -- but I get an error after trying to sign in
    with my admin password. It's processing the admin password, because
    if I intentionally type the wrong one, I get the authorization failed
    message. But if I type the correct password, I get a "Bug in Mailman
    2.1.4" message -- starts out like this:

    ------------begin copy------------

    Bug in Mailman version 2.1.4

    We're sorry, we hit a bug!
    If you would like to help us identify the problem, please email a
    copy of this page to the webmaster for this site with a description
    of what happened. Thanks!
    Traceback:

    Traceback (most recent call last):
    File "/usr/share/mailman/scripts/driver", line 87, in run_main
    main()
    File "/usr/share/mailman/Mailman/Cgi/admin.py", line 200, in main
    mlist.Save()
    File "/usr/share/mailman/Mailman/MailList.py", line 526, in Save
    self.__save(dict)
    File "/usr/share/mailman/Mailman/MailList.py", line 498, in __save
    os.unlink(fname_last)
    OSError: [Errno 22] Invalid argument:
    '/private/var/mailman/lists/disciples/config.pck.last'

    ------------end copy------------

    Is there a /private/var/mailman/lists/disciples/config.pck.last file?
    What are its permissions? Are they the same as
    /private/var/mailman/lists/disciples/config.pck? How do these compare
    with another list?

    Mailman is in the process of saving the list config. It is in the last
    step. It has saved the config to config.pck.tmp.host.pid and is trying
    to do the equivalent of

    rm config.pck.last
    mv config.pck config.pck.last
    mv config.pck.tmp.host.pid config.pck

    and it gets the exception on the first step.

    Are there more errors like this in Mailman's error log?

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Patrick Bogen at Jun 14, 2006 at 11:02 pm

    On 6/13/06, Bob Bergey wrote:
    At 11:57 AM -0500 on 6/13/06, Patrick Bogen wrote:
    http://rentzsch.com/macosx/mailmanWorkaround
    Wow -- that's exactly my problem! Thanks for the tip -- I'll try it
    later today.
    Let us know how it goes.
    I'm a little scared to upgrade -- still running OS 10.3.9 on my
    Xserve, and have been reluctant to upgrade Mailman, mainly because
    I'm just not familiar with the process. Have you upgraded Mailman on
    an Xserve, and had any problems?
    I haven't; all of our machines are Debian GNU/Linux. The upgrade
    should be fairly standard, but don't take my word for it. If you can,
    it might be wiser to try the upgrade on a different machine (another,
    similar Xserve, but one you don't rely on for a functional mailman) to
    get the feel of it.

    P.S., Please CC the list on all replies.

    --
    - Patrick Bogen

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedJun 13, '06 at 4:51p
activeJun 14, '06 at 11:02p
posts3
users3
websitelist.org

People

Translate

site design / logo © 2021 Grokbase