FAQ
mailman-2.1.7
apache 2.2.0

Okay I just upgrade from apache 1.3.x to apache 2.2.0 and arriving at a
permissions problem when viewing pipermail mailman directories:


---s nip ---

You don't have permission to access /pipermail/garbled-name/ on this server.

--- snip ---


Here is what I've done so far:

---- apache httpd.conf file ----

int he virtual host stanza

ScriptAlias /mailman/ /usr/home/mailman/cgi-bin/
Alias /pipermail/ /usr/home/mailman/archives/public/
Alias /icons/ /usr/home/mailman/icons/
<Directory /usr/home/mailman/archives/public/>
Options +FollowSymlinks
</Directory>

---s nip ---

restarted apache.

and I ran bin/check_perms

--- snip----

# /usr/home/mailman/bin/check_perms -f
No problems found

=---- snip ----


what else could be the problem here?

cheers,

Noah

Search Discussions

  • Odhiambo Washington at Apr 20, 2006 at 8:59 pm

    * On 20/04/06 07:25 -0800, Noah wrote:
    mailman-2.1.7
    apache 2.2.0

    Okay I just upgrade from apache 1.3.x to apache 2.2.0 and arriving at a
    permissions problem when viewing pipermail mailman directories:


    ---s nip ---

    You don't have permission to access /pipermail/garbled-name/ on this server.

    --- snip ---


    Here is what I've done so far:

    ---- apache httpd.conf file ----

    int he virtual host stanza

    ScriptAlias /mailman/ /usr/home/mailman/cgi-bin/
    Alias /pipermail/ /usr/home/mailman/archives/public/
    Alias /icons/ /usr/home/mailman/icons/
    <Directory /usr/home/mailman/archives/public/>
    Options +FollowSymlinks
    ==============> Allow from all
    </Directory>
    Add that, restart Apache and cross your fingers.....


    cheers
    - wash
    +----------------------------------+-----------------------------------------+
    Odhiambo Washington . WANANCHI ONLINE LTD (Nairobi, KE) |
    wash () WANANCHI ! com . 1ere Etage, Loita Hse, Loita St., |
    GSM: (+254) 722 743 223 . # 10286, 00100 NAIROBI |
    GSM: (+254) 733 744 121 . (+254) 020 313 985 - 9 |
    +---------------------------------+------------------------------------------+
    "Oh My God! They killed init! You Bastards!"
    --from a /. post
  • Noah at Apr 20, 2006 at 9:26 pm
    On Thu, 20 Apr 2006 23:59:04 +0300, Odhiambo Washington wrote
    * On 20/04/06 07:25 -0800, Noah wrote:
    mailman-2.1.7
    apache 2.2.0

    Okay I just upgrade from apache 1.3.x to apache 2.2.0 and arriving
    at a | permissions problem when viewing pipermail mailman
    directories: | | | ---s nip --- | | You don't have permission to
    access /pipermail/garbled-name/ on this server. | | --- snip --- | |
    Here is what I've done so far: | | ---- apache httpd.conf file ----
    int he virtual host stanza | | ScriptAlias /mailman/
    /usr/home/mailman/cgi-bin/ | Alias /pipermail/
    /usr/home/mailman/archives/public/
    Alias /icons/ /usr/home/mailman/icons/
    <Directory /usr/home/mailman/archives/public/>
    Options +FollowSymlinks
    ==============> Allow from all
    </Directory>
    Add that, restart Apache and cross your fingers.....


    still an apache error:

    --- snip ----


    Forbidden

    You don't have permission to access /pipermail/dir_garbled/ on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an
    ErrorDocument to handle the request.
    Apache/2.2.0 mod_ssl/2.2.0 OpenSSL/0.9.8a DAV/2 PHP/4.4.2 Server at
    garbled.domain.com Port 80


    ---- snip ----


    cheers,

    Noah


    cheers
    - wash
    +----------------------------------+---------------------------------
    --------+ Odhiambo Washington . WANANCHI ONLINE LTD
    (Nairobi, KE) | wash () WANANCHI ! com . 1ere Etage, Loita Hse,
    Loita St., | GSM: (+254) 722 743 223 . # 10286, 00100 NAIROBI
    GSM: (+254) 733 744 121 . (+254) 020 313 985 - 9
    +---------------------------------+----------------------------
    --------------+ "Oh My God! They killed init! You Bastards!"
    --from a /. post
  • Patrick Bogen at Apr 21, 2006 at 2:38 pm

    On 4/20/06, Noah wrote:
    Additionally, a 403 Forbidden error was encountered while trying to use an
    ErrorDocument to handle the request.
    It sounds like you have more problems with your Apache install thank
    you think. Is it running under the same user/group as before?
    Did you install from a distribution package, or build from source?
    What do the permissions look like on the pipermail directory in question?

    --
    - Patrick Bogen
  • Mark Sapiro at Apr 21, 2006 at 6:51 pm

    Noah wrote:
    Forbidden

    You don't have permission to access /pipermail/dir_garbled/ on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an
    ErrorDocument to handle the request.
    Apache/2.2.0 mod_ssl/2.2.0 OpenSSL/0.9.8a DAV/2 PHP/4.4.2 Server at
    garbled.domain.com Port 80

    Is there anything more specific in Apache's error_log?

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Noah at Apr 22, 2006 at 12:38 am
    On Fri, 21 Apr 2006 11:51:17 -0700, Mark Sapiro wrote
    Noah wrote:
    Forbidden

    You don't have permission to access /pipermail/dir_garbled/ on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an
    ErrorDocument to handle the request.
    Apache/2.2.0 mod_ssl/2.2.0 OpenSSL/0.9.8a DAV/2 PHP/4.4.2 Server at
    garbled.domain.com Port 80
    Is there anything more specific in Apache's error_log?

    Yeah Mark,

    --- snip ----

    Symbolic link not allowed or link target not accessible:
    /usr/home/mailman/archives/public/news, referer:
    http://domain.garbled.com/mailman/listinfo/news

    --- snip ---

    cllues please?





    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Mark Sapiro at Apr 22, 2006 at 1:00 am

    Noah wrote:
    Symbolic link not allowed or link target not accessible:
    /usr/home/mailman/archives/public/news, referer:
    http://domain.garbled.com/mailman/listinfo/news

    In the OP you said you had for the appropriate virtual host

    <Directory /usr/home/mailman/archives/public/>
    Options +FollowSymlinks
    </Directory>

    So symlinks should be allowed. That leaves existence and permissions:

    Is /usr/home/mailman/archives/public/news a symlink to
    /usr/home/mailman/archives/private/news?

    Is /usr/home/mailman/archives/private/news and its subordinates world
    readable and in the case of directories searchable, i.e. do directory
    permissions (other than the news/database directory) look like

    drwxrwsr-x

    and file permissions look like

    -rw-rw-r--


    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Mark Sapiro at Apr 22, 2006 at 1:48 am

    Noah wrote:
    lets look at the dirs involved:

    drwxrws--- 101 mailman mailman 2560 Apr 13 17:49
    /usr/local/mailman/archives/private
    # ls -ld /usr/local/mailman/archives/private/list
    drwxrwsr-x 50 www www 4096 Apr 17 21:40
    /usr/local/mailman/archives/private/list
    This should be owned by mailman:mailman or you won't be able to access
    it through the private wrapper. Not a problem as long as the archive
    is public, and not the cause of your current problem, but it would be
    good to fix it.


    drwxrwsr-x 2 mailman mailman 1536 Apr 13 17:49
    /usr/local/mailman/archives/public
    lrwxrwxrwx 1 root mailman 49 Jan 11 2003
    /usr/local/mailman/archives/public/list -> /home/mailman/archives/private/list
    So it looks like the symlink points to the wrong directory. S/b either
    /usr/local/mailman/archives/private/list or following the symlink
    below, /usr/home/mailman/archives/private/list, but what's
    /home/mailman/archives/private/list?

    lrwxr-xr-x 1 root wheel 18 Apr 4 2004 /usr/home/mailman -> /usr/local/mailman
    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Noah at Apr 22, 2006 at 2:02 am
    On Fri, 21 Apr 2006 18:48:38 -0700, Mark Sapiro wrote
    Noah wrote:
    lets look at the dirs involved:

    drwxrws--- 101 mailman mailman 2560 Apr 13 17:49
    /usr/local/mailman/archives/private
    # ls -ld /usr/local/mailman/archives/private/list
    drwxrwsr-x 50 www www 4096 Apr 17 21:40
    /usr/local/mailman/archives/private/list
    This should be owned by mailman:mailman or you won't be able to
    access it through the private wrapper. Not a problem as long as the archive
    is public, and not the cause of your current problem, but it would be
    good to fix it.
    okay Mark:

    check_perms fixed now it does not report any errors:


    ---=- snip ----
    # /usr/local/mailman/bin/check_perms -f
    No problems found
    --- snip ---
    drwxrwsr-x 2 mailman mailman 1536 Apr 13 17:49
    /usr/local/mailman/archives/public
    lrwxrwxrwx 1 root mailman 49 Jan 11 2003
    /usr/local/mailman/archives/public/list -> /home/mailman/archives/private/list
    So it looks like the symlink points to the wrong directory. S/b
    either /usr/local/mailman/archives/private/list or following the symlink
    below, /usr/home/mailman/archives/private/list, but what's
    /home/mailman/archives/private/list?

    okay look - /home symlinked to /usr/home
    lrwxr-xr-x 1 root wheel 9 Jan 10 2003 home -> /usr/home

    now I changed this:

    lrwxr-xr-x 1 root mailman 54 Apr 21 19:00
    /usr/local/mailman/archives/public/list ->
    /usr/local/mailman/archives/private/list



    lrwxr-xr-x 1 root wheel 18 Apr 4 2004 /usr/home/mailman ->
    /usr/local/mailman
    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Mark Sapiro at Apr 22, 2006 at 2:37 am

    Noah wrote:
    now I changed this:

    lrwxr-xr-x 1 root mailman 54 Apr 21 19:00
    /usr/local/mailman/archives/public/list ->
    /usr/local/mailman/archives/private/list
    And do you still have the same error in the apache error_log?

    If so, this would seem to be an Apache configuration issue rather than
    a Mailman issue. I don't know what the problem might be, but you might
    get more help from an Apache support resource.

    I note that <http://httpd.apache.org/docs/2.0/mod/core.html#options>
    says

    FollowSymLinks
    The server will follow symbolic links in this directory.

    ...

    Note also, that this option gets ignored if set inside a <Location>
    section.

    Could that be the problem?

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Noah at Apr 22, 2006 at 3:43 am
    On Fri, 21 Apr 2006 19:37:43 -0700, Mark Sapiro wrote
    Noah wrote:
    now I changed this:

    lrwxr-xr-x 1 root mailman 54 Apr 21 19:00
    /usr/local/mailman/archives/public/list ->
    /usr/local/mailman/archives/private/list
    And do you still have the same error in the apache error_log?

    Hey Mark,

    yuppers.

    If so, this would seem to be an Apache configuration issue rather
    than a Mailman issue. I don't know what the problem might be, but
    you might get more help from an Apache support resource.

    I note that <http://httpd.apache.org/docs/2.0/mod/core.html#options>
    says

    FollowSymLinks
    The server will follow symbolic links in this directory.

    ...

    Note also, that this option gets ignored if set inside a <Location>
    section.

    Could that be the problem?

    Yeah I found some <Location> sections in the config file but the
    FollowSymLinks option is not present in those sections:

    grep Location *
    httpd.<garbled>.conf:<Location /fnord/server-status>
    httpd.<garbled>.conf:</Location>
    httpd.<garbled>.conf:<Location /fnord/server-info>
    httpd.<garbled>.conf:</Location>
    httpd.<garbled>.conf:<Location /cgi-bin/phf*>
    httpd.<garbled>.conf:</Location>


    thanks for all your help. if you have any other ideas please dont hesitate to
    send them.

    I am going to get on the apache mail list and ask again because the apache
    docs are quite thorough but I still cant figure it out after reading them.

    cheers,

    Noah



    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Noah at Apr 22, 2006 at 11:49 pm
    mailman-2.1.7
    apache 2.2.0
    FreeBSD-4.11

    Okay I just upgrade from apache 1.3.x to apache 2.2.0 and arriving at a
    permissions problem when viewing pipermail mailman directories.

    I've asked already but Maybe somebody else on the list can help. I apologize
    for the duality but I cant figure it out.


    --- Browser error message ---

    You don't have permission to access /pipermail/list/ on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an
    ErrorDocument to handle the request.

    --- snip ---

    Here is what apache places in the /usr/local/www/logs/domain.name/error_log

    --- snip ---

    Symbolic link not allowed or link target not accessible:
    /usr/home/mailman/archives/public/list, referer:
    http://hostname.garbled.com/mailman/listinfo/list

    ---- snip ----


    Here is what I've done so far:

    ---- apache httpd.conf file ----

    in the virtual host stanza for the particular domain:

    ScriptAlias /mailman/ /usr/local/mailman/cgi-bin/
    Alias /pipermail/ /usr/local/mailman/archives/public/
    Alias /icons/ /usr/local/mailman/icons/

    <Directory /usr/local/mailman/archives/public/>
    Options All
    Order allow,deny
    Allow from all
    </Directory>

    <Directory /usr/home/mailman/archives/public/>
    Options All
    Order allow,deny
    Allow from all
    </Directory>

    <Directory /usr/local/mailman/archives/private/>
    Options +FollowSymLinks
    Order allow,deny
    Allow from all
    </Directory>


    --- snip ---

    then restarted apache.

    --- snip ---

    looks like the directories have proper permissions:
    typhoon# ls -ld /usr/local/mailman/archives/private
    drwxrws--- 103 mailman mailman 2560 Apr 21 21:49
    /usr/local/mailman/archives/private
    typhoon# ls -ld /usr/local/mailman/archives/public/
    drwxrwsr-x 2 mailman mailman 1536 Apr 21 21:49
    /usr/local/mailman/archives/public/
    typhoon# ls -ld /usr/local/mailman/archives/public/list
    lrwxr-xr-x 1 root mailman 54 Apr 21 19:00
    /usr/local/mailman/archives/public/list ->
    /usr/local/mailman/archives/private/list
    typhoon# ls -ld /usr/local/mailman/archives/private/list
    drwxrwsr-x 50 www mailman 4096 Apr 21 18:34
    /usr/local/mailman/archives/private/list

    --- snip ---



    what else could be the problem here?

    cheers,

    Noah

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedApr 20, '06 at 3:25p
activeApr 22, '06 at 11:49p
posts12
users4
websitelist.org

People

Translate

site design / logo © 2022 Grokbase