FAQ
Hi All

This is my first post to the list but I've been lurking for a while.
I'm running Mailman 2.1.5 on a debian sarge box with exim 4, apache 1.3
etc. at home. I also have an account with a hosting company which
provides mailman 2.1.5 lists and a fairly standard mailman control
interface.
My home setup runs fine and so far I've had no problems with the couple
of test lists set up on the host.
What I want to do is to set up a list with the host and forward emails
received there to a list on my home system purely to provide a backup
archive. For test purposes I'm only using my home setup at the moment.

I've created a main list (main at domain) and an archive list
(archive at domain) and added archive at domain to main at domain member list.

archive at domain has no members but in the privacy options /senderfilters
I've added main at domain to the "List of non-member addresses whose
postings should be automatically accepted" section.

So far so good.

I post to main at domain and the post goes out to all members including
archive at domain but there it gets held for approval by the list admin
(i.e. me). The reason given is:

"Blind carbon copies or other implicit destinations are not allowed. Try
reposting your message by explicitly including the list address in the
To: or Cc: fields."

I can pass it through to the list manually but would prefer it to go
through automatically as I intend to do this several lists.
Does anyone have any ideas as to how I can do this. I have access to the
python source on my machine so I can modify if need be.

Apologies if the detail above is a bit excessive.

Cheers


Horse

Search Discussions

  • Mark Sapiro at Oct 29, 2005 at 12:19 am

    Horse wrote:
    I post to main at domain and the post goes out to all members including
    archive at domain but there it gets held for approval by the list admin
    (i.e. me). The reason given is:

    "Blind carbon copies or other implicit destinations are not allowed. Try
    reposting your message by explicitly including the list address in the
    To: or Cc: fields."

    In the list configuration for the archive list on, Privacy
    options...->Recipient filters, put main at domain in acceptable_aliases.
    You could also just set require_explicit_destination Off, but the
    alias is better.

    Also, on the subscription options for the archive at domain subscription
    to the main list, be sure to set "Get password reminder email for this
    list?" to No.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Jared Rimer at Oct 29, 2005 at 12:19 am
    Horse,
    Go to privacy, I don't remember if its sender or recipient
    and turn off implicit destination.
    At 17:08 10/28/2005, you wrote:
    Hi All

    This is my first post to the list but I've been lurking for a while.
    I'm running Mailman 2.1.5 on a debian sarge box with exim 4, apache 1.3
    etc. at home. I also have an account with a hosting company which
    provides mailman 2.1.5 lists and a fairly standard mailman control
    interface.
    My home setup runs fine and so far I've had no problems with the couple
    of test lists set up on the host.
    What I want to do is to set up a list with the host and forward emails
    received there to a list on my home system purely to provide a backup
    archive. For test purposes I'm only using my home setup at the moment.

    I've created a main list (main at domain) and an archive list
    (archive at domain) and added archive at domain to main at domain member list.

    archive at domain has no members but in the privacy options /senderfilters
    I've added main at domain to the "List of non-member addresses whose
    postings should be automatically accepted" section.

    So far so good.

    I post to main at domain and the post goes out to all members including
    archive at domain but there it gets held for approval by the list admin
    (i.e. me). The reason given is:

    "Blind carbon copies or other implicit destinations are not allowed. Try
    reposting your message by explicitly including the list address in the
    To: or Cc: fields."

    I can pass it through to the list manually but would prefer it to go
    through automatically as I intend to do this several lists.
    Does anyone have any ideas as to how I can do this. I have access to the
    python source on my machine so I can modify if need be.

    Apologies if the detail above is a bit excessive.

    Cheers


    Horse
    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/
    Unsubscribe:
    http://mail.python.org/mailman/options/mailman-users/jrimer%40tagline.cc

    Security Policy:
    http://www.python.org/cgi-bin/faqw-mm.py?req=show&amp;file=faq01.027.htp
    Jared Rimer
    Business website: http://www.superior-software.com/support
    Personal Website: http://www.asmodean.net/jrimer
    Music Education Network for the Visually Impaired http://menvi.org a
    service done through Superior Software level one
    WBBY Internet Radio and All In Play team up. Learn more
    http://www.menvi.org/allinplay
    WBBY Internet Radio: www.wbby.us
  • Horse at Oct 31, 2005 at 12:12 am
    Hi again

    Apologies if this is another dumb question.
    The fix below works fine if I set "General Options / Hide the sender of
    a message, replacing it with the list address" to 'yes' so that the list
    name appears in the 'From:' field, but if I set it to 'no' so that the
    'From:' field is the name of the member then again it gets held for
    moderator approval. Is there some way of getting mailman to pass posts
    through based on either the 'Reply To:' or the 'To' field.

    Thanks in advance


    Horse


    Jared Rimer wrote:
    Horse,
    Go to privacy, I don't remember if its sender or recipient
    and turn off implicit destination.
    At 17:08 10/28/2005, you wrote:

    Hi All

    This is my first post to the list but I've been lurking for a while.
    I'm running Mailman 2.1.5 on a debian sarge box with exim 4, apache 1.3
    etc. at home. I also have an account with a hosting company which
    provides mailman 2.1.5 lists and a fairly standard mailman control
    interface.
    My home setup runs fine and so far I've had no problems with the couple
    of test lists set up on the host.
    What I want to do is to set up a list with the host and forward emails
    received there to a list on my home system purely to provide a backup
    archive. For test purposes I'm only using my home setup at the moment.

    I've created a main list (main at domain) and an archive list
    (archive at domain) and added archive at domain to main at domain member list.

    archive at domain has no members but in the privacy options /senderfilters
    I've added main at domain to the "List of non-member addresses whose
    postings should be automatically accepted" section.

    So far so good.

    I post to main at domain and the post goes out to all members including
    archive at domain but there it gets held for approval by the list admin
    (i.e. me). The reason given is:

    "Blind carbon copies or other implicit destinations are not allowed. Try
    reposting your message by explicitly including the list address in the
    To: or Cc: fields."

    I can pass it through to the list manually but would prefer it to go
    through automatically as I intend to do this several lists.
    Does anyone have any ideas as to how I can do this. I have access to the
    python source on my machine so I can modify if need be.

    Apologies if the detail above is a bit excessive.

    Cheers


    Horse
    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/
    Unsubscribe:
    http://mail.python.org/mailman/options/mailman-users/jrimer%40tagline.cc

    Security Policy:
    http://www.python.org/cgi-bin/faqw-mm.py?req=show&amp;file=faq01.027.htp

    Jared Rimer
    Business website: http://www.superior-software.com/support
    Personal Website: http://www.asmodean.net/jrimer
    Music Education Network for the Visually Impaired http://menvi.org a
    service done through Superior Software level one
    WBBY Internet Radio and All In Play team up. Learn more
    http://www.menvi.org/allinplay
    WBBY Internet Radio: www.wbby.us

    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/
    Unsubscribe: http://mail.python.org/mailman/options/mailman-users/horse%40darkstar.uk.net

    Security Policy: http://www.python.org/cgi-bin/faqw-mm.py?req=show&amp;file=faq01.027.htp
  • Mark Sapiro at Oct 31, 2005 at 2:08 am

    Horse wrote:
    Apologies if this is another dumb question.
    The fix below works fine if I set "General Options / Hide the sender of
    a message, replacing it with the list address" to 'yes' so that the list
    name appears in the 'From:' field, but if I set it to 'no' so that the
    'From:' field is the name of the member then again it gets held for
    moderator approval. Is there some way of getting mailman to pass posts
    through based on either the 'Reply To:' or the 'To' field.

    You can't use the To:

    If you have a fixed Reply-To: on messages from the main list, you
    should be able to make that address a member of the archive list with
    delivery disabled and have posts from the main list accepted by the
    archive list.

    There are at least two other things that can be done in your particular
    case, i.e. main list on a host service, archive list on your own box.

    1) you can set USE_ENVELOPE_SENDER = Yes on the archive box. The
    envelope sender of the posts to be archived will be
    main-bounces at domain. You can make that address a list member with
    delivery disabled and the posts should be accepted. Actually, this
    shouldn't even be necessary as long as SENDER_HEADERS, which is by
    default, ('from', None, 'reply-to', 'sender') is not changed. The
    default setting of SENDER_HEADERS means that a post should be accepted
    as long as one of From:, envelope sender, Reply-To: or Sender: is a
    list member.


    2) you can open the archive list to anyone by setting Privacy
    options...->Sender filters->generic_nonmember_action to Accept. I
    don't actually suggest this as it opens the archive to spam.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Horse at Oct 31, 2005 at 2:34 am
    Cheers Mark

    Initial test with suggestion 1 is looking good.
    I think it may be that a few more tweaks and it'll be there.

    Many thanks


    Horse



    Mark Sapiro wrote:
    Horse wrote:
    Apologies if this is another dumb question.
    The fix below works fine if I set "General Options / Hide the sender of
    a message, replacing it with the list address" to 'yes' so that the list
    name appears in the 'From:' field, but if I set it to 'no' so that the
    'From:' field is the name of the member then again it gets held for
    moderator approval. Is there some way of getting mailman to pass posts
    through based on either the 'Reply To:' or the 'To' field.


    You can't use the To:

    If you have a fixed Reply-To: on messages from the main list, you
    should be able to make that address a member of the archive list with
    delivery disabled and have posts from the main list accepted by the
    archive list.

    There are at least two other things that can be done in your particular
    case, i.e. main list on a host service, archive list on your own box.

    1) you can set USE_ENVELOPE_SENDER = Yes on the archive box. The
    envelope sender of the posts to be archived will be
    main-bounces at domain. You can make that address a list member with
    delivery disabled and the posts should be accepted. Actually, this
    shouldn't even be necessary as long as SENDER_HEADERS, which is by
    default, ('from', None, 'reply-to', 'sender') is not changed. The
    default setting of SENDER_HEADERS means that a post should be accepted
    as long as one of From:, envelope sender, Reply-To: or Sender: is a
    list member.


    2) you can open the archive list to anyone by setting Privacy
    options...->Sender filters->generic_nonmember_action to Accept. I
    don't actually suggest this as it opens the archive to spam.
  • Horse at Oct 29, 2005 at 9:37 am
    Mark, Jared

    Thanks for the suggestions - they worked perfectly. The setup now works
    just as I wanted it to.

    Many thanks


    Horse



    Jared Rimer wrote:
    Horse,
    Go to privacy, I don't remember if its sender or recipient
    and turn off implicit destination.

    Mark Sapiro wrote:
    Horse wrote:
    >
    I post to main at domain and the post goes out to all members including
    archive at domain but there it gets held for approval by the list admin
    (i.e. me). The reason given is:
    >>
    "Blind carbon copies or other implicit destinations are not allowed. Try
    reposting your message by explicitly including the list address in
    the To: or Cc: fields."
    >
    >
    >
    >
    In the list configuration for the archive list on, Privacy
    options...->Recipient filters, put main at domain in acceptable_aliases.
    You could also just set require_explicit_destination Off, but the
    alias is better. >
    Also, on the subscription options for the archive at domain subscription
    to the main list, be sure to set "Get password reminder email for this
    list?" to No.
    >

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedOct 29, '05 at 12:08a
activeOct 31, '05 at 2:34a
posts7
users3
websitelist.org

3 users in discussion

Horse: 4 posts Mark Sapiro: 2 posts Jared Rimer: 1 post

People

Translate

site design / logo © 2022 Grokbase